Wrong disc number when installing on a system with IDE & SCSI disks

Bug #13430 reported by Jean Schurger on 2005-03-02
6
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Medium
Colin Watson

Bug Description

When i install Hoary array-5, on my system :

I use the SCSI disk for (/) and (/home).
The whole IDE disk is an mounted on other partition.
I boot on the SCSI disk (the bios boot order)

Hoary install well, but it setup grub to use (hd1:0) instead of (hd0:0).

... i'm not sure if there is a rule that says that scsi disks are counted befire
ide one.

Hoeflerb (hoeflerb) wrote :

I had a similar problem when installing on my system. I have an ide disk that I
use for extra storage, but I run my system on a scsi raid array (I boot from scsi).
  1) When running the installer in normal mode, it automatically installed grub
on the ide disk. The installer should have detected multiple disks and asked
which to install grub on. I think it just ignored my scsi disks.
  2) There is an inherent problem with installing on this setup because grub
uses the bios to detect disks, so I'm not sure how easily this can be fixed.
When I install, I boot from my ide cdrom drive. This causes the bios to order
the disks like this: ide (hd0), scsi (hd1-hd5). So if I tell grub to install to
the first scsi disk, it uses (hd1,0) as the root device in its config. But then,
after the installer completes, I reboot off of scsi, the bios reorders the
disks: scsi (hd0), ide (hd1), scsi (hd2-hd5). So now grub doesn't know where to
find the kernel because it is looking in (hd1,0), which is the wrong disk.

I solved this by unplugging the ide disk during installation. A better solution
is desirable, but it will probably require some voodoo because I can't think of
any way for grub-install to know my system is setup this way without asking.

Renzokiller (renzokiller) wrote :

Got the same problem installing breezy. If the ide disk is plugged, and installation on scsi one, you need to change grub for (hd0:0) in order to boot, and change /boot/grub/menu.list too.
Right, it is easier to install without ide disk plugged !

Looks confirmed to me (And also confirmed lately...)

Changed in grub-installer:
status: Unconfirmed → Confirmed

Anyone of you tryed with Dapper to see if it is still an issue?

kuma (sv-imoku) wrote :

Had the same / similar problem with dapper. 1 scsi disk and 3 ide disks on my system. Grub, when used from the ubuntu live-cd or installed ubuntu says scsi disk is hd3, but when i boot grub says scsi disk is hd0.

 Strangely, i think the problem did not appear first time i installed, only after i installed a third OS on my previously empty /dev/hda (primary master IDE drive).

My fix was changing the /boot/grub/menu.lst replacing hd3 with hd0. Wich was really way over my head until i spent a day researching the subject.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.