In UEFI mode, installer crashes if OS is installed on 2nd drive and grub installs successfully but ubiquity doesn't think so

Bug #1303790 reported by Jean-Baptiste Lallement on 2014-04-07
698
This bug affects 88 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Critical
Phillip Susi

Bug Description

Ubuntu Trusty Desktop 20140406 amd64

TEST CASE:
0. Requirement: Create 2 empty disk drives and boot in UEFI mode
1. Boot from an installation media
2. Proceed to the partitioner and select 'Entire Disk' and continue
3. To the question on which disk to install Ubuntu, select '/dev/sdb'
4. Proceed with the rest of the installation

ACTUAL RESULT
The installer crashes when it tries to install grub on /dev/sda

EXPECTED RESULT
Same result than in BIOS mode. If installation of grub fails, there is a dialog explaining what failed and proposes to install grub on another disk.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.17.10
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CasperVersion: 1.339
Date: Mon Apr 7 14:49:05 2014
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140406)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
tags: added: rls-s-incoming
tags: added: rls-t-incoming
removed: rls-s-incoming
Phillip Susi (psusi) wrote :

It looks like partman failed to create the efi system partition.

Exception during installation:
Apr 7 12:48:50 ubuntu /plugininstall.py: Traceback (most recent call last):
Apr 7 12:48:50 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1780, in <module>
Apr 7 12:48:50 ubuntu /plugininstall.py: install.run()
Apr 7 12:48:50 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Apr 7 12:48:50 ubuntu /plugininstall.py: func(self)
Apr 7 12:48:50 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 242, in run
Apr 7 12:48:50 ubuntu /plugininstall.py: self.configure_bootloader()
Apr 7 12:48:50 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1036, in configure_bootloader
Apr 7 12:48:50 ubuntu /plugininstall.py: "GrubInstaller failed with code %d" % ret)
Apr 7 12:48:50 ubuntu /plugininstall.py: ubiquity.install_misc.InstallStepError: GrubInstaller failed with code 1
Apr 7 12:48:50 ubuntu /plugininstall.py:

tags: added: testcase
tags: added: installer-crash
Changed in ubiquity (Ubuntu):
importance: Undecided → High

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) on 2014-05-10
Changed in ubiquity (Ubuntu):
importance: High → Critical
Phillip Susi (psusi) on 2014-06-24
summary: In UEFI mode, installer crashes if OS is installed on 2nd drive and grub
- fails to install on 1rst drive
+ installs successfully but ubiquity doesn't think so
Phillip Susi (psusi) on 2014-07-09
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

I'm not sure this is just UEFI. I'm thought I tried legacy mode too...

The only thing that worked was physically removing the primary drive so that the second was named /dev/sda. Then ubiquity completed without crashing.

Also confirmed in UEFI mode for trusty, utopic and vivid. All of them gave me this installer crash.

Phillip Susi (psusi) wrote :

This only applies to UEFI mode because grub-install ignores its argument and always installs to /boot/EFI. Thus when ubiquity runs grub-install /dev/sda, and /boot/EFI is on /dev/sdb, grub actually installs it to the correct place and the system will boot fine, but ubiquity foolishly tries to inspect /dev/sda and finds that drive has no partition table.

Robin McCorkell (xenopathic) wrote :

It seems that the root cause of the issue is Ubiquity ignoring the target disk and attempting to install GRUB to /dev/sda anyway, so this is a duplicate of #704763

Phillip Susi (psusi) wrote :

It is related only tangentially: ubiquity defaults to /dev/sda, which generally is the right thing to do for bios based systems, but grub-efi is installed to the right place anyhow. The problem is that ubiquity then does its own additional diddling with the disk it thinks grub was installed to, and attributes the failure of this diddling to grub-install. I believe that additional diddling only makes sense for a bios install so should probably be made contingent upon that, but even when it is done and fails, it should not claim that grub-install failed when it didn't.

Wim (wim-mintiens) wrote :

I had the same issue, my SSD was configured on the motherboard as the 3rd device. Trying several times to install Kubuntu 14.10 each time it failed as described above.

I changed on the motherboard the SSD disk to the 1st SATA and rebooted .. without having to re-install .. kubuntu started without a problem.

While installing and receiving the pop-up with the error .. I was not able to send the details ..text box was empty

hope this info helps

Phillip Susi (psusi) on 2015-01-20
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-15.04
Phillip Susi (psusi) on 2015-01-27
affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Changed in grub-installer (Ubuntu):
assignee: nobody → Phillip Susi (psusi)
status: Triaged → In Progress

Unsubscribe
On Jan 27, 2015 4:00 PM, "Phillip Susi" <email address hidden> wrote:

> ** Branch linked: lp:~psusi/ubuntu/vivid/grub-installer/fix-efi-multi-
> disk-installs
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1380980).
> https://bugs.launchpad.net/bugs/1303790
>
> Title:
> In UEFI mode, installer crashes if OS is installed on 2nd drive and
> grub installs successfully but ubiquity doesn't think so
>
> Status in grub-installer package in Ubuntu:
> In Progress
>
> Bug description:
> Ubuntu Trusty Desktop 20140406 amd64
>
> TEST CASE:
> 0. Requirement: Create 2 empty disk drives and boot in UEFI mode
> 1. Boot from an installation media
> 2. Proceed to the partitioner and select 'Entire Disk' and continue
> 3. To the question on which disk to install Ubuntu, select '/dev/sdb'
> 4. Proceed with the rest of the installation
>
> ACTUAL RESULT
> The installer crashes when it tries to install grub on /dev/sda
>
> EXPECTED RESULT
> Same result than in BIOS mode. If installation of grub fails, there is a
> dialog explaining what failed and proposes to install grub on another disk.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: ubiquity 2.17.10
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14.1-0ubuntu1
> Architecture: amd64
> CasperVersion: 1.339
> Date: Mon Apr 7 14:49:05 2014
> InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi
> file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
> LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140406)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubiquity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1303790/+subscriptions
>

Phillip Susi (psusi) wrote :

Nope.

Paulo Molina (polochamps2004) wrote :

^
Thanks for confirming.

PS: Would it also be fixed on RC or Final?

Thank you

Phillip Susi (psusi) wrote :

The fix has not been applied yet.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.78ubuntu28

---------------
grub-installer (1.78ubuntu28) vivid; urgency=medium

  [ Phillip Susi ]
  * Don't try to mark a partition as active, except on grub-pc.
    This was causing failures for grub-efi (LP: #1303790).
 -- Timo Aaltonen <email address hidden> Sat, 04 Apr 2015 16:48:58 +0300

Changed in grub-installer (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers