xubuntu, lubuntu images missing secure boot packages

Bug #1279470 reported by ubuser on 2014-02-12
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned
lubuntu-meta (Ubuntu)
High
Unassigned
xubuntu-meta (Ubuntu)
High
Unassigned

Bug Description

Fresh install of lubuntu 13.10 latest desktop amd64 iso image from USB drive onto blank SSD 120GB, with GPT partition table, fails when there is no internet connection. Same thing happens installing xubuntu 13.10 latest iso image. Subsequently the installer crashes.

I think an install succeeds when there is an internet connection, or when the SSD partition table is MSDOS format instead of GPT. But it seems it "should" be able to install to machine off the internet....

For l/xubuntu installs, the failure starts with an error popup window:

GRUB installation failed
The grub-amd64-signed package failed to install into /target/. Without the GRUB boot loader the installed system will not boot.

The details log says:

Installing the grub2 package
xubuntu ubiquity: E: Unable to locate package shim-signed
xubuntu grub-installer: info: calling 'apt-install grub-efi-amd64-signed' failed.

When I press "OK" on error window and another windo pops up:

"Installer Crashed. We're sorry; the installer crashed. After you close this window ....

After closing the window, sometimes the system hangs, sometimes it tries to send an error report. But since the error happens with no internet connection the error report isn't going to be sent.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.26 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CasperVersion: 1.336ubuntu1
Date: Wed Feb 12 13:29:15 2014
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity quiet splash --
LiveMediaBuild: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

ubuser (ubuser) wrote :
ubuser (ubuser) wrote :

A fresh install with no internet using ubuntu-gnome 13.10 64bit iso image works fine. Comparing the difference between the ubuntu-gnome iso and a xubuntu 13.10 64bit iso image, there are several packages missing from the later:

pool/main/g/grub2-signed/grub-efi-amd64-signed_1.22+2.00-19ubuntu2_amd64.deb
pool/main/s/secureboot-db/secureboot-db_1.1_amd64.deb
pool/main/s/shim-signed/shim-signed_1.3+0.4-0ubuntu3_amd64.deb

If these packages are added to the above xubuntu iso image, and the ./dists/saucy/main/binary-amd64/Packages.gz and ./md5sum.txt files files are updated accordingly then the modified xubuntu install is able to complete without any errors.

As far as I can tell the xubuntu and perhaps lubuntu iso images are simply missing some packages that allow an install without an internet connection to complete successfully.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
summary: - Fresh install from USB, no internet, to gpt blank ssd, fails
+ xubuntu, lubuntu images missing secure boot packages
Dimitri John Ledkov (xnox) wrote :

If those packages are missing from the iso, they need to be seeded, as done similarly on other seeds.
Also probably makes sense to do secure-boot enablement on those iso images.

Changed in grub-installer (Ubuntu):
status: Confirmed → Invalid
Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in lubuntu-meta (Ubuntu):
importance: Undecided → High
Changed in xubuntu-meta (Ubuntu):
importance: Undecided → High
Julien Lavergne (gilir) wrote :

Is there a list somewhere of packages that need to be included (on live seed and / or desktop seed ?) to enable secure boot, and a way to test it ?

Sean Davis (bluesabre) wrote :

I've attached added a branch that fixes this for the Xubuntu seed.

Changed in lubuntu-meta (Ubuntu):
status: Confirmed → Fix Committed
Changed in xubuntu-meta (Ubuntu):
status: Confirmed → Fix Committed
Thomas (t.c) wrote :

I also run in the issue with trusty-server-daily-20140326-amd64.iso

On the front I see: grub install dummy failed.

on tty4 I see:

grub-installer: info: Installing grub on 'dummy'
grub-installer: info: grub-install does not support --no-floppy
grub-installer: info: Running chroot /target grub-install --force
grub-installer: Installing for x86_64-efi platform.
grub-installer: grub-install: warning: Couldn't find physical volume '(null)'. Some modules may be missing from core image...
grub-installer: grub-install: warning:
grub-installer:
grub-installer: Couldn't find physical volume '(null)'. Some modules may be missing from core image...
grub-installer: .
grub-installer: grub-install: error: cannot open `/boot/grub/x86_64-efi/load.cfg`: No such file or directory.
grub-installer: error: Running 'grub-install --force failed.

Sean Davis (bluesabre) wrote :

This has been merged and fixed for xubuntu-default-settings.

Changed in xubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Simon Quigley (tsimonq2) on 2017-11-19
Changed in lubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers