Installation hangs on: grub-mount /dev/sdb1 /var/lib/os-prober/mount

Bug #1059619 reported by Jean-Baptiste Lallement on 2012-10-01
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Quantal desktop on hardware (with BIOS) from USB created with dd.

Ubiquity stops any kind of activity at the end of installation, and the "installation successful" dialog is never displayed. Ubiquity's UI is like frozen but still responsive (I can switch slides in slideshow, open/close the embedded terminal). The last message in the progress bar is "Copying installation logs".

If the machine is rebooted, it boots successfully to the newly installed system despite installation didn't end.

This is reproducible.

Log in debug mode attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.5
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CasperVersion: 1.324
Date: Mon Oct 1 16:09:01 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: rls-q-incoming
description: updated
description: updated
Jean-Baptiste Lallement (jibel) wrote :

Here is the list of processes that where running when Ubiquity was /frozen/

I killed the following process:
23924 grub-mount /dev/sdb1 /var/lib/os-prober/mount

and the final "installation done" dialog appeared immediately.

tags: removed: rls-q-incoming
Changed in grub-installer (Ubuntu Quantal):
importance: Undecided → High
Colin Watson (cjwatson) on 2012-10-03
Changed in grub-installer (Ubuntu Quantal):
milestone: none → ubuntu-12.10
summary: - Installation never ends
+ Installation hangs on: grub-mount /dev/sdb1 /var/lib/os-prober/mount
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

I notice earlier:

  Oct 1 13:59:38 ubuntu ubiquity: grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map.

That's pretty odd in itself; and I wonder if grub-mount deals with that underlying condition rather less well.

Colin Watson (cjwatson) wrote :

I notice that parted also doesn't seem to think that there are any partitions on that disk. So I wonder if it's a consequence of bug 1062737, which we worked around recently?

Jean-Baptiste Lallement (jibel) wrote :

Not reproducible with Quantal Desktop 20121009 and 20121010 on the 2 machines which had this problem.
I'm closing this bug.

Changed in grub-installer (Ubuntu Quantal):
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1059619

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers