Vivid and Utopic Virtualbox guest gets only up to resolution of 640x480

Bug #1368784 reported by Daniel Holbach on 2014-09-12
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
grub-gfxpayload-lists (Ubuntu)
High
Colin Watson

Bug Description

Utopic Virtualbox guest gets only up to resolution of 640x480

This happened with the recent xorg update (2014-09-12).

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xorg 1:7.7+7ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
Uname: Linux 3.16.0-14-generic i686
.tmp.unity.support.test.1:

ApportVersion: 2.14.7-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Sep 12 16:02:55 2014
DistUpgraded: Fresh install
DistroCodename: utopic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationDate: Installed on 2014-09-11 (1 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20140905)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-14-generic root=UUID=d36d2942-0e30-43aa-a306-e8a2bba7985b ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.12+14.10.20140812-0ubuntu1
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.6-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.6-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Fri Sep 12 16:01:26 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Sleep Button KEYBOARD, id 7
 input VirtualBox USB Tablet TOUCHSCREEN, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input ImExPS/2 Generic Explorer Mouse MOUSE, id 10
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.16.0-1ubuntu1

Daniel Holbach (dholbach) wrote :
Robert Hooker (sarvatt) wrote :

[ 12.327] (II) Loading /usr/lib/xorg/modules/drivers/vboxvideo_drv.so
[ 12.327] (II) Module vboxvideo: vendor="Oracle Corporation"
[ 12.327] compiled for 10.15.0, module version = 1.0.1
[ 12.328] Module class: X.Org Video Driver
[ 12.328] ABI class: X.Org Video Driver, version 15.0
[ 12.328] (EE) module ABI major version (15) doesn't match the server's version (18)

The virtualbox driver isn't loading, and it looks like you dont have virtualbox 4.3.14-dfsg-1build1 which is the one that works with it. Is the update available to you?

affects: xorg (Ubuntu) → virtualbox (Ubuntu)
Daniel Holbach (dholbach) wrote :

That's what I have installed.

Daniel Holbach (dholbach) wrote :

I tried a lot of different combinations. In the end it only worked when I had virtualbox-guest-x11 installed on the guest. -dkms and -guest-additions-iso didn't make it work.

Norbert (nrbrtx) wrote :

I can confirm this on todays daily build.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Carla Sella (carla-sella) wrote :

After rebooting a fresh Install of Utopic on Virtualbox I get resolution 640x480, no changes happen if you reinstall Virtualbox guest additions.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1368784

tags: added: iso-testing
Otus (jan-varho) wrote :

Resolution in the live session is fine, it is only after booting to the installed system that it degrades to 640x480.

Norbert (nrbrtx) wrote :

Installed virtualbox-guest-x11 package in Ubuntu Utopic 14.10 final guest and got normal resolution in it.

Elfy (elfy) on 2014-11-09
tags: added: vivid
Changed in virtualbox (Ubuntu):
importance: Undecided → High
Bruce Pieterse (octoquad) wrote :

This is still present with the daily build for 11 Dec on Ubuntu Gnome.

Bruce Pieterse (octoquad) wrote :

This is still present with the vivid alpha 1 image for Ubuntu Gnome. Additionally with LVM encryption, the text is cut off on the left and the right as well as the input box being slightly cut off at the bottom.

amjjawad  (amjjawad) wrote :

Hi,

This has fixed the issue for me:
http://ubuntuforums.org/showthread.php?t=2251116&p=13158092#post13158092

Try that and let me know, please if that did help or not? :)

Tim (darkxst) wrote :

The virtualbox drivers used to be included on the live CD, that doesnt seem to be the case anymore however.

Bruce Pieterse (octoquad) wrote :

Also affects Ubuntu Gnome 14.04.2 with 20150203 build.

tags: added: trusty
gravy45 (gravy45) wrote :

amijawad's solution three posts up fixed the issue for me. (And https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1386005 as well).

summary: - Utopic Virtualbox guest gets only up to resolution of 640x480
+ Vivid and Utopic Virtualbox guest gets only up to resolution of 640x480

After discussing this with Colin Watson in #ubuntu-devel I've found a work around that is more agreeable.

Create '/usr/share/grub-gfxpayload-lists/blicklist/11_virtualbox' with the following content:

    v80eedbeef.*

Run the following to update the blacklist and grub.

    sudo update-grub-gfxpayload
    sudo update-grub

The boot process will now be text only for Virtualbox guests and the default X resolution is 1024x768.

The other benefit of this approach is that if full disk encryption is used, you are now always able to enter your pass phrase. So this technique is also a fix for https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1386005

Colin Watson (cjwatson) on 2015-03-27
affects: virtualbox (Ubuntu) → grub-gfxpayload-lists (Ubuntu)
Changed in grub-gfxpayload-lists (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Download full text (5.8 KiB)

Colin Watson asked that I discuss this issue in #ubuntu-kernel. A log of the IRC discussion is below, as requested by Martin Pitt, and I'll attach a debdiff for 'grub-gfxpayload-lists' in due course:

 Here is what we discussed:

<flexiondotorg> I been discussing https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1368784/ with cjwatson in #ubuntu-devel
<ubot5> Ubuntu bug 1368784 in virtualbox (Ubuntu) "Vivid and Utopic Virtualbox guest gets only up to resolution of 640x480" [High,Confirmed]
<flexiondotorg> I've got the following work around - https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1368784/comments/17
<flexiondotorg> cjwatson is prepared to update grub-gfxpayload-lists if someone here can confirm "fixing" this issue at a kernel level is hopeless.
<flexiondotorg> So, thoughts?
<apw> flexiondotorg, "fixing" at the kernel level, do we know what the issue is ?
<apw> flexiondotorg, the implication of the (admittedly older) comments is that you need virtualbox-guest-x11
<apw> flexiondotorg, and indeed i can confirm that installing the said package does sort things out, who knows what i has in it mind
<apw> seems it has a vbox specific video drivers
<apw> i wonder if they should be being installed by jockey
<flexiondotorg> apw, So the issue is the default resolution when virtualbox-guest-x11 is not installed.
<apw> the default resolution is that offered by the vesa settings i assume ?
<flexiondotorg> apw, The vmware video devices are already blacklisted by grub-gfxpayload-lists
<apw> ok, so then it sounds like whatever this is using now is a candidate for blacklisting ?
<flexiondotorg> apw, Must be. vesa is used by vbox when the guestadditions-x11 is absent.
<apw> so that is a vbox issue really, offering stupid resolutions by default
<flexiondotorg> apw, Since 14.04. Yes.
<flexiondotorg> apw, The 640x480 thing started sometime during 14.10.
<apw> and presumably it does that because they don't care about you if you don't install their video driver
<flexiondotorg> apw, I couldn't possibly comment ;)
<apw> i wonder why i makes a difference to blacklist it in grub though, vesa must be very broken
<apw> and so i would think rather than being a fallback option to blacklist more things in grub, it might
<apw> be the appropriate option instead
<flexiondotorg> apw, It is odd because when booting from the live media, resolution is 1024x768.
<flexiondotorg> But on first install, resolution is 640x480.
<apw> right, that doesn't use grub, nor initialise the display
<apw> it uses syslinux
<flexiondotorg> apw, Indeed.
<apw> grub initialises the display, because you know the vesa modes offered should be the preferred size of your display, so setting it up early makes sense and makes things prettier
<apw> unless your vesa config is spam
<apw> and has "1 1024x768 2 640x480 (default)" in it ... or equiv
<flexiondotorg> So, possibly a regression in what Virtualbox provides.
<apw> but if we are blacklisting for vbox video anyhow, it may well make sense to blacklist everything when vbox is found
<apw> which is what i assume the wildcard you added does
<flexiondotorg> apw, Yes.
<flexiondotorg> Although, AKAIK, vbox have only ever used one device I...

Read more...

Colin Watson (cjwatson) on 2015-03-27
Changed in grub-gfxpayload-lists (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-gfxpayload-lists - 0.7

---------------
grub-gfxpayload-lists (0.7) vivid; urgency=medium

  * Blacklist VirtualBox Graphics Adapter (thanks, Martin Wimpress;
    LP: #1368784).
  * Skip various backup files (LP: #1136592).
 -- Colin Watson <email address hidden> Fri, 27 Mar 2015 17:52:29 +0000

Changed in grub-gfxpayload-lists (Ubuntu):
status: Fix Committed → Fix Released
gravy45 (gravy45) wrote :

The fix is that the resolution will be 1024x768 (max)?

The fix would be that installer correctly recognizes the screen
resolution. 1024x768 would certainly be be better that 640x480 as you
could actually use the virtual installation.

On 04/16/2015 09:15 PM, gravy45 wrote:
> The fix is that the resolution will be 1024x768 (max)?
>

gravy45 (gravy45) wrote :

Thanks @John P. Resolution in the 20150422 build of Ubuntu MATE is 1024x768. I'd prefer that it be able to go full screen like with past Ubuntu releases, and think that would be a true, final fix. That's the question for the folks working on this - what's the intention?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers