groff version is too old

Bug #329375 reported by Miek Gieben on 2009-02-14
4
Affects Status Importance Assigned to Milestone
groff (Debian)
Fix Released
Unknown
groff (Ubuntu)
Wishlist
Colin Watson

Bug Description

Binary package hint: groff

The version of groff included in Ubuntu is from:
% groff -v
GNU groff version 1.18.1
Copyright (C) 2002 Free Software Foundation, Inc.

GNU groff is currently at 1.20.

I would like to see this package upgrade. I've build a quick 'n dirty deb for ubuntu, but a clean/supported
package would be better

Andreas Olsson (andol) wrote :

Does the 1.20 version have any specific features you are missing? Are there any situations where you are limited by the current Ubuntu version of groff?

Changed in groff:
status: New → Incomplete
Miek Gieben (miek) wrote :

Yes, we were running to trouble with psbb macro (I'm no export in groff), but upgrading groff made this
problem(*) go away.

(*) the bounding box of an included eps figure wasn't detected properly, which meant the figure didn't fit on the page.

Colin Watson (cjwatson) wrote :

I know (and have known for a long time). I'm working on it. The delay is due to my desire to avoid regressing support for Japanese speakers. The current package includes a very extensive patch to support CJK languages, which is essentially impossible to forward-port beyond the current version. However, now that 1.20 is out, we're not very far from being able to use a much simpler method to do the same thing, which can actually be accepted upstream. Brian M. Carlson started on this last year, but apparently got stalled; I'm working on finishing the job he started now.

Changed in groff:
assignee: nobody → cjwatson
importance: Undecided → Wishlist
status: Incomplete → Triaged
Changed in groff:
status: Unknown → Confirmed
Changed in groff (Debian):
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

I uploaded groff 1.20.1 to Debian unstable yesterday, and just synced it into Karmic.

Changed in groff (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.