blockdev: ioctl error on BLKRRPART: Device or resource busy

Bug #1905452 reported by dann frazier on 2020-11-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grml2usb (Debian)
Unknown
Unknown
grml2usb (Ubuntu)
Status tracked in Hirsute
Groovy
Undecided
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

[Impact]
grml2usb autopkgtest frequently fail in Ubuntu's CI. For example:
  https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-hirsute/hirsute/amd64/g/grml2usb/20201116_194744_cbe0f@/log.gz

An excerpt showing the error:
2020-11-17 14:14:49,362 Installing default MBR
2020-11-17 14:14:49,363 executing: dd if='/dev/loop0' of='/tmp/tmpa2umy9df' bs=5
12 count=1
2020-11-17 14:14:49,381 executing: dd if=/usr/share/grml2usb/mbr/mbrldr of=/tmp/
tmpa2umy9df bs=439 count=1 conv=notrunc
2020-11-17 14:14:49,385 executing: dd if='/tmp/tmpa2umy9df' of='/dev/loop0' bs=5
12 count=1 conv=notrunc
2020-11-17 14:14:49,401 executing: sync
2020-11-17 14:14:49,433 Probing device via 'blockdev --rereadpt /dev/loop0'
blockdev: ioctl error on BLKRRPART: Device or resource busy
2020-11-17 14:14:49,452 Execution failed: ("Couldn't execute blockdev on '%s' (i
nstall util-linux?)", '/dev/loop0')

[Test Case]
Run the built-in autopkgtest on a cloud instance.

[Where problems might occur]
We may find that the system wide sync is necessary in some other environments, which could cause a similar issue to this one to appear there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grml2usb - 0.18.3ubuntu2

---------------
grml2usb (0.18.3ubuntu2) hirsute; urgency=medium

  * Reformat grml2usb to fix build check.

 -- dann frazier <email address hidden> Tue, 24 Nov 2020 12:11:44 -0700

Changed in grml2usb (Ubuntu Hirsute):
status: New → Fix Released

Hello dann, or anyone else affected,

Accepted grml2usb into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grml2usb/0.18.3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in grml2usb (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-groovy
dann frazier (dannf) wrote :
tags: added: verification-done verification-done-groovy
removed: verification-needed verification-needed-groovy

The verification of the Stable Release Update for grml2usb has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grml2usb - 0.18.3ubuntu0.1

---------------
grml2usb (0.18.3ubuntu0.1) groovy; urgency=medium

  * [272b66e] Fix race condition with blockdev/BLKRRPART due to lack
    of fsync. LP: #1905452.

 -- dann frazier <email address hidden> Tue, 24 Nov 2020 11:58:37 -0700

Changed in grml2usb (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.