Test suite should be enabled during build

Bug #1119781 reported by Michael Terry on 2013-02-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Grilo
Expired
Medium
grilo (Ubuntu)
Undecided
Unassigned

Bug Description

The test suite in grilo is currently not run.

There are several reasons:
 * The check in configure.ac for "enable_tests" is broken and never runs the tests, even when --enable-tests is passed.
 * The test source files themselves are out of date and need some fixing to run with latest grilo.
 * Some tests, like the registry one, seems to require that the package be installed first (which isn't a deal breaker, we can run as a dep8)

Changed in grilo:
importance: Unknown → Medium
status: Unknown → Confirmed

The test suite in grilo is more than broken: as it is right now, it tests mostly nothing.

It is not a matter of activating and fixing the tests: we need to remove those tests and write a new one from scratch.

We have started to add more tests in the case of plugins, but didn't do it yet in grilo core, because it is a bit more complex. We need to write several mockups that helps to test different use cases.

I'm tempted to remove all tests in core to avoid misunderstandings and people trying to activate them.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grilo (Ubuntu):
status: New → Confirmed
Changed in grilo:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.