Please sync Griffith 0.12-1 from Debian (unstable) to Maverick - updated dependency

Bug #607896 reported by Uttam Pal on 2010-07-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Griffith
Undecided
Unassigned
maverick-backports
Won't Fix
Undecided
Unassigned
griffith (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: griffith

everytime i tried to add a movie name in the database, the pop up message said "wait... fetching date from the internet" and after a few moment the program gets terminated automatically.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: griffith 0.11-1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
CheckboxSubmission: 4403f21f5e3272d24aaebcfd9d4f87af
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Tue Jul 20 23:21:01 2010
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: griffith

Uttam Pal (uttam2707) wrote :
Michael (mikej06) wrote :

Please start griffith with the argument "--debug" in a terminal window and post the output here.

Kenny Meyer (knny-myer) on 2010-07-21
summary: - very unstable
+ [lucid] griffith very unstable
Download full text (3.8 KiB)

$ griffith --debug
2010-07-21T13:31:18: DEBUG: Griffith(gconsole:86): Starting Griffith 0.11
2010-07-21T13:31:18: DEBUG: Griffith(gconsole:87): Platform: Linux-2.6.32-23-generic-i686-with-Ubuntu-10.04-lucid (posix)
2010-07-21T13:31:18: DEBUG: Griffith(gconsole:88): Dependencies:
gtk :: 2.17.0
gtk.glade :: 2.17.0
sqlalchemy :: 0.5.8
sqlite3 :: 2.4.1
reportlab :: 2.4
PIL :: True
psycopg2 :: 2.0.13 (dt dec mx ext pq3)
MySQLdb :: 1.2.2.final.0
chardet :: 2.0.1
sqlite :: False
2010-07-21T13:31:18: DEBUG: Griffith(griffith:1467): config file used: /home/uttam/.griffith/griffith.cfg
2010-07-21T13:31:19: INFO: Griffith(initialize:102): Using Griffith directory: /home/uttam/.griffith
/usr/share/griffith/lib/initialize.py:140: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  define_widgets(self, gtk.glade.XML(gf))
/usr/share/griffith/lib/widgets.py:364: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'] = gtk.Tooltips()
/usr/share/griffith/lib/widgets.py:365: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['epdf_reader'], _('Define here the PDF reader you want to use within Griffith. Popular choices are xpdf, gpdf, evince or kpdf. Make sure you have this program installed and working first.'))
/usr/share/griffith/lib/widgets.py:366: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['spell_lang'], _("Here you can define the desired language to use while spell checking some fields. Use you locale setting. For example, to use european portuguese spell checking enter 'pt'"))
/usr/share/griffith/lib/widgets.py:367: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['mail_smtp_server'], _("Use this entry to define the SMTP server you want to use to send e-mails. On *nix systems, 'localhost' should work. Alternatively, you can use your Internet Service Provider's SMTP server address."))
/usr/share/griffith/lib/widgets.py:368: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['mail_email'], _("This is the from e-mail address that should be used to all outgoing e-mail. You want to include your own e-mail address here probably."))
/usr/share/griffith/lib/widgets.py:369: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['mail_smtp_port'], _("Here you can define the smtp server port to use. If you want to use your gmail account service to send e-mails, try to enter '587' here. Default (and the most common one) is '25'"))
/usr/share/griffith/lib/widgets.py:370: DeprecationWarning: Use the new widget gtk.Tooltip
  self.widgets['tooltips'].set_tip(self.widgets['preferences']['mail_use_tls'], _("If you need TLS support, please check this checkbox. This is needed, for example, when using gmail service to send your reminder e-mails."))
/usr/share/griffith/lib/plugins/extensions/__init__.py:70: DeprecationWarning: object.__new__() takes no parameters
  obj = object.__new__(class_, *args, **...

Read more...

Michael (mikej06) wrote :

A segmentation fault occurs. I fear that I can not help because I don't have an Ubuntu installation running.
I maintain griffith mainly for the windows platform. And a segmentation fault is not an error which I can fix generally.
Perhaps there are other users experiencing the same error and who can analyse a dump from a segmentation fault.

This seems even more relevant to Maverick, where python-sqlalchemy has been updated to 0.6. We have to upgrade to 0.12-1 already for this reason, per http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590463. I am going to do a test build to see if 0.12-1 from sid builds on Maverick...

This is confirmed that it builds and runs on maverick from sid 0.12-1. I am renaming the bug appropriately and referencing so it can be triaged...

summary: - [lucid] griffith very unstable
+ Please sync Griffith 0.12-1 from Debian (unstable) to Maverick - updated
+ dependency
Marco Rodrigues (gothicx) wrote :

The sync will also fix Bug 662061.

Changed in griffith (Ubuntu):
status: New → Fix Released
Andrew Mitchell (ajmitch) wrote :

Natty has griffith 0.12.1-1, we'll look at getting this into maverick-backports.

Evan Broder (broder) wrote :

It sounds like the current state of Griffith in Maverick is pretty broken. As a rule, we prefer to backport packages for the sake of new features, not as workarounds for bugs in the stable release.

If it's the case that you can't do even a basic operation (adding a movie to the database) in the current version of Griffith with the current version of SQLAlchemy, then it's possible we should consider the SRU process (https://wiki.ubuntu.com/StableReleaseUpdates)

Can you give a sense of what *can* be done in Maverick's Griffith right now that *doesn't* cause a crash?

Micah Gersten (micahg) wrote :

Marking maverick-backports task incomplete pending response.

Changed in maverick-backports:
status: New → Incomplete
Evan Broder (broder) wrote :

I'm closing the maverick-backports task on this bug due to Ubuntu 10.10 (Maverick Meerkat) no longer being supported.

This bug is being closed by a bot. If you feel the change was made in error, please feel free to re-open the bug. However, backports requests for Ubuntu 10.10 (Maverick Meerkat) are no longer being accepted.

Changed in maverick-backports:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.