Ubuntu

Opening exampleN.ps in Document Viewer causes freeze

Reported by Jo on 2008-03-17
6
Affects Status Importance Assigned to Milestone
gri (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gri

When gri is run on example1.gri and example2.gri, the resulting postscript files cause problems. Gri runs fine (or at least no error messages, and ps is produced). example1.ps and example2.ps do not open using Document Viewer. Document Viewer displays "loading..." and then the cursor begins to move jerkily and other programs running e.g. Rhythmbox are interrupted. This gets worse - if I don't close Document Viewer as soon as cursor starts going wrong, I cannot close anything and eventually computer freezes. If I open the ps files in Gimp, none of this happens, it opens fine.

I am running gri on Ububtu Feisty Fawn (7.04). I have got gri version 2.12.23-1.

Jo (feanelwa) wrote :

A colleague just helped me make this not happen by doing these things:

sudo apt-get install gs-gpl
sudo update-alternatives --set gs /usr/bin/gs-gpl

because he found out it doesn't work with gs-esp (the default) but it does with gs-gpl.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in gri:
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gri:
status: Incomplete → Invalid

Sorry, I have a mountain of things to do at the moment, writing a PhD thesis
among them. When I have some spare time in a few months, I will reopen the
bug report and give the information you asked for.

Best wishes,

Jo Sharp

On Wed, Jan 14, 2009 at 8:58 PM, Pedro Villavicencio <email address hidden>wrote:

> We are closing this bug report because it lacks the information we need
> to investigate the problem, as described in the previous comments.
> Please reopen it if you can give us the missing information, and don't
> hesitate to submit bug reports in the future. To reopen the bug report
> you can click on the current status, under the Status column, and change
> the Status back to New. Thanks again!.
>
> ** Changed in: gri (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> Opening exampleN.ps in Document Viewer causes freeze
> https://bugs.launchpad.net/bugs/203131
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "gri" source package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: gri
>
> When gri is run on example1.gri and example2.gri, the resulting postscript
> files cause problems. Gri runs fine (or at least no error messages, and ps
> is produced). example1.ps and example2.ps do not open using Document
> Viewer. Document Viewer displays "loading..." and then the cursor begins to
> move jerkily and other programs running e.g. Rhythmbox are interrupted. This
> gets worse - if I don't close Document Viewer as soon as cursor starts going
> wrong, I cannot close anything and eventually computer freezes. If I open
> the ps files in Gimp, none of this happens, it opens fine.
>
> I am running gri on Ububtu Feisty Fawn (7.04). I have got gri version
> 2.12.23-1.
>

Jo (feanelwa) wrote :

Can finish supplying the information you asked for now, sorry...thanks for being patient.

The freezing of Document Viewer when opening Example*.ps doesn't happen anymore - now using Ubuntu 8.04. Problem solved!

Changed in gri (Ubuntu):
status: Invalid → New
Thomas Hotz (thotz) on 2012-11-10
Changed in gri (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers