score fails to update during game; remains permanently at 0.06% (as it appears at start)

Bug #1224187 reported by breezer on 2013-09-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
greed (Ubuntu)
Undecided
Unassigned

Bug Description

Reproduction + error details
* Reproducible 100% of time.
* I started the game in a regular Ubuntu "Terminal" window as a normal (non-root) user.
* It immediately and continuously shows the score in the bottom left corner as 0.06% (with a few spaces indent, a "1", a couple of spaces, then "0.06%"), with game board full of digits and the '@' cursor inside the board randomly as expected.
* Move the cursor using numeric keypad or the indicated letter keys; the score never changes no matter how many numbers I eat up. It also doesn't change at game over if I press q or run out of valid moves.

Deeper Detail:
The issue also occurred exactly the same if I run it in "guake" (drop-down) terminal which I use regularly and have installed as regular ubuntu package.
The text line with the score and version and "Hit '?' for help" text updates but the text "1 0.06%" does not change however far through a game you get, and when the greed command is run with "-s" option to show scores, they all show 0.06% after every game I play.

Actions Taken so far:
I attempted to write an email to the author feedback email address given on the "developers website" link from ubuntu software centre, and discovered a version 3.8 was available there (which I have not tried). The email bounced back undeliverable. I also saw screen grabs showing valid scores other than 0.06%, so the bug could possibly lie in the packaging or build or maybe even only shows on certain architectures (this box is amd64), or in v3.7 (and if 3.8 is ok).

Looks like extra debug will be added automatically but in case, I believe I am running standard ncurses on this dual-core Ubuntu desktop. See attachments for copy-pasted textual screenshots (so no colours present).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: greed 3.7-1
ProcVersionSignature: Ubuntu 3.5.0-40.62-generic 3.5.7.20
Uname: Linux 3.5.0-40-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu12
Architecture: amd64
Date: Wed Sep 11 23:06:22 2013
MarkForUpload: True
SourcePackage: greed
UpgradeStatus: Upgraded to quantal on 2012-10-20 (326 days ago)

Revision history for this message
breezer (jgbreezer) wrote :
Revision history for this message
Lenin (gagarin) wrote :

Can you check if it's still a problem with 18.04?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in greed (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers