libgv-python: wrong symlink from _gv.x86_64-linux-gnu.so

Bug #1583897 reported by Michel Alexandre Salim
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
graphviz (Debian)
Fix Released
Unknown
graphviz (Ubuntu)
Fix Released
Medium
Unassigned
Xenial
Fix Released
Medium
Unassigned
Yakkety
Fix Released
Medium
Unassigned

Bug Description

Impact
======
libgv-python is unusable because the symlink is not pointed to the correct file. Ubuntu 16.04 LTS and 16.10 are affected by this bug, but Ubuntu 14.04 LTS is not.

Test Case
=========
Install libgv-python
Run these commands:
$ python
>>> import gv

It should silently print a new line without errors
>>>

Then, type exit() to exit the python interpreter

Regression Potential
====================
None. Without this fix, libgv-python doesn't work at all.
The fix in debian/rules is copied from Debian 2.38.0-16.

Original Bug Report
===================

On xenial, with the latest version of libgv-python (2.38.0-12ubuntu2) on x86_64,

when importing the gv module I get the following error:

```
❯ python
Python 2.7.11+ (default, Apr 17 2016, 14:00:29)
[GCC 5.3.1 20160413] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gv
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "gv.py", line 28, in <module>
    _gv = swig_import_helper()
  File "gv.py", line 20, in swig_import_helper
    import _gv
ImportError: No module named _gv
>>>
```

Upon investigation, there is a dangling symlink -- _gv.x86_64-linux-gnu.so points to a non-existent library that does not contain the architecture, whereas the actual existing file is tagged with the architecture (x86_64-linus-gnu):

```
/usr/lib/python2.7/dist-packages
❯ ls -l *gv*so
lrwxrwxrwx 1 root root 17 Mar 14 05:29 _gv.x86_64-linux-gnu.so -> libgv_python27.so
-rw-r--r-- 1 root root 92624 Mar 14 05:29 libgv_python27.x86_64-linux-gnu.so

```

Currently creating the libgv_python27.so -> libgv_python27.x86_64-linux-gnu.so symlink manually so as not to touch the files coming from the package.

Jeremy Bicha (jbicha)
Changed in graphviz (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Changed in graphviz (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Medium
Changed in graphviz (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Medium
tags: added: xenial yakkety
Changed in graphviz (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package graphviz - 2.38.0-16ubuntu1

---------------
graphviz (2.38.0-16ubuntu1) zesty; urgency=medium

  * Sync with Debian (LP: #1583897). Remaining change:
    - Build without gts support since the library is still in universe
  * Don't build-depend on libann-dev since it's in universe

graphviz (2.38.0-16) unstable; urgency=low

  * Fix libgv-python broken symlink (closes: #839176).
  * Add libann-dev to build dependency to build tool mingle (closes: #830998).

 -- Jeremy Bicha <email address hidden> Sat, 24 Dec 2016 21:43:57 -0500

Changed in graphviz (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha)
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Michel, or anyone else affected,

Accepted graphviz into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/graphviz/2.38.0-12ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in graphviz (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in graphviz (Ubuntu Yakkety):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Michel, or anyone else affected,

Accepted graphviz into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/graphviz/2.38.0-15ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Jeremy Bicha (jbicha) wrote :

The test case completes successfully on xenial-proposed and yakkety-proposed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package graphviz - 2.38.0-12ubuntu2.1

---------------
graphviz (2.38.0-12ubuntu2.1) xenial; urgency=medium

  * Fix broken symlink that made libgv-python unusable (LP: #1583897)
  * Add missing dependency from libgraphviz-dev to libgvc6-plugins-gtk
    (LP: #1398028)
  * Install missing GDK plugin in libgvc6-plugin-gtk

 -- Jeremy Bicha <email address hidden> Sat, 24 Dec 2016 21:53:57 -0500

Changed in graphviz (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Robie Basak (racb) wrote : Update Released

The verification of the Stable Release Update for graphviz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package graphviz - 2.38.0-15ubuntu1.1

---------------
graphviz (2.38.0-15ubuntu1.1) yakkety; urgency=medium

  * Fix broken symlink that made libgv-python unusable (LP: #1583897)

 -- Jeremy Bicha <email address hidden> Sat, 24 Dec 2016 21:43:57 -0500

Changed in graphviz (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.