libgraphviz-dev: dangling symbolic links for missing files libgvplugin_gdk.so and libgvplugin_gtk.so

Bug #1398028 reported by J G Miller on 2014-12-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
graphviz (Debian)
Fix Released
Unknown
graphviz (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

Impact
======
libgraphviz-dev has dangling symlinks.

Test Case
=========
Verify that libgraphviz-dev depends on libgvc6-plugin-gtk and that
libgvplugin_gdk.so.6.0.0 and libgvplugin_gtk.so.6.0.0 exist in libgvc6-plugin-gtk.

Regression Potential
====================
None. This simply installs one file that had been built but not installed (the GDK plugin) and adds a missing dependency from libgraphviz-dev to the graphviz GTK plugin library built in the same package.

Other Info
==========
These bugs were fixed in Debian's graphviz 2.38.0-13 and -14 and fixed in yakkety.

Original Bug Report
===================

PRETTY_NAME="Ubuntu 14.04.1 LTS"
VERSION="14.04.1 LTS, Trusty Tahr"

Package: libgraphviz-dev
Architecture: i386
Source: graphviz
Version: 2.36.0-0ubuntu3

In /usr/lib/graphviz, dangling symbolic links to non-existing files are created.

0 lrwxrwxrwx 1 root root 24 2014-02-20 14:11 libgvplugin_gdk.so -> libgvplugin_gdk.so.6.0.0
0 lrwxrwxrwx 1 root root 24 2014-02-20 14:11 libgvplugin_gtk.so -> libgvplugin_gtk.so.6.0.0

No package contains either libgvplugin_gdk.so.6.0.0 or libgvplugin_gtk.so.6.0.0: neither graphviz i386 architecture package nor amd64 architecture package.

Perhaps these symbolic links are an unintended remnant from the libgraphviz to graphviz transition.

If not, then libgvplugin_gdk.so.6.0.0 and libgvplugin_gtk.so.6.0.0 should be provided in the graphviz package.

J G Miller (jgmiller) on 2014-12-01
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in graphviz (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-12-25
Changed in graphviz (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

I uploaded the fix for this for Ubuntu 16.04 LTS to the trusty-proposed queue.

But, for 14.04 LTS graphviz is not part of the ubuntu-desktop packageset so I will need sponsorship. .debdiff attached

Jeremy Bicha (jbicha) on 2016-12-25
description: updated
Changed in graphviz (Ubuntu Xenial):
importance: Undecided → Low
Changed in graphviz (Ubuntu):
importance: Undecided → Low
Changed in graphviz (Ubuntu Xenial):
status: New → Triaged
Changed in graphviz (Debian):
status: Unknown → Fix Released
tags: added: packaging patch
removed: dangling graphviz missing

Hello J, or anyone else affected,

Accepted graphviz into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/graphviz/2.38.0-12ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in graphviz (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) on 2017-01-05
Changed in graphviz (Ubuntu Trusty):
importance: Undecided → Low
status: New → Triaged
no longer affects: bubblewrap (Ubuntu Xenial)
no longer affects: bubblewrap (Ubuntu Trusty)
no longer affects: bubblewrap (Ubuntu)
tags: added: xenial
J G Miller (jgmiller) wrote :

Since reporting this bug TWO YEARS ago (2014-12-01), my system has moved on to

DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

With the current package versions installed for Ubuntu 16.04 Xenial

graphviz 2.38.0-12ubuntu2
graphviz-doc 2.38.0-12ubuntu2
libgraphviz-dev 2.38.0-12ubuntu2

there are, in /usr/lib/graphviz, the two dangling symbolic links

lrwxrwxrwx 1 root root 24 2016-03-13 23:30 libgvplugin_gdk.so -> libgvplugin_gdk.so.6.0.0
lrwxrwxrwx 1 root root 24 2016-03-13 23:30 libgvplugin_gtk.so -> libgvplugin_gtk.so.6.0.0

After downloading all of the required "proposed" new packages and

Setting up libcdt5 (2.38.0-12ubuntu2.1) ...
Setting up libcgraph6 (2.38.0-12ubuntu2.1) ...
Setting up libgvpr2 (2.38.0-12ubuntu2.1) ...
Setting up libpathplan4 (2.38.0-12ubuntu2.1) ...
Setting up libxdot4 (2.38.0-12ubuntu2.1) ...
Setting up libgvc6 (2.38.0-12ubuntu2.1) ...
Setting up graphviz (2.38.0-12ubuntu2.1) ...
Setting up libgvc6-plugins-gtk (2.38.0-12ubuntu2.1) ...
Setting up libgraphviz-dev (2.38.0-12ubuntu2.1) ...

the symbolic links no longer dangle because the gdk and gtk plugin shared library files are present.

lrwxrwxrwx 1 root root 24 2017-01-05 22:17 libgvplugin_gdk.so -> libgvplugin_gdk.so.6.0.0
lrwxrwxrwx 1 root root 24 2017-01-05 22:17 libgvplugin_gdk.so.6 -> libgvplugin_gdk.so.6.0.0
-rw-r--r-- 1 root root 10100 2017-01-05 22:17 libgvplugin_gdk.so.6.0.0
lrwxrwxrwx 1 root root 24 2017-01-05 22:17 libgvplugin_gtk.so -> libgvplugin_gtk.so.6.0.0
lrwxrwxrwx 1 root root 24 2017-01-05 22:17 libgvplugin_gtk.so.6 -> libgvplugin_gtk.so.6.0.0
-rw-r--r-- 1 root root 30636 2017-01-05 22:17 libgvplugin_gtk.so.6.0.0

Thank you for finally fixing this problem and thank you to Jeremy for all his work in maintaining and packaging this and other packages.

J G Miller (jgmiller) on 2017-01-06
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package graphviz - 2.38.0-12ubuntu2.1

---------------
graphviz (2.38.0-12ubuntu2.1) xenial; urgency=medium

  * Fix broken symlink that made libgv-python unusable (LP: #1583897)
  * Add missing dependency from libgraphviz-dev to libgvc6-plugins-gtk
    (LP: #1398028)
  * Install missing GDK plugin in libgvc6-plugin-gtk

 -- Jeremy Bicha <email address hidden> Sat, 24 Dec 2016 21:53:57 -0500

Changed in graphviz (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for graphviz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Michael Terry (mterry) wrote :

I've uploaded this to trusty-proposed. Thanks Jeremy, for the patch! Dropping sponsor subscription for now.

Hello J, or anyone else affected,

Accepted graphviz into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/graphviz/2.36.0-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in graphviz (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Robie Basak (racb) wrote :
Jeremy Bicha (jbicha) wrote :

I installed libgraphviz-dev 2.36.0-0ubuntu3.2 on Ubuntu GNOME 14.04 LTS. It installed libgvc6-plugin-gtk. I verified that libgvc6-plugin-gtk installed both libgvplugin_gdk.so.6.0.0 and libgvplugin_gtk.so.6.0.0.

In my terminal I ran
ls -lah /usr/lib/graphviz/
and all the files and symlinks looked correct.

tags: added: verification-done verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package graphviz - 2.36.0-0ubuntu3.2

---------------
graphviz (2.36.0-0ubuntu3.2) trusty; urgency=medium

  * Add missing dependency from libgraphviz-dev to libgvc6-plugins-gtk
    (LP: #1398028)
  * Install missing GDK plugin in libgvc6-plugin-gtk

 -- Jeremy Bicha <email address hidden> Sat, 24 Dec 2016 22:28:32 -0500

Changed in graphviz (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.