Ubuntu

Please sync gramps 3.3.1-1 (universe) from Debian sid

Reported by Pion on 2011-10-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gramps (Ubuntu)
Undecided
Unassigned

Bug Description

2011-10-01
Version 3.3.1 -- "The Tenth Anniversary Edition" bug fix release.
* translation updates: ca, cs, de, fr, hr, it, nb, nl, pl, pt_br, sk, sl, sv, uk, zh_cn
* new languages in this release: ja (Japanese), vi (Vietnamese)
* 36 bugs closed since v3.3.0: http://www.gramps-project.org/bugs/roadmap_page.php?version_id=27
* 79 translation commits since v3.3.0
* 189 code commits since v3.3.0
* ten years since v0.1.1 was first released: http://www.gramps-project.org/wiki/index.php?title=Previous_releases
* "Thank you!" to Donald Allingham, The Gramps Developers, translators, and our every day users

==================
Very large Diff: https://launchpadlibrarian.net/81958680/gramps_3.3.0-1_3.3.1-1.diff.gz

I scanned the svn commit log and the changes appeared to be just lots of bugfixes and translation updates.

Testing done
============
I loaded an old test gramps file which gramps converted to the new format. I exported my family tree to a backup and restored from the backup successfully.

Original bug report
==================
list index out of range in gettext.install(TransUtils.LOCALEDOMAIN, localedir=None, unicode=1)

Gramps 3.3.0-1e won't start. I've been using Ubuntu 11.10 beta2 for a week now, so it's a relatively clean computer. It's an EliteBook 8560w (64-bits) if that matters. This is the output I'm getting (Gtk warnings in norwegian):

jostein@jostein-laptop:~$ gramps

(gramps.py:7715): Gtk-WARNING **: Kunne ikke finne temamotor i module_path: «pixmap».

(gramps.py:7715): Gtk-WARNING **: Kunne ikke finne temamotor i module_path: «pixmap».

(gramps.py:7715): Gtk-WARNING **: Kunne ikke finne temamotor i module_path: «pixmap».

(gramps.py:7715): Gtk-WARNING **: Kunne ikke finne temamotor i module_path: «pixmap».
Traceback (most recent call last):
  File "/usr/share/gramps/gramps.py", line 72, in <module>
    gettext.install(TransUtils.LOCALEDOMAIN, localedir=None, unicode=1) #None is sys default locale
  File "/usr/lib/python2.7/gettext.py", line 508, in install
    t = translation(domain, localedir, fallback=True, codeset=codeset)
  File "/usr/lib/python2.7/gettext.py", line 493, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 314, in _parse
    plural = v[1].split('plural=')[1]
IndexError: list index out of range

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gramps 3.3.0-1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 1 15:58:52 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110920.5)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: gramps
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (1 days ago)

Pion (josteinaj) wrote :
Pion (josteinaj) wrote :

Posted to gramps bug tracker as well:

http://www.gramps-project.org/bugs/view.php?id=5267

Pion (josteinaj) wrote :

This was a known issue, and a ptch has been released to the Debian repos, although not yet the Ubuntu repos. I'm marking this as "fix committed":

http://www.gramps-project.org/bugs/view.php?id=5267

description: updated
Changed in gramps (Ubuntu):
status: New → Incomplete
status: Incomplete → Fix Committed

On Saturday, October 01, 2011 07:25:38 PM Pion wrote:
> This was a known issue, and a ptch has been released to the Debian
> repos, although not yet the Ubuntu repos. I'm marking this as "fix
> committed":

Ummm. Debian Unstable and Ubuntu Oneiric have identical Gramps versions, so
what does "released to the Debian repos" mean?

Not sure, but the reply I got on the Gramps bugtracker was "Note, debian package seems to have been patched (not yet the ubuntu one)...".

Anyway, it's marked as "fixed in version 3.3.1" there, and the one I'm able to install in oneiric atm is 3.3.0. I don't know about Debian since I don't use it.

Jeremy Bicha (jbicha) on 2011-10-04
summary: - list index out of range in gettext.install(TransUtils.LOCALEDOMAIN,
- localedir=None, unicode=1)
+ Please sync gramps 3.3.1-1 (universe) from Debian sid
Jeremy Bicha (jbicha) wrote :

Install log:

sudo dpkg -i /home/jeremy/Downloads/gramps_3.3.1-1_all.deb
(Reading database ... 258345 files and directories currently installed.)
Preparing to replace gramps 3.3.0-1 (using .../gramps_3.3.1-1_all.deb) ...
Unpacking replacement gramps ...
Setting up gramps (3.3.1-1) ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-icon-theme ...

description: updated
Iain Lane (laney) wrote :

sync request acked (no ffe required)

Changed in gramps (Ubuntu):
status: Fix Committed → Confirmed
Colin Watson (cjwatson) wrote :

2011-10-06 08:06:43 INFO Creating lockfile: /var/lock/launchpad-sync-source.lock
[Updating] gramps (3.3.0-1 [Ubuntu] < 3.3.1-1 [Debian])
 * Trying to add gramps...
2011-10-06 08:07:01 INFO - <gramps_3.3.1.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-10-06 08:07:03 INFO - <gramps_3.3.1-1.dsc: downloading from http://ftp.debian.org/debian/>
2011-10-06 08:07:03 INFO - <gramps_3.3.1-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-10-06 08:07:04 DEBUG Removing lock file: /var/lock/launchpad-sync-source.lock
I: gramps [universe] -> gramps_3.3.0-1 [universe].

Changed in gramps (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.