Please remove gradle from quantal

Bug #935146 reported by Andreas Moog on 2012-02-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gradle (Debian)
Fix Released
Unknown
gradle (Ubuntu)
High
Unassigned

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

make[1]: Entering directory `/build/buildd/gradle-1.0~m3'
gradle assemble -g /build/buildd/gradle-1.0~m3/.gradlehome

FAILURE: Build failed with an exception.

* Where:
Build file '/build/buildd/gradle-1.0~m3/buildSrc/build.gradle' line: 21

* What went wrong:
A problem occurred evaluating root project 'buildSrc'.
Cause: org/codehaus/groovy/transform/powerassert/ValueRecorder
Cause: org.codehaus.groovy.transform.powerassert.ValueRecorder

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 6.25 secs
make[1]: *** [override_dh_auto_build] Error 1
make[1]: Leaving directory `/build/buildd/gradle-1.0~m3'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120206-0253
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3148427/+files/buildlog_ubuntu-precise-i386.gradle_1.0~m3-1_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Andreas Moog (ampelbein) on 2012-02-18
Changed in gradle (Ubuntu):
importance: Undecided → High
Changed in gradle (Debian):
status: Unknown → New
Andreas Moog (ampelbein) on 2012-02-24
Changed in gradle (Ubuntu Precise):
status: New → Triaged
Shawn Kovalchick (bamapookie) wrote :

I am getting the same error. It fails on line 3 of my build.gradle file, which is "apply plugin: 'eclipse'".

If I remove this line, then the error goes away. I have libgradle-ide-plugin package installed.

Shawn Kovalchick (bamapookie) wrote :

It appears that prior to Gradle version 1.0-milestone-6, only groovy 1.7 was supported. Groovy 1.8 support was added in 1.0-milestone-6. See http://issues.gradle.org/browse/GRADLE-1722.

Marius B. Kotsbak (mariusko) wrote :

I also have the same problem as comment #1.

Kavan Patil (kavan-patil) wrote :

Hi I also have this issue. Is there a known workaround. Could we work with a lower version of the groovy package < 1.8.0?

Marius B. Kotsbak (mariusko) wrote :

Download and install the latest version of Gradle is maybe a workaround?

Changed in gradle (Debian):
status: New → Fix Committed
James Page (james-page) wrote :

Looking at the Debian maintainers comments, we should remove this package from quantal as its not going to work with the version of groovy that we have.

WIP on a new package but not ready yet so to late for this release.

summary: - gradle version 1.0~m3-1 FTBFS on i386 in precise
+ Please remove gradle from quantal
Scott Kitterman (kitterman) wrote :
Download full text (4.2 KiB)

Removing packages from quantal:
        gradle 1.0~m3-1 in quantal
                gradle 1.0~m3-1 in quantal amd64
                gradle 1.0~m3-1 in quantal armel
                gradle 1.0~m3-1 in quantal armhf
                gradle 1.0~m3-1 in quantal i386
                gradle 1.0~m3-1 in quantal powerpc
                gradle-doc 1.0~m3-1 in quantal amd64
                gradle-doc 1.0~m3-1 in quantal armel
                gradle-doc 1.0~m3-1 in quantal armhf
                gradle-doc 1.0~m3-1 in quantal i386
                gradle-doc 1.0~m3-1 in quantal powerpc
                libgradle-announce-java 1.0~m3-1 in quantal amd64
                libgradle-announce-java 1.0~m3-1 in quantal armel
                libgradle-announce-java 1.0~m3-1 in quantal armhf
                libgradle-announce-java 1.0~m3-1 in quantal i386
                libgradle-announce-java 1.0~m3-1 in quantal powerpc
                libgradle-antlr-java 1.0~m3-1 in quantal amd64
                libgradle-antlr-java 1.0~m3-1 in quantal armel
                libgradle-antlr-java 1.0~m3-1 in quantal armhf
                libgradle-antlr-java 1.0~m3-1 in quantal i386
                libgradle-antlr-java 1.0~m3-1 in quantal powerpc
                libgradle-code-quality-java 1.0~m3-1 in quantal amd64
                libgradle-code-quality-java 1.0~m3-1 in quantal armel
                libgradle-code-quality-java 1.0~m3-1 in quantal armhf
                libgradle-code-quality-java 1.0~m3-1 in quantal i386
                libgradle-code-quality-java 1.0~m3-1 in quantal powerpc
                libgradle-core-java 1.0~m3-1 in quantal amd64
                libgradle-core-java 1.0~m3-1 in quantal armel
                libgradle-core-java 1.0~m3-1 in quantal armhf
                libgradle-core-java 1.0~m3-1 in quantal i386
                libgradle-core-java 1.0~m3-1 in quantal powerpc
                libgradle-ide-java 1.0~m3-1 in quantal amd64
                libgradle-ide-java 1.0~m3-1 in quantal armel
                libgradle-ide-java 1.0~m3-1 in quantal armhf
                libgradle-ide-java 1.0~m3-1 in quantal i386
                libgradle-ide-java 1.0~m3-1 in quantal powerpc
                libgradle-jetty-java 1.0~m3-1 in quantal amd64
                libgradle-jetty-java 1.0~m3-1 in quantal armel
                libgradle-jetty-java 1.0~m3-1 in quantal armhf
                libgradle-jetty-java 1.0~m3-1 in quantal i386
                libgradle-jetty-java 1.0~m3-1 in quantal powerpc
                libgradle-maven-java 1.0~m3-1 in quantal amd64
                libgradle-maven-java 1.0~m3-1 in quantal armel
                libgradle-maven-java 1.0~m3-1 in quantal armhf
                libgradle-maven-java 1.0~m3-1 in quantal i386
                libgradle-maven-java 1.0~m3-1 in quantal powerpc
                libgradle-osgi-java 1.0~m3-1 in quantal amd64
                libgradle-osgi-java 1.0~m3-1 in quantal armel
                libgradle-osgi-java 1.0~m3-1 in quantal armhf
                libgradle-osgi-java 1.0~m3-1 in quantal i386
                libgradle-osgi-java 1.0~m3-1 in quantal powerpc
           ...

Read more...

Changed in gradle (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Changed in gradle (Debian):
status: Fix Committed → Fix Released
Andreas Moog (ampelbein) on 2017-10-04
no longer affects: gradle (Ubuntu Precise)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.