Please backport grace (1:5.1.22-8build1) from Maverick to Lucid

Bug #535459 reported by Nicola Ferralis
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Grace
New
Wishlist
Unassigned
Lucid Backports
Undecided
Unassigned
maverick-backports
Invalid
Undecided
Unassigned
grace (Debian)
Fix Released
Unknown
grace (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: grace

Version 1:5.1.22-6 of grace added support for non-linear peak fitting, which is a commonly needed feature in scientific data analysis.

Test build uploaded to <https://launchpad.net/~broder/+archive/ubuntu-tests>. Verified that it builds/installs/runs on Lucid

rdepends:
  mitools recommends grace
  science-viewing recommends grace
  thunar-thumbnailers suggests grace
  thunar-thumbnailers build-depends grace

rdepends analysis:

  mitools: Needs testing

  science-viewing: OK. Just a metapackage

  thunar-thumbnailers (Suggests): Needs testing

  thunar-thumbnailers (Build-Depends): OK. Builds against the new grace

========
Original title: Add non-linear peak fitting to xmgrace

Original package description (modified by broder):

One of the most used features in software for scientific data analysis is the ability to perform non linear peak fitting (specifically Lorentzian and Gaussian fits). Xmgrace sorely lacks this capability, unless you consider adding manually the required formula.

The attached patch attempts to resolve this issue, by extending the non-linear panel with two menu entries (under a new "Library" menu entry) for: a single peak Lorentzian or Gaussian (see attached image). The modifications are minor, and flexible for future implementations of other possible usable formulas and more important, for multi-peak fitting.

I realize this patch should be pushed upstream first. However development upstream has been nonexistent for more than a year now, and the patch I submitted many months back is still sitting there. Given the more active development via Debian, I try this as a more viable mean to get it through.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
tags: added: patch
Revision history for this message
Nicola Ferralis (feranick) wrote :

New patch with support for double peak fitting. Builds and compiles OK. Test binaries:

https://launchpad.net/~feranick/+archive/ppa/+packages

Revision history for this message
Nicola Ferralis (feranick) wrote :
tags: added: kernel-series-unknown
Revision history for this message
Nicola Ferralis (feranick) wrote :

Just to clarify: the patches are for grace 5.1.22-3 in lucid.

tags: removed: kernel-series-unknown
Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Hi Feranick,

Great work... please could you create a debdiff between the Debian package (5.1.22-3) and your new version (5.1.22-3ubuntu1) and attach it? Once you have done that, please subscribe ubuntu-universe-sponsors to the package so that someone can review the patch and add it to the repositories.

Also, it's probably a good idea to forward this upstream even though Evgeny's upstream development is currently stalled. If/when he or someone else resumes the development, it would be helpful to include all the downstream changes there.

Changed in grace (Ubuntu):
status: New → Confirmed
Changed in grace-plotting-tool:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Alex Valavanis (valavanisalex) wrote :
Changed in grace-plotting-tool:
status: Confirmed → New
Revision history for this message
Nicola Ferralis (feranick) wrote :

Alex,

I will do as indicated. I am working on an improved patch. As soon as I am done with it I'll proceed with the subscription.

Thanks,
Nicola Ferralis (aka feranick)

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Attached updated patch and debdiff. Subscribed ubuntu-universe-sponsors.

Revision history for this message
Nicola Ferralis (feranick) wrote :

I significantly improved the current patch with the following:

1. For single Gaussian and Lorentzian fitting, now upon selection of the proper function, the user can use the mouse to point to the maximum of the peak (as indicated also in the footer of xmgrace window). This sets the initial values for the peak maximum and intensity. With these values, the fit becomes straightforward.
2. I added an short explanation in the user guide.

Attached are the new patch with the debdiff.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

I significantly extended the library of non-linear fitting function, so that it includes:

Gaussian (single, double, chromatography), Lorentzian (single double), Pseudo Voigt 1, Pseudo Voigt 2, Asymmetric double sigmoidal, Log Normal Function, Gram-Charlier A-Series, Edgeworth-Cramer Series, Inverse Polynomial Function.

It also includes, Periodic Peak functions (Sine, Sine square, Sine damp), and Baseline Functions (Exponential Decay 1, Exponential Decay 2, Exponential Growth 1, Exponential Growth 2, Hyperbolic, Bradley, Logarithm 3 parameters).

The new patch and the debdiff are attached.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Sorry for the multiple attachment, please consider only the latest. I added support for triple Lorentzian and Gaussians.

I am done with the patch, no more modifications for now.

Revision history for this message
Nicola Ferralis (feranick) wrote :

I created a new ppa for testing binaries:

https://launchpad.net/~grace-extended/+archive/ppa

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Thanks Nicola, I have untagged the old patches to help avoid confusion. I'll give the ppa version a try today if I get a chance.

Revision history for this message
Nicola Ferralis (feranick) wrote :

Any news about this?

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

- New debdiff against new upstream release (5.1.22-5)
- Fixed typo in patch.

Test builds available in grace-extended ppa:

https://launchpad.net/~grace-extended/+archive/ppa/+packages

description: updated
Changed in grace (Debian):
status: Unknown → New
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Updated patch. Now user input (via mouse coordinates) for initial peak position/amplitude is available for single, double and triple Lorentzian and Gaussian. Previously it was available only for single peak fitting.

Test builds available in grace-extended ppa:

https://launchpad.net/~grace-extended/+archive/ppa/+packages

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

I re-uploaded the patch and debdiff, since the old ones were the wrong ones...

Sorry for the inconvenience.

Revision history for this message
Nicola Ferralis (feranick) wrote :

I attach a screenshot highlighting the new "Library" entry in the nonlinear fitting panel, and the initialization parameters (in the console) used for a three peak Lorentzian fit.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Hi Nicola,

I finally got round to testing the new function library, and it looks great. I think the user guide should mention the mouse input for Lorentzian fitting too. It might even be a good idea to print instructions to the console window which pops up.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Thanks for the feedback, Alex, and please, keep it coming!

I implemented the suggested changes, specifically I added a brief note in the User guide about the user input, and instructions for user input are now printed both in the console and in the footer of the window.

Test builds available soon in the ppa.

Changed in grace (Debian):
status: New → Fix Committed
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

I added another useful fitting function to the patch (asymmetric Doniach-Sunjic), which is used in fitting photoemission spectra. I do include a debdiff, as this patch will be soon available in Debian.

Changed in grace (Debian):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grace - 1:5.1.22-6

---------------
grace (1:5.1.22-6) unstable; urgency=low

  * rules: Run sensible-editor inside x-terminal-emulator.
    (Closes: #582154) (LP: #582399)
  * New patches:
    - non-resizable-dialogs.patch: Set certain dialog boxes to fixed sizes,
      preventing display errors and possible concealment of action buttons.
      (Closes: #253087)
    - superscript-subscript-scale.patch: Adjust {sub,super}script scaling to
      bring them more in line with LaTeX's style. (Closes: #279359)
    - nonlinfit_lorentzian_gaussian_2.diff: Add support for non-linear
      Lorentzian and Gaussian fitting. Written and contributed by Nicola
      Ferralis. (Closes: #578435) (LP: #535459)
  * control: Add Build-Depends on texlive-latex-{base,recommended} for
    regeneration of DVI documentation.
 -- Ubuntu Archive Auto-Sync <email address hidden> Fri, 28 May 2010 11:22:55 +0100

Changed in grace (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Nicola Ferralis (feranick) wrote :

Adding request to port this patch to grace 5.1.22-5 in lucid. The capabilities provided by this patch are significant since easy non-linear fitting is sorely missing. The patch has been significantly tested and it is included in more recent version of grace (it's included in version 5.1.22-6 and beyond). No side effects or potential regressions are found.

 The patch (attached) has been tested and found to work on 5.1.22-5. I also attach a debdiff for version 5.1.22-5ubuntu1.

grace (1:5.1.22-5ubuntu1) lucid; urgency=low

  * Add support for non-linear fitting.
    - Written and contributed by Nicola Ferralis. (LP: #535459)

 -- Nicola Ferralis <email address hidden> Tue, 23 Nov 2010 15:04:47 -0800

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Requesting a "nomination for lucid".

Revision history for this message
Alessio Treglia (quadrispro) wrote :

Hi Nicola, and thank you for taking the time to report this bug and helping to make Ubuntu better.

Just two points:
 - The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status.
 - Would you mind to change the target release in your debdiff from 'lucid' to 'lucid-proposed'? You may find useful information information about Ubuntu's SRU here: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Thanks in advance.

Revision history for this message
Alessio Treglia (quadrispro) wrote :

Unsubscribing sponsors team for now, please re-subscribe when ready.

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

@Alessio - This patch is really to add a new feature, rather than a bug fix. It was forwarded upstream some months ago at http://plasma-gate.weizmann.ac.il/Grace/phpbb/viewtopic.php?f=6&t=1898. Unfortunately, upstream development of Grace has stalled, and the patch is is not likely to be taken upstream in the foreseeable future.

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Thanks, Alessio.

1. As Alex mentioned, the bug has been sitting upstream for a long while with no action (see also comment #7 above).

2. Done, see below. Re-subscribing sponsors-team.

grace (1:5.1.22-5ubuntu1) lucid-proposed; urgency=low

  * Add support for non-linear fitting.
    - Written and contributed by Nicola Ferralis. (LP: #535459)

 -- Nicola Ferralis <email address hidden> Wed, 24 Nov 2010 17:29:03 -0800

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

Hi Nicola,

I just noticed that the latest patch also adds the Weibull PDF, so it also closes bug #608789. Probably worth mentioning this in debian/changelog?

Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :
Revision history for this message
Nicola Ferralis (feranick) wrote :

Hi Alex, done.

grace (1:5.1.22-5ubuntu1) lucid-proposed; urgency=low

  * Add support for non-linear fitting.
    - Written and contributed by Nicola Ferralis. (LP: #535459, #608789)

 -- Nicola Ferralis <email address hidden> Thu, 25 Nov 2010 14:09:02 -0800

Revision history for this message
Evan Broder (broder) wrote :

I don't think that this patch is appropriate for an SRU. SRU's are supposed to fix "high-impact bugs", such as "severe regressions" and "loss of user data", and are specifically not supposed to be used as a mechanism to provide new features. (See https://wiki.ubuntu.com/StableReleaseUpdates#When)

Backports, on the other hand, are for including "significant new features", so I think that backporting grace from Natty to Lucid (and Maverick) is pretty clearly the way to go here.

I'm going to turn this into a backports bug instead of an SRU bug.

Changed in grace (Ubuntu Lucid):
status: New → Invalid
Revision history for this message
Evan Broder (broder) wrote :

Oh, whoops - this got fixed in Maverick, so we only need to backport to Lucid.

Changed in maverick-backports:
status: New → Invalid
description: updated
summary: - Add non-linear peak fitting to xmgrace
+ Please backport grace (1:5.1.22-8build1) from Maverick to Lucid
Evan Broder (broder)
description: updated
Evan Broder (broder)
description: updated
Evan Broder (broder)
Changed in lucid-backports:
status: New → Confirmed
status: Confirmed → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.