gpxviewer crashes from Unity and hangs from Terminal

Bug #1766983 reported by John Rose on 2018-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpxviewer (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu version is 16.04.4. gpxviewer is 0.5.2-1.
Until approx a week ago gpxviewer worked fine when invoked from Unity Dash (as GPX Viewer) or by clicking a gpx file in Nautilus etc. Now it crashes. When I invoke it from Terminal, it hangs when I try to open a gpx file:
john@John:~$ gpxviewer
/usr/bin/gpxviewer:28: PyGIWarning: Gdk was imported without specifying a version first. Use gi.require_version('Gdk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gdk
/usr/share/gpxviewer/gpxviewer/ui.py:26: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/share/gpxviewer/gpxviewer/ui.py:30: PyGIWarning: OsmGpsMap was imported without specifying a version first. Use gi.require_version('OsmGpsMap', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import OsmGpsMap
/usr/share/gpxviewer/gpxviewer/pygtk_chart/chart.py:42: PyGIWarning: PangoCairo was imported without specifying a version first. Use gi.require_version('PangoCairo', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import PangoCairo
Traceback (most recent call last):
  File "/usr/share/gpxviewer/gpxviewer/ui.py", line 394, in openGPX
    if self.loadGPX(filename):
  File "/usr/share/gpxviewer/gpxviewer/ui.py", line 381, in loadGPX
    self.showGPXError()
  File "/usr/share/gpxviewer/gpxviewer/ui.py", line 400, in showGPXError
    message_box = Gtk.MessageDialog(parent=self.mainWindow,type=Gtk.MESSAGE_ERROR,buttons=Gtk.BUTTONS_OK,message_format=_("You selected an invalid GPX file. \n Please try again"))
  File "/usr/lib/python2.7/dist-packages/gi/overrides/__init__.py", line 39, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 139, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'MESSAGE_ERROR'

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gpxviewer 0.5.2-1
ProcVersionSignature: Ubuntu 4.4.0-121.145-generic 4.4.117
Uname: Linux 4.4.0-121-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.16
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 25 22:02:55 2018
InstallationDate: Installed on 2016-12-08 (503 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
SourcePackage: gpxviewer
UpgradeStatus: No upgrade log present (probably fresh install)

John Rose (johnaaronrose) wrote :
John Rose (johnaaronrose) wrote :

This is a regression bug i.e. gpxviewer used to work with the same Ubuntu version (16.04). So it's presumably been caused by a Ubuntu software update. So it should be an easy bug to fix.

Changed in gpxviewer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers