gpsshogi version 0.3.0-1 failed to build on amd64 with GCC-4.6/oneiric

Bug #770752 reported by Matthias Klose on 2011-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpsshogi (Debian)
Fix Released
Unknown
gpsshogi (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

gpsshogi version 0.3.0-1 failed to build on amd64 with GCC-4.6/oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2451995

Details about the rebuild:
https://lists.ubuntu.com/archives/ubuntu-devel/2011-April/033042.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2451995/+files/buildlog_ubuntu-natty-amd64.gpsshogi_0.3.0-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1671 lines into the build log:

g++ -Wl,-Bsymbolic-functions -L/usr/share/libosl-dev/release -L../lib -Wl,-rpath,../lib gpsshogi.o -lboost_thread-mt -lboost_program_options-mt -lpthread -losl -lboost_system-mt -lboost_filesystem-mt -ltcmalloc_minimal -o gpsshogi
/usr/lib64/libosl.so: undefined reference to `boost::thread::start_thread()'
/usr/lib64/libosl.so: undefined reference to `typeinfo for boost::detail::thread_data_base'
/usr/lib64/libosl.so: undefined reference to `boost::detail::get_current_thread_data()'
/usr/lib64/libosl.so: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
/usr/lib64/libosl.so: undefined reference to `boost::this_thread::sleep(boost::posix_time::ptime const&)'
/usr/lib64/libosl.so: undefined reference to `boost::thread::~thread()'
/usr/lib64/libosl.so: undefined reference to `boost::thread::join()'
/usr/lib64/libosl.so: undefined reference to `boost::this_thread::yield()'
/usr/lib64/libosl.so: undefined reference to `vtable for boost::detail::thread_data_base'
collect2: ld returned 1 exit status
make[1]: *** [gpsshogi] Error 1
make[1]: Leaving directory `/build/buildd/gpsshogi-0.3.0/bin'
make: *** [build/gpsshogi] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110423-0643
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/gpsshogi-0.3.0

Related branches

Matthias Klose (doko) on 2011-04-26
Changed in gpsshogi (Ubuntu):
importance: Undecided → High
Changed in gpsshogi (Ubuntu):
milestone: none → oneiric-alpha-3
Changed in gpsshogi (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → none
status: New → Confirmed
tags: added: universe
Julian Taylor (jtaylor) wrote :

this is caused by libosl not linked against boost threads. See the debian bug.

Changed in gpsshogi (Debian):
status: Unknown → New
Julian Taylor (jtaylor) wrote :

libosl was fixed in 0.4.0-1ubuntu1 solving this issue

Changed in gpsshogi (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in gpsshogi (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.