Sync gpsd 2.90.1~svn6819-1 (universe) from Debian testing (main)

Bug #508013 reported by Artur Rona on 2010-01-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpsd (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync gpsd 2.90.1~svn6819-1 (universe) from Debian testing (main)

Explanation of the Ubuntu delta and why it can be dropped:
No delta in Ubuntu.

Changelog entries since current lucid version 2.39-8ubuntu1:

gpsd (2.90.1~svn6819-1) unstable; urgency=low

  * SVN snapshot, uploading to unstable as it fixes
    the blocking issues with gps_poll.
    The non-blocking gps_poll was introduced while fixing
    an issue in gps_unpack, so this upload also
    Closes: #561280
  * [84ab918f] Merge branch 'master' into experimental.
  * [bbd1d183] Merge branch 'experimental-upstream' into experimental
  * [fd98f498] Update symbols file.
  * [6f63fa61] Update gbp.conf.

 -- Bernd Zeimetz <email address hidden> Wed, 16 Dec 2009 10:25:26 +0100

gpsd (2.90-2) unstable; urgency=low

  * Upload to unstable.
    This will also fix the following issues:
    - gpsd doesn't support pipelining (Closes: #488913)
    - FTBFS with binutils-gold (Closes: #554739)

 -- Bernd Zeimetz <email address hidden> Tue, 08 Dec 2009 13:51:27 +0100

gpsd (2.90-1) experimental; urgency=low

  * New upstream release.
  * [bb9c3eb5] Add Conflicts: fso-gpsd to libgps19. fso-gpsd is a mess
    and not supported.
  * [4b2d3b57] Merge commit 'upstream/2.90'
  * [fdad4622] Work around --disable-python not being available anymore.

 -- Bernd Zeimetz <email address hidden> Mon, 07 Dec 2009 11:13:14 +0100

gpsd (2.90~svn6694-1) experimental; urgency=low

  * SVN snapshot.
  * [10b2460a] Include gps.h in Tachometer.c, needed to define UNUSED.
  * [3f75872e] Merge branch 'experimental-upstream' into experimental
  * [33831f96] Update gbp config for experimental.
  * [476e547e] Update soname in debian/control.
  * [0561c6cf] Updaing patches, dropping those which were applied
    upstream.
  * [d721c055] Revert "Revert "Remove workarounds for broken --disable-
    python."" This reverts commit
    0e5c78b75ec0390b9317c4e8db3f9294ae9cf319. Conflicts: debian/rules
  * [151e52e5] Clean up patches which were applied by upstream.
  * [b9bff239] Merge branch 'experimental-upstream' into experimental
  * [981b2ce1] Ship gps.1 again as the package `gps' was RMed from
    Debian.
  * [9674fb87] Add a Conflicts: gps for gpsd-clients. Just in case the
    package is still installed somewhere.
  * [6c788d8d] Clean ../gpsd_config.h.in~ in case it was left by the
    build.
  * [cf72c26f] Delete packaging/gpsd.spec.in.rej, was done upstream
    also.
  * [5eadc03b] Dropping INSTALL-description-fix. Not necessary anymore.
  * [c4a1d3f1] python-gps needs python2.6 or simplejson, update Depends.
  * [5e8ed26d] Do not try to install manpages via gpsd-clients.install.
  * [2b598581] s/dj_installman/dh_installman/
  * [1fc3151e] Update symbols files for the new soname.
  * [f530af1b] Install missing manpages which were forgotten before.
  * [9a964d22] Make hotplug wrapper executable.
  * [06b11aa2] Add python-gps.manpages to install manpages.

 -- Bernd Zeimetz <email address hidden> Thu, 03 Dec 2009 21:12:54 +0100

Artur Rona wrote:
> Public bug reported:
>
> Please sync gpsd 2.90.1~svn6819-1 (universe) from Debian testing (main)

No, DO NOT DO THAT YET.

What so hard to understand on

gpsd (2.39-8ubuntu1) lucid; urgency=low

  * Sync from Debian 2.39-8, this version is known to work. Please
    get in contact with me or Bernd before touching it again.

When did you contact me about that?
If you have a specific reason for syncing it, please let me know - and I'll give
a proper advice on whats the best way to handle it.

--
 Bernd Zeimetz Debian GNU/Linux Developer
 http://bzed.de http://www.debian.org
 GPG Fingerprints: 06C8 C9A2 EAAD E37E 5B2C BE93 067A AD04 C93B FF79
                   ECA1 E3F2 8E11 2432 D485 DD95 EB36 171A 6FF9 435F

Changed in gpsd (Ubuntu):
status: New → Incomplete
Fabrice Coutadeur (fabricesp) wrote :

unsubscribing u-u-s in the meantime. Please subscribe u-u-s again when it's clear that the package needs to be synced

Artur Rona (ari-tczew) wrote :

Bernd, oh, it's very incredible! Man, take it easy...

Fabrice Coutadeur (fabricesp) wrote :

For your info, someone requested a sync of Viking (Bug #508408), and it requires libgps-dev(>= 2.90).

Fabrice Coutadeur wrote:
> For your info, someone requested a sync of Viking (Bug #508408), and it
> requires libgps-dev(>= 2.90).

Is there a reason why viking needs to be synced now? The changes should not make
a difference for Ubuntu if I remember right.
I'd like to wait for gpsd 2.91 until syncing it - but if its really needed, we
could sync the current - less stable - gpsd version.

--
 Bernd Zeimetz Debian GNU/Linux Developer
 http://bzed.de http://www.debian.org
 GPG Fingerprints: 06C8 C9A2 EAAD E37E 5B2C BE93 067A AD04 C93B FF79
                   ECA1 E3F2 8E11 2432 D485 DD95 EB36 171A 6FF9 435F

Fabrice Coutadeur (fabricesp) wrote :

AFAIK, there are no specific reason for syncing viking, but if we don't do anything, it will get autosynced. So I should perhaps upload an ubuntu version, to avoid that to happen (or speak with an archive admin).

What do you think?

Bernd Zeimetz (bzed) wrote :

Fabrice Coutadeur wrote:
> AFAIK, there are no specific reason for syncing viking, but if we don't
> do anything, it will get autosynced. So I should perhaps upload an
> ubuntu version, to avoid that to happen (or speak with an archive
> admin).
>
> What do you think?

I'll talk with DktrKranz to find the best solution.

--
 Bernd Zeimetz Debian GNU/Linux Developer
 http://bzed.de http://www.debian.org
 GPG Fingerprints: 06C8 C9A2 EAAD E37E 5B2C BE93 067A AD04 C93B FF79
                   ECA1 E3F2 8E11 2432 D485 DD95 EB36 171A 6FF9 435F

Paul Gevers (paul-climbing) wrote :

Isn't autosyncing checking for (build)-dependencies, and thus not going to happen as long as gpsd is not updated? Just my 2cents.

Michael Bienia (geser) wrote :

No, auto-syncing doesn't check any dependencies.
Lucid has currently some packages auto-synced from testing which are currently in DEPWAIT on a newer libgps-dev. So some advice how to move on would be nice.

The best way would be to wait for gpsd 2.91 as the svn version is a bit buggy at some points. But if it makes to many issues I can coordinate a sync of the svn version to ubuntu. 2.91 was supposed to be out since some weeks but the developers didn't have the time to finish it unfortunately.

"Michael Bienia" <email address hidden> schrieb:

>No, auto-syncing doesn't check any dependencies.
>Lucid has currently some packages auto-synced from testing which are currently in DEPWAIT on a newer libgps-dev. So some advice how to move on would be nice.
>
>--
>Sync gpsd 2.90.1~svn6819-1 (universe) from Debian testing (main)
>https://bugs.launchpad.net/bugs/508013
>You received this bug notification because you are subscribed to gpsd in
>ubuntu.

--
Sent from my Android phone with K-9. Please excuse my brevity.

Michael Bienia (geser) wrote :

We are in no real hurry (yet) as Feature Freeze is still some days away (Feb 18th).
As you know the gpsd package better than me, I leave the decision up to you when to sync.
It should also be no big problem if gpsd 2.91 misses Feature Freeze by a few days.

Luca Falavigna (dktrkranz) wrote :

Please proceed checking the sync, also have a look at its rdeps to see if they need newer version from Debian.

Changed in gpsd (Ubuntu):
importance: Undecided → Wishlist
status: Incomplete → New
Fabrice Coutadeur (fabricesp) wrote :

It builds and installs fine, and all the rdepends has already been synced, and are actually depwaiting on this version:
  viking
  s3dosm
  navit
  geoclue-gpsd
  gaia

Sync request ack'd

Changed in gpsd (Ubuntu):
status: New → Triaged
Bernd Zeimetz (bzed) wrote :

You've missed kde4 in the build-deps. If the ubuntu kde4 package does not require libgps 2.90 it will FTBFS.

"Fabrice Coutadeur" <email address hidden> schrieb:

>It builds and installs fine, and all the rdepends has already been synced, and are actually depwaiting on this version:
> viking
> s3dosm
> navit
> geoclue-gpsd
> gaia
>
>Sync request ack'd
>
>** Changed in: gpsd (Ubuntu)
> Status: New => Triaged
>
>--
>Sync gpsd 2.90.1~svn6819-1 (universe) from Debian testing (main)
>https://bugs.launchpad.net/bugs/508013
>You received this bug notification because you are subscribed to gpsd in
>ubuntu.

--
Sent from my Android phone with K-9. Please excuse my brevity.

Jonathan Riddell (jr) on 2010-02-16
Changed in gpsd (Ubuntu):
status: Triaged → Fix Released
Charles Curley (charlescurley) wrote :

Be aware that upgrading gpsd to 2.92 or higher will break clients that are not in synch. 2.92 stripped out the old protocol.

Roadnav is one such client. It isn't available from the Ubuntu repos, but it is available from getdeb. I have it working with 2.92 (on Karmic), but not in a form I'm willing to release.

I think the version of gpsdrive in the Lucid repo is another.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers