Must run gpsbabel (gebabbel) as root to access Garmin usb:

Bug #991652 reported by Blown2bits
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gpsbabel (Ubuntu)

Bug Description

In order for gpsbabel to save gps data from a Garmin device (usb:), gpsbabel must be run as root.

Steps to reproduce problem:
1. Install gebabbel (includes gpsbabel).
2. Connect Garmin gps (in my case, a Garmin GPS 60)
3. Start gebabbel from console with: gebabbel
4. Make sure "In Type" is "garmin", and "In From" is "usb:"
5. Save as gpx, "~/Desktop/GarminWaypoint.gpx"

Note error from gpsbabel (through gebabbel dialog box):
Claim interfaced failed: could not claim interface 0: Operation not permitted
Also, note that output file does not exist.

1. Start gebabbel as root from console with: sudo gebabbel
2. Repeat steps 4 and 5 above.

Note that output file exists and data is copied correctly.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gebabbel 0.4+repack-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun Apr 29 20:38:42 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
 PATH=(custom, user)
SourcePackage: gebabbel
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Blown2bits (blown2bits) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gpsbabel (Ubuntu):
status: New → Confirmed
Revision history for this message
ckx (john2-hendrickx) wrote :

There was some relevant information from Herbert Kaminski on the Qlandkarte-users mailing list on May 1. By placing the following text in /etc/udev/rules.d/51-garmin.rules, I can now download waypoints and tracks from Qlandkartegt:

SUBSYSTEM=="usb", ATTR{idVendor}=="091e", ATTR{idProduct}=="0003", MODE="0660", GROUP="plugdev"

See Herbert's post at

I found some differences on my system. I don't have a /var/log/daemon.log file. Running "sudo udevadm control --reload-rules" did not work for me, a restart was required.

I tried to replicate the steps above but gebabbel is not present on my computer although gpsbabel is. The main thing for me is that I can use Qlandkartegt normally again under Ubuntu 12.04 (cf. duplicate bug

Revision history for this message
Dmitry Savvateev (savvdm) wrote :

I had the similar problem with OziExplorer under Wine - could not open GPS port on Lubuntu 12.04.

I noticed (after reading this) that /dev/ttyUSB0 belongs to 'dialout' group. Then I simply added my account to this group, and this solved my problem. Thanks for pointing this out!

The udev rule is probably a better solution, but this one works as well.

Revision history for this message
SMF (stephen-furner) wrote :

See question

I have only just discovered this bug report after going around this loop again 4 years later in 2016 with a Garmin GPS 96. The Gpsbabel support team were not happy Linux distribution were still going out with this problem in their hotplug. They claim its been a source of constant support demands on them to provide patches and work arounds for the last 10 years.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions