problems with time control: wrong icon, 100% on manual time adjustment

Bug #789691 reported by Glenn Horton-Smith on 2011-05-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpredict (Debian)
Fix Released
Unknown
gpredict (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gpredict

If I try to change the day or slide the slider in the time control, gpredict stops responding and uses 100% of CPU.
Also (and this may be unrelated?) the Time Controller dialog shows the wrong icon for the "Play Backwards" button.
Ubuntu 11.04 (natty).
Seen with both 1.1-7 nd 1.3 (Specifically, gpredict 1.1-7 from ubuntu.com natty/universe and also with gpredict 1.3-ppa4+natty from http://ppa.launchpad.net/gpredict-team/ppa/ubuntu/ natty/main.)

Related branches

AA1VS (hamaa1vs) wrote :

Hello,

The icon phenomenon I have encountered. The funny thing was the source looked right and if I displayed it over an ssh tunnel to a cygwin box the icons were correct.

Now for the 100% issue, do you use the default amateur module with the default location? Also are your elements up to date?

Tnx

Hello,
Thanks for the quick response. I used the default amateur model with a
different location. I just tried switching to the default location
("Copenhagen"), and the problem still happens. In case it matters, I had
added STS-134 to the satellite list in the module configuration, but the
problem still happens after removing it. The list of satellites being
displayed is just AO-27, AO-51, AO-7, FO-29, ISS, and VO-52. My elements
are up-to-date as of 2011-05-28 23:28 GMT.
Thanks for your work on GPredict!
Best regards,
Glenn Horton-Smith
N6OAL

On , AA1VS <email address hidden> wrote:
> Hello,

> The icon phenomenon I have encountered. The funny thing was the source

> looked right and if I displayed it over an ssh tunnel to a cygwin box

> the icons were correct.

> Now for the 100% issue, do you use the default amateur module with the

> default location? Also are your elements up to date?

> Tnx

> --

> You received this bug notification because you are a direct subscriber

> of the bug.

> https://bugs.launchpad.net/bugs/789691

> Title:

> problems with time control: wrong icon, 100% on manual time adjustment

> Status in “gpredict” package in Ubuntu:

> New

> Bug description:

> Binary package hint: gpredict

> If I try to change the day or slide the slider in the time control,
> gpredict stops responding and uses 100% of CPU.

> Also (and this may be unrelated?) the Time Controller dialog shows the
> wrong icon for the "Play Backwards" button.

> Ubuntu 11.04 (natty).

> Seen with both 1.1-7 nd 1.3 (Specifically, gpredict 1.1-7 from ubuntu.com
> natty/universe and also with gpredict 1.3-ppa4+natty from
> http://ppa.launchpad.net/gpredict-team/ppa/ubuntu/ natty/main.)

> To unsubscribe from this bug, go to:

> https://bugs.launchpad.net/ubuntu/+source/gpredict/+bug/789691/+subscribe

AA1VS (hamaa1vs) wrote :

Hello,

I tried to replicate your situation and was unable to. Would it be possible to tarball your .config/Gpredict directory so I can give it a try?

> Would it be possible to tarball your .config/Gpredict directory so I can
give it a try?

Sure, here it is attached. I also found out some more. If I take ISS out
of the satellites list in "Configure", then the 100% CPU does NOT happen.
If ISS is reenabled, the 100% happens.

Please note: In the tarball config attached, ISS is NOT in the list of
satellites being tracked, so you have to add it back in on "Configure" to
reproduce the error.

I compiled version 1.3 from source and ran it under the debugger, and got
the attached stack trace when it was in the 100% condition. I saw a
reference to the ISS data in the argument to one of the functions of the
stack trace, so that's why I tried taking ISS out of the display list.
Perhaps there is something funny about these particular ISS elements?

So then I wondered if it was perhaps due to the "decayed satellite" bug
reported in SourceForge tracker (ID: 3229639), which you had fixed with
commit 789. So I checked out the SVN trunk (@ rev 826) and compiled it.
But the 100% happens in trunk@826 too, in the same place according to the
gdb stack dump, so the problem is not solved.

One other thing to note: with ISS out of the list, all is still not well.
After manually changing the time, if I then try to resume "real time" mode,
it jumps to Dec 13, 1901. I also note in the stack trace that the first
argument to Calculate_User_PosVel() is "_time=_time=nan(0x8000000000000)".
I don't understand the code well enough to be sure, but that seems very
strange.

On the other issue: I tried running Gpredict under different windows
managers (plain gnome and twm) on the same netbook, and indeed the icons are
fine. But the 100% when changing time manually problem still happened with
ISS enabled. So the icon issue seems to be purely an issue specific to
"Unity", and the manual time control issue is unrelated to the window
manager.

In case it matters, I am using an HP netbook whose CPU is an Intel(R)
Atom(TM) CPU N455 @ 1.66GHz.

    Best regards.

On Sun, May 29, 2011 at 7:28 AM, AA1VS <email address hidden> wrote:

> Hello,
>
> I tried to replicate your situation and was unable to. Would it be
> possible to tarball your .config/Gpredict directory so I can give it a
> try?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/789691
>
> Title:
> problems with time control: wrong icon, 100% on manual time adjustment
>
> Status in “gpredict” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: gpredict
>
> If I try to change the day or slide the slider in the time control,
> gpredict stops responding and uses 100% of CPU.
> Also (and this may be unrelated?) the Time Controller dialog shows the
> wrong icon for the "Play Backwards" button.
> Ubuntu 11.04 (natty).
> Seen with both 1.1-7 nd 1.3 (Specifically, gpredict 1.1-7 from ubuntu.comnatty/universe and also with gpredict 1.3-ppa4+natty from
> http://ppa.launchpad.net/gpredict-team/ppa/ubuntu/ natty/main.)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gpredict/+bug/789691/+subscribe
>

AA1VS (hamaa1vs) wrote :

Thank you for the tarball. It replicates on my machine.

AA1VS (hamaa1vs) wrote :

As a work around please switch to using UTC time instead of local time. Local time appears to be broken.

AA1VS (hamaa1vs) wrote :

Glenn,

Please find attached a patch for the time controller and the time engine that might help. It may require further testing and is preliminary.

If you care for the bloody details, the Julian time functions use the calendar year and the gmtime functions use year-1900. This patch addresses that.

Further comparisons between gpredict running in UTC mode and in localtime would be appreciated.

Indeed, everything works fine if I stick to GMT. I had forgotten I had
changed that option.

With the patch, I now find no problem with the localtime option. The time
control works as expected now, no 100% CPU issues. I tried the patch on
both the 1.3 source and the svn head, and it worked fine with both. Thanks!

73

On , AA1VS <email address hidden> wrote:
> Glenn,

> Please find attached a patch for the time controller and the time engine

> that might help. It may require further testing and is preliminary.

> If you care for the bloody details, the Julian time functions use the

> calendar year and the gmtime functions use year-1900. This patch

> addresses that.

> Further comparisons between gpredict running in UTC mode and in localtime
> would be appreciated.

> ** Patch added: "UTC v local time patch for time controller"

> https://bugs.launchpad.net/ubuntu/+source/gpredict/+bug/789691/+attachment/2147262/+files/UTC_TIME_CONTROLLER.patch

> --

> You received this bug notification because you are a direct subscriber

> of the bug.

> https://bugs.launchpad.net/bugs/789691

> Title:

> problems with time control: wrong icon, 100% on manual time adjustment

> Status in “gpredict” package in Ubuntu:

> New

> Bug description:

> Binary package hint: gpredict

> If I try to change the day or slide the slider in the time control,
> gpredict stops responding and uses 100% of CPU.

> Also (and this may be unrelated?) the Time Controller dialog shows the
> wrong icon for the "Play Backwards" button.

> Ubuntu 11.04 (natty).

> Seen with both 1.1-7 nd 1.3 (Specifically, gpredict 1.1-7 from ubuntu.com
> natty/universe and also with gpredict 1.3-ppa4+natty from
> http://ppa.launchpad.net/gpredict-team/ppa/ubuntu/ natty/main.)

> To unsubscribe from this bug, go to:

> https://bugs.launchpad.net/ubuntu/+source/gpredict/+bug/789691/+subscribe

tags: added: patch
AA1VS (hamaa1vs) wrote :

Did I miss a step when uploading the patch?

My apologies.
On May 30, 2011 1:41 PM, "Brian Murray" <email address hidden> wrote:
> ** Tags added: patch
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/789691
>
> Title:
> problems with time control: wrong icon, 100% on manual time adjustment
>
> Status in “gpredict” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: gpredict
>
> If I try to change the day or slide the slider in the time control,
gpredict stops responding and uses 100% of CPU.
> Also (and this may be unrelated?) the Time Controller dialog shows the
wrong icon for the "Play Backwards" button.
> Ubuntu 11.04 (natty).
> Seen with both 1.1-7 nd 1.3 (Specifically, gpredict 1.1-7 from ubuntu.comnatty/universe and also with gpredict 1.3-ppa4+natty from
http://ppa.launchpad.net/gpredict-team/ppa/ubuntu/ natty/main.)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gpredict/+bug/789691/+subscribe

AA1VS (hamaa1vs) wrote :

Related to the wrong icon appearing.

Many themes do not appear to define the stock media play right to left variant.

To whom does one report this?

AA1VS (hamaa1vs) wrote :

I have recipe for a solution for this problem. Ideally it would be fixed upstream in the themes but for now....

For the theme Humanity which appears to be the default on my machine:
in /usr/share/icons/Humanity/actions/ there are several subdirectories with a file called media-playback-start.svg (these are the playback icons).

Using inkscape I flipped them horizontally. (for png's, you might want to use convert for this.) and save the file to media-playback-start-rtl.svg

I then ran gtk-update-icon-cache /usr/share/icons/Humanity to update the cache.

Voila... Stuff starts working.

I will attach a tarball with the updated icons to save others the inkscape learning curve.

Similiar results have been achieved on Fedora using convert and png's.

AA1VS (hamaa1vs) wrote :
Daniel T Chen (crimsun) on 2011-07-19
tags: added: patch-forwarded-debian
removed: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpredict - 1.3-1ubuntu1

---------------
gpredict (1.3-1ubuntu1) oneiric; urgency=low

  * Apply patch from hamaa1vs to resolve the application becoming
    unresponsive when the day or time slider is adjusted.
    (LP: #789691)
 -- Daniel T Chen <email address hidden> Tue, 19 Jul 2011 17:18:01 -0400

Changed in gpredict (Ubuntu):
status: New → Fix Released
Changed in gpredict (Debian):
status: Unknown → New
Changed in gpredict (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.