Ubuntu

Segfault with bad atom error

Reported by Karl Lattimer on 2010-09-27
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gpointing-device-settings (Debian)
Fix Released
Unknown
gpointing-device-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gpointing-device-settings

Sorry for the poor backtrace, I can't find the appropriate debug packages :/

Starting program: /usr/bin/gpointing-device-settings
[Thread debugging using libthread_db enabled]
[New Thread 0x7fffeee77710 (LWP 3636)]
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).

Program received signal SIGSEGV, Segmentation fault.
0x00007fffef2dd2f5 in ?? ()
   from /usr/lib/gpointing-device-settings/module/touchpad.so
(gdb) bt
#0 0x00007fffef2dd2f5 in ?? ()
   from /usr/lib/gpointing-device-settings/module/touchpad.so
#1 0x0000000000401c19 in ?? ()
#2 0x0000000000402141 in ?? ()
#3 0x00007ffff480dd8e in __libc_start_main (main=<value optimised out>,
    argc=<value optimised out>, ubp_av=<value optimised out>,
    init=<value optimised out>, fini=<value optimised out>,
    rtld_fini=<value optimised out>, stack_end=0x7fffffffe278)
    at libc-start.c:226
#4 0x0000000000401b09 in ?? ()
#5 0x00007fffffffe278 in ?? ()
#6 0x000000000000001c in ?? ()
#7 0x0000000000000001 in ?? ()
#8 0x00007fffffffe544 in ?? ()
#9 0x0000000000000000 in ?? ()

Karl Lattimer (karl-qdh) wrote :

Forgot to mention, this is from the current maverick release as of 27/9/2010

Karl Lattimer (karl-qdh) wrote :

Same problem continues, here's with the debugging symbols;

(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y

Starting program: /usr/bin/gpointing-device-settings
[Thread debugging using libthread_db enabled]
[New Thread 0x7fffeeedb710 (LWP 2852)]
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).
An X error occurred. The error was BadAtom (invalid Atom parameter).

Program received signal SIGSEGV, Segmentation fault.
0x00007fffef3442f5 in set_tapping_time_from_preference (ui=0x6aff70,
    error=<value optimised out>) at gpds-touchpad-ui.c:969
969 gpds-touchpad-ui.c: No such file or directory.
 in gpds-touchpad-ui.c
(gdb) bt
#0 0x00007fffef3442f5 in set_tapping_time_from_preference (ui=0x6aff70,
    error=<value optimised out>) at gpds-touchpad-ui.c:969
#1 setup_current_values (ui=0x6aff70, error=<value optimised out>)
    at gpds-touchpad-ui.c:1005
#2 build (ui=0x6aff70, error=<value optimised out>) at gpds-touchpad-ui.c:1059
#3 0x0000000000401c19 in append_ui (icon_view=0x669210,
    notebook=<value optimised out>, ui=0x2) at gpointing-device-settings.c:106
#4 0x0000000000402141 in append_uis (argc=1, argv=0x7fffffffe288)
    at gpointing-device-settings.c:168
#5 main (argc=1, argv=0x7fffffffe288) at gpointing-device-settings.c:257

Paul Battley (pbattley) wrote :

Applying this change from upstream fixed the segfault for me.

tags: added: patch
Changed in gpointing-device-settings (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpointing-device-settings - 1.5.1-3

---------------
gpointing-device-settings (1.5.1-3) unstable; urgency=low

  * Bump standards to 3.9.1.
  * Move packaging to collab-maint.
  * Fix possible crash on start (Closes: #573979, LP: #648674).
 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 16 Nov 2010 10:05:49 +0000

Changed in gpointing-device-settings (Ubuntu):
status: New → Fix Released
Leandro Cioletti (leandro-mat) wrote :

I tried to run today gpointing in Lucid 64 bits and I got the seg fault error. I read in the above post that

" This bug was fixed in the package gpointing-device-settings - 1.5.1-3 "

Is this package available for Lucid ? Is there any expected time to it appear on the official repositories of Lucid ?
Thanks.

Tony Moran (awjm) wrote :

If this bug was fixed in package gpointing-device-settings - 1.5.1-3, where is this package?

Michal Čihař (nijel) wrote :
Tony Moran (awjm) wrote :

Well since the page you refer to lists gpointing-device-settings for Maverick Meerkat (current stable release) version as 1.5.1-2, then yes.

Version 1.5.1-3 is NOT referred to. Neither is it included in any current updates available for download.

Michal Čihař (nijel) wrote :

Yes, but there is 1.5.1-4, which surprisingly is newer than 1.5.1-3 and contains all it's fixes.

Tony Moran (awjm) wrote :

And what help is that to a complete novice?

I take it you are expecting them to know that a package for next release (that is still in development, as you well know) is okay to be installed on their system? And how on earth would they get to learn this, when all they might know is that gpointing-device-settings causes a Segmentation Fault error when they run it?

There are people on the planet that do not know as much about running linux as you evidently do. And why would they bother to learn?

Michal Čihař (nijel) wrote :

The question was "Where is the package?" and not "How can I get fixed package to my system?". Don't expect to get answers on questions you did not ask.

PS: I have no idea whether it is possible to install latest package on older Ubuntu versions, but I guess it should work.

Is there any way to get this into Maverick repos? It's a high-importance bug, you know.

Tony Moran (awjm) wrote :

"The question was "Where is the package?" and not "How can I get fixed package to my system?". Don't expect to get answers on questions you did not ask.

PS: I have no idea whether it is possible to install latest package on older Ubuntu versions, but I guess it should work.
"

Ah, the microsoft defence - thank you for pointing out the problem which we have fixed but you cannot actually use it.

Dne Wed, 22 Dec 2010 13:32:50 -0000
"Sergey \"Shnatsel\" Davidoff" <email address hidden> napsal(a):

> Is there any way to get this into Maverick repos? It's a high-importance
> bug, you know.

Sorry, I don't know how to make it into Maverick repos, I don't know
how these things work in Ubuntu.

--
 Michal Čihař | http://cihar.com | http://blog.cihar.com

Michal Čihař (nijel) wrote :

Dne Wed, 22 Dec 2010 16:46:31 -0000
Tony Moran <email address hidden> napsal(a):

> "The question was "Where is the package?" and not "How can I get fixed
> package to my system?". Don't expect to get answers on questions you did
> not ask.
>
> PS: I have no idea whether it is possible to install latest package on older Ubuntu versions, but I guess it should work.
> "
>
> Ah, the microsoft defence - thank you for pointing out the problem which
> we have fixed but you cannot actually use it.

You can still get the sources and build them for you if the binary
package does not work (have you at least tried to do so?). Or persuade
somebody who knows how to push upgrade into older Ubuntu to do it. Or
do it yourself.

I neither use Ubuntu nor know how to release this package in older
distribution, I just maintain the package in Debian and fixed this bug.

--
 Michal Čihař | http://cihar.com | http://blog.cihar.com

Phil Lord (phillip-lord) wrote :

I've tried the package on 10.10. The segfault has gone and it all appears to be working.

Many thanks. This was causing me a disproportionate amount of headache, as I find tapping to make a laptop largely unusable due to my wandering thumbs.

funicorn (funicorn) wrote :

Ubuntu 11.04, gpointing-device-settings, the "bad atom" bug comes back. And my alps touchpad cannot support scrolling.

James Yuen (jwingy) wrote :

I can also confirm this bug is back on (K)Ubuntu 11.04 with gpointing-device-settings version 1.5-1-4

schiemanski (schiemanski) wrote :

The message: An X error occurred. The error was BadAtom (invalid Atom parameter) is still present in Xubuntu 11.10 with gpointing-device-settings version 1.5.1-5

Stefano Prenna (stefanoprenna) wrote :

Confirmed in Ubuntu 11.10 - gpointing-device-settings v1.5.1-5ubuntu1

tekstr1der (tekstr1der) wrote :

This error is still occurring in Precise 12.04 x64 with daily build 03/19/2012

gpointing-device-settings 1.5.1-6

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.