gphoto2 fails to recognize current Canon S100 with An error occurred in the io-library ('Bad parameters')

Bug #1245303 reported by Mark Eichin on 2013-10-28
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gphoto2 (Ubuntu)
Undecided
Unassigned

Bug Description

x220t$ gphoto2 -l --debug
finds the camera, and then:

0.090692 gphoto2-camera(2): Listing folders in '/'...
0.090698 gphoto2-camera(2): Initializing camera...
0.090721 context(0): An error occurred in the io-library ('Bad parameters'): No error description available

Turns out this is fixed for 2.5.3 back in July (vs. the 2.5.2 that Saucy includes) though it appears that hasn't shipped yet.
http://sourceforge.net/p/gphoto/bugs/958/

This is, oddly, a regression from raring (which I guess didn't have the listing? and worked fine with this camera by default...)

I don't yet know of a workaround.

Mark Eichin (eichin-gmail) wrote :

(actually, sf/gphoto/958 only fixes the S110, based on looking at svn://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2/camlibs/canon/canon.c r14452, but the same fix is needed for the S100 on line 128 as well (should say 2000 instead of 2001.)

Mark Eichin (eichin-gmail) wrote :

https://sourceforge.net/p/gphoto/bugs/965/ includes a patch for the S100 case. The attached patch built and worked under Saucy with my own S100 (and includes the S110 case from upstream as well, though I didn't test that.)

The attachment "upstream-r14452-plus-S100-change" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Mark Eichin (eichin-gmail) wrote :

https://sourceforge.net/p/gphoto/bugs/965/

is the upstream recognition of the fix if anyone is motivated to cherry pick upstream revisions instead.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gphoto2 (Ubuntu):
status: New → Confirmed

Hi,

This bug seems to be closed.

Can someone confirm that ?

regards,
Herbert

Daniel Barrett (dbarrett-m) wrote :

It definitely works for me on Ubuntu 14.04.2 LTS, with my Canon S100. Previously, it didn't work.

Changed in gphoto2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers