libgpgme-dev installs libgpgme-pthread.so in /usr/lib/${DEB_HOST_MULTIARCH}, literally

Bug #1762384 reported by Corentin Noël on 2018-04-09
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gpgme1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
In Bionic, libgpgme-pthread.so it is installed in /usr/lib/${DEB_HOST_MULTIARCH} instead of /usr/lib/x86_64-linux-gnu (the variable is not replaced)

[Test case]
Check that package installs to correct location

[Regression potential]
Packages looking for libgpgme-pthread find it now and might enable gpgme when they did not.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gpgme1.0 (Ubuntu):
status: New → Confirmed
nitrogen (i-am-nitrogen) wrote :

Attaching a screenshot highlighting the issue.

Changed in gpgme1.0 (Ubuntu):
status: Confirmed → Triaged
status: Triaged → In Progress
status: In Progress → Fix Committed
Changed in gpgme1.0 (Ubuntu Bionic):
status: New → Triaged
description: updated
Changed in gpgme1.0 (Ubuntu Bionic):
status: Triaged → In Progress
tags: added: id-5b72f74a5a43864c2f8d1a10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpgme1.0 - 1.11.1-1ubuntu3

---------------
gpgme1.0 (1.11.1-1ubuntu3) cosmic; urgency=medium

  * Fix Build-Depends to use python3-all-dev instead of python3-dev

gpgme1.0 (1.11.1-1ubuntu2) cosmic; urgency=medium

  * Mak debian/libgpgme-dev.links executable, it uses dh-exec (LP: #1762384)

 -- Julian Andres Klode <email address hidden> Tue, 14 Aug 2018 16:32:44 +0200

Changed in gpgme1.0 (Ubuntu):
status: Fix Committed → Fix Released

Hello Corentin, or anyone else affected,

Accepted gpgme1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gpgme1.0/1.10.0-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gpgme1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Julian Andres Klode (juliank) wrote :

I checked the build logs for arm64, as they were done already, and it works:

old version -1ubuntu1:

lrwxrwxrwx root/root 0 2018-01-15 13:22 ./usr/lib/${DEB_HOST_MULTIARCH}/libgpgme-pthread.so -> libgpgme.so

with the -1ubuntu2 in proposed:

lrwxrwxrwx root/root 0 2018-08-14 14:53 ./usr/lib/aarch64-linux-gnu/libgpgme-pthread.so -> libgpgme.so

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpgme1.0 - 1.10.0-1ubuntu2

---------------
gpgme1.0 (1.10.0-1ubuntu2) bionic; urgency=medium

  * Make debian/libgpgme-dev.links executable, it uses dh-exec (LP: #1762384)
  * Drop python3.5 test since python3.5 is not supported (fixes autopkgtest)

 -- Julian Andres Klode <email address hidden> Tue, 14 Aug 2018 16:53:39 +0200

Changed in gpgme1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gpgme1.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers