gpgme1.0 doesn't work properly with gnupg 2.0

Bug #1564234 reported by Mario Limonciello on 2016-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnupg2 (Ubuntu)
Undecided
Unassigned
gpgme1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

In trying to debug https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1536871/comments/16 there has been the discovery that gpgme doesn't actually verify the version of gnupg on the system and sends arguments to it that are only supported in Gnupg 2.1.

http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=61a0d92b679f248505f1bf16386bc41a5bf2ba1d

This causes problems because the error doesn't populate up to apps as an import failure but rather a silent pass with no results.

Matthias Klose (doko) wrote :

now fixed in 16.04

Changed in gpgme1.0 (Ubuntu):
status: New → Fix Released
Changed in gpgme1.0 (Ubuntu):
status: Fix Released → Won't Fix
Matthias Klose (doko) on 2016-03-31
Changed in gnupg2 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers