FTBFS with a "shift: 2368: can't shift that many" error

Bug #415536 reported by Fabrice Coutadeur
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpe-expenses (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: gpe-expenses

Hi,

This package FTBFS in Karmic with the following error:
Making all in po-lib
make[3]: Entering directory `/build/buildd/gpe-expenses-0.1.7/po-lib'
cd .. \
   && CONFIG_FILES=po/Makefile.in CONFIG_HEADERS= CONFIG_LINKS= \
        /bin/sh ./config.status
config.status: creating po/Makefile.in
config.status: executing depfiles commands
shift: 2368: can't shift that many
make[3]: *** [stamp-it] Error 2
make[3]: Leaving directory `/build/buildd/gpe-expenses-0.1.7/po-lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/gpe-expenses-0.1.7'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/gpe-expenses-0.1.7'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

It seems that after updating the autconf file (aclocal, automake and autoconf), the package builds correctly. The package should be patch to regenerate autoconf files.

Cheers,
Fabrice

Changed in gpe-expenses (Ubuntu):
assignee: nobody → fabrice_sp (fabricesp)
status: New → Confirmed
Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

Debdiff with the fix

Changed in gpe-expenses (Ubuntu):
assignee: fabrice_sp (fabricesp) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpe-expenses - 0.1.7-2ubuntu1

---------------
gpe-expenses (0.1.7-2ubuntu1) karmic; urgency=low

  [ Fabrice Coutadeur ]
  * debian/rules: included CDBS DEB_AUTO_UPDATE_* variables to regenerate
    the autoconf files and fix a FTBFS (LP: #415536)

  [ Michael Casadevall ]
  * Manually merged from Debian grab additional fixes from 0.1.7-2

gpe-expenses (0.1.7-2) unstable; urgency=low

  * migrate to qofsql support instead of libgda3-3 (build-depend
    on latest QOF source and add shlibs.local for runtime support.)
  * Update standards version (no changes)
  * Clean up some generated man3 manpages for build-twice-in-a-row
    support.

 -- Michael Casadevall <email address hidden> Fri, 21 Aug 2009 02:35:18 -0400

Changed in gpe-expenses (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers