Upgrade GPaste to 3.32 for 19.04

Bug #1821410 reported by Eskander Bejaoui on 2019-03-22
100
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Gpaste
Fix Released
Unknown
gpaste (Ubuntu)
Low
Unassigned
Disco
Low
Unassigned

Bug Description

While Ubuntu 19.04 uses GNOME 3.32, the version of GPaste in the repos is 3.30.
GPaste 3.30 works as expected but gnome-shell-extensions-gpaste in not compatible with GNOME Shell 3.32
The upstream developer released the new version that works on GS 3.32 some days ago:
https://github.com/Keruspe/GPaste/releases/tag/v3.32.0
Please upgrade GPaste and its extension in the repos, otherwise it's unusable in Disco.

no longer affects: gpaste
tags: added: upgrade-software-version
Jeremy Bicha (jbicha) on 2019-03-23
tags: added: rls-dd-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gpaste (Ubuntu):
status: New → Confirmed

I uploaded an updated package on my personal PPA available at: https://launchpad.net/~danilopiazza/+archive/ubuntu/ppa/+sourcepub/10096097/+listing-archive-extra

To upgrade gpaste, I followed these steps:

1. Update the upstream source
2. Remove debian/patches/version-reqs.patch, as it has been integrated upstream
3. Require gnome-shell 3.32 in debian/control
4. Update some more dependencies in debian/control, according to meson.build

Changed in gpaste:
status: Unknown → Fix Released

The attachment "Patch from 3.30.2-1ubuntu1 to 3.32.0" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in gpaste (Ubuntu):
importance: Undecided → Low
Changed in gpaste (Ubuntu Disco):
importance: Undecided → Low
Simon Quigley (tsimonq2) wrote :

Hello, thank you for your work on this bug!

In order to upload to a stable release, the bug description needs to be updated to follow the Stable Release Update template: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Please resubscribe sponsors when this is done.

The new GPaste package worked perfectly with GNOME Shell 3.32.0+git20190410-1ubuntu1, but there are some regressions when using 3.32.1-1ubuntu1~19.04.1 from disco-proposed.

Since the regression potential is high (repeatedly crashing GNOME Shell will kill the user session), I am holding the SRU request for now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.