gpartedbin crashed with SIGABRT in ped_assert()

Bug #981636 reported by Bruno Medeiros on 2012-04-14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)

Bug Description

I got it when I tried to apply another operation while there is already an operation running. I was moving a partition and realized that gparted was allowing me to do another operation, so I tried, just to test. And I got this after press apply and try to cancel the second one.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gparted 0.11.0-2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Sat Apr 14 02:06:13 2012
ExecutablePath: /usr/sbin/gpartedbin
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: /usr/sbin/gpartedbin
 PATH=(custom, no user)
Signal: 6
SourcePackage: gparted
 raise () from /lib/x86_64-linux-gnu/
 abort () from /lib/x86_64-linux-gnu/
 ped_assert () from /lib/x86_64-linux-gnu/
 ped_device_write () from /lib/x86_64-linux-gnu/
 ?? ()
Title: gpartedbin crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)

Bruno Medeiros (brunojcm) wrote :

 ped_assert () from /tmp/tmpVcGWq2/lib/x86_64-linux-gnu/
 ped_device_write () from /tmp/tmpVcGWq2/lib/x86_64-linux-gnu/
 GParted::GParted_Core::copy_block (this=0x7fff87aba020, lp_device_src=<optimized out>, lp_device_dst=0x7f3cc0012d90, offset_src=427387340, offset_dst=593195008, block_length=<optimized out>, error_message=..., readonly=false) at
 GParted::GParted_Core::copy_blocks (this=0x7fff87aba020, src_device=..., dst_device=..., src_start=545104331, dst_start=710911999, length=193188593664, blocksize=-8388608, operationdetail=..., readonly=false, total_done=@0x7f3cc98e7518) at
 GParted::GParted_Core::copy_filesystem (this=0x7fff87aba020, src_device=..., dst_device=..., src_start=167782860, dst_start=333590528, src_sector_size=512, dst_sector_size=512, src_length=193272479744, operationdetail=..., readonly=false, total_done=@0x7f3cc98e7518) at

Changed in gparted (Ubuntu):
importance: Undecided → Medium
summary: - gpartedbin crashed with SIGABRT in raise()
+ gpartedbin crashed with SIGABRT in ped_assert()
tags: removed: need-amd64-retrace
Phillip Susi (psusi) on 2013-06-21
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gparted (Ubuntu):
status: New → Confirmed
Curtis Gedak (gedakc) wrote :

Only one GParted process is *supposed* to be permitted to run at any one time. From testing the gparted 0.11.0 package in ubuntu 12.04, I can confirm that multiple running copies of GParted are permitted.

An enhancement was made to GParted 0.16.2 that permits only one instance of GParted to execute at a time. Following is a link to the relevant upstream bug report that also contains the "permit only one running instance" patch.

gparted doesn't inhibit systemd mounting, leading to potential data loss

GParted 0.16.2 was released upstream on September 18, 2013.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.