Ubuntu

debsums reports mismatch for a PNG file

Reported by Hernando Torque on 2012-02-19
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Unassigned
gnome-media (Ubuntu)
Low
Unassigned
gnome-system-monitor (Ubuntu)
Low
Unassigned
gparted (Ubuntu)
Low
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

debsums reports this PNG file being changed:

/usr/share/gnome/help/gnome-sound-recorder/uk/figures/grecord_window.png

According to the build log, other PNG files were optimized too, but debsum doesn't report those, so I don't think this is a problem with OptiPNG.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-media 2.91.2-3ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 19 18:18:04 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
SourcePackage: gnome-media
UpgradeStatus: No upgrade log present (probably fresh install)

Hernando Torque (htorque) wrote :
Sebastien Bacher (seb128) wrote :

Thanks hernando, I'm not sure it's a bug on those packages though, they didn't change or do anything special, seems rather a bug in the packaging tools if somewhere...

Sebastien Bacher (seb128) wrote :

Martin, do you have any clue about this issue?

Hernando Torque (htorque) wrote :

FWIW (from a dupe): all the files are just symlinks to the "/usr/share/gnome/help/.../C/..." version of the images.

Sebastien Bacher (seb128) wrote :

Right, that's wanted, pkgbinarymangler does that to spare space, it should only do it when images are identical though so it shouldn't lead to checksum differences

Could be an effect of e. g. bug 923407. It's worth trying a local
build with current pkgbinarymangler, and if that is correct, doing a
no-change upload.

Sebastien Bacher (seb128) wrote :

Confirmed, a rebuild seems to do it

Changed in gnome-media (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 2.91.2-3ubuntu5

---------------
gnome-media (2.91.2-3ubuntu5) precise; urgency=low

  * Rebuild with new pkgbinarymangle to fix md5sum issues (lp: #936368)
 -- Sebastien Bacher <email address hidden> Mon, 20 Feb 2012 16:31:10 +0100

Changed in gnome-media (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Ok, adding the component from the duplicates and setting the GNOME components that will get an upload this week (new GNOME coming) to fix commited

Changed in gnome-system-monitor (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
Changed in evince (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
Changed in totem (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
Changed in gparted (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.0.1-0ubuntu18

---------------
totem (3.0.1-0ubuntu18) precise; urgency=low

  * Rebuild with new pkgbinarymangle to fix md5sum issues (lp: #936368)
 -- Sebastien Bacher <email address hidden> Mon, 20 Feb 2012 16:45:00 +0100

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-monitor - 3.3.90-0ubuntu1

---------------
gnome-system-monitor (3.3.90-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Hide kthreadd by default (LP: #406825)
    - Fix crash if default colors list is shorter than the number of CPUs.
      (LP: #919014)
  * Rebuild against current pkgbinarymangler to fix md5sums. (LP: #936368)
  * 02_lpi.patch: Unfuzz.
 -- Martin Pitt <email address hidden> Wed, 22 Feb 2012 08:09:45 +0100

Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Fix Released
Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Phillip Susi (psusi) on 2013-06-21
Changed in gparted (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers