Gparted does not start and continues to scan devices

Bug #910379 reported by Carla Sella on 2011-12-31
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Medium
gparted (Ubuntu)
Low
Phillip Susi
parted (Ubuntu)
Undecided
Phillip Susi

Bug Description

I have Precise Pangolin Alpha 1 with all updates installed.
When launching Gparted it continues to scan for devices and never starts.
I tried as normal user, as root, with and without a usb key attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gparted 0.8.1-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Sat Dec 31 16:18:08 2011
ExecutablePath: /usr/sbin/gpartedbin
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: gparted
UpgradeStatus: Upgraded to precise on 2011-12-02 (28 days ago)
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2143): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2148): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (gnome-panel:2275): Gtk-WARNING **: cannot open display: :1.0

Related branches

Carla Sella (carla-sella) wrote :
Phillip Susi (psusi) wrote :

At the bottom of the window, it should specify what device it is scanning. Can you tell me what that is?

Changed in gparted (Ubuntu):
status: New → Incomplete
Curtis Gedak (gedakc) wrote :

Would you please also provide the output from the following command while GParted is scanning:

ps -ef | egrep -i "dosfsck|ntfsresize"

If the problem occurs with NTFS or FAT file systems, then sometimes running a disk check or defragmenting the file system can fix the problem.

Carla Sella (carla-sella) wrote :

Hi Philipp,
I cannot se what devices it's trying to scan.
I launched gparted from terminal, but there's no output, see attached immage.

I have this output on /var/log/syslog, but these messages occur also when gparted is closed so I'm not sure they are caused by gparted:

Jan 4 11:30:07 charlie02 kernel: [ 5986.764506] end_request: I/O error, dev fd0, sector 0
Jan 4 11:30:07 charlie02 kernel: [ 5986.764520] Buffer I/O error on device fd0, logical block 0
Jan 4 11:30:20 charlie02 kernel: [ 5998.932486] end_request: I/O error, dev fd0, sector 0
Jan 4 11:30:20 charlie02 kernel: [ 5998.932500] Buffer I/O error on device fd0, logical block 0
Jan 4 11:30:32 charlie02 kernel: [ 6011.100471] end_request: I/O error, dev fd0, sector 0
Jan 4 11:30:32 charlie02 kernel: [ 6011.100485] Buffer I/O error on device fd0, logical block 0
Jan 4 11:30:44 charlie02 kernel: [ 6023.268967] end_request: I/O error, dev fd0, sector 0
Jan 4 11:30:44 charlie02 kernel: [ 6023.268979] Buffer I/O error on device fd0, logical block 0

Carla Sella (carla-sella) wrote :

Hello Curtis,
This is the output while Gparted is running:

root@charlie02:/var/log# ps -ef | egrep -i "dosfsck|ntfsresize"
root 7889 7535 0 11:33 pts/0 00:00:00 egrep -i dosfsck|ntfsresize
root@charlie02:/var/log#

On this PC I do not have NTFS or FAT filesystems:

root@charlie02:/home/charlie/Desktop# fdisk -l

Disk /dev/sda: 400.1 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders, total 781422768 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf6bf21de

   Device Boot Start End Blocks Id System
/dev/sda1 * 63 112454999 56227468+ 83 Linux
/dev/sda2 118752480 760942591 321095056 83 Linux
/dev/sda3 112455000 118752479 3148740 82 Linux swap / Solaris
/dev/sda4 760944638 781420543 10237953 5 Extended
/dev/sda5 760944640 781420543 10237952 83 Linux

Partition table entries are not in disk order
root@charlie02:/home/charlie/Desktop#

Phillip Susi (psusi) wrote :

It looks like it is trying to scan your floppy drive, and I assume you do not actually have one. You need to configure your bios to not think you have a floppy drive if you don't actually have one.

Carla Sella (carla-sella) wrote :

Great!
I disabled "Legacy diskette" in my PC's BIOS and now gparted works.

I have one argument though:
Before precise pangolin gparted used to work also with legacy diskette enabled in my BIOS.
Can't this be fixed ?
Thank you.

Curtis Gedak (gedakc) wrote :

The problem with GParted taking a long time scanning a non-existent floppy drive is identified in the FAQ.
http://gparted.org/faq.php#faq-11

The relevant bug report is:
Bug 351753 - missing floppy causes loop on scan devices
https://bugzilla.gnome.org/show_bug.cgi?id=351753

The fix back then involved changing GParted to parse the /proc/partitions file, and only use
libparted ped_device_probe_all() function call if /proc/partitions does not exist.

In Precise Pangolin, has the /proc/partitions file disappeared?

Phillip Susi (psusi) wrote :

Can you turn the floppy back on and run "sudo strace -e trace=files /usr/sbin/gpartedbin" and post the last 15 or so lines?

Carla Sella (carla-sella) wrote :
Download full text (5.7 KiB)

Here are the last lines of "sudo strace -e trace=file /usr/sbin/gpartedbin" (I put file instead of files, files gave me an error):

open("/usr/local/share//mime/aliases", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/share//mime/subclasses", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/share//mime/icons", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/share//mime/generic-icons", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/share//mime/mime.cache", {st_mode=S_IFREG|0644, st_size=123508, ...}) = 0
open("/usr/share//mime/mime.cache", O_RDONLY) = 5
open("/usr/share/icons/Humanity/actions/24/document-new.svg", O_RDONLY) = 5
stat("/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so", {st_mode=S_IFREG|0644, st_size=10464, ...}) = 0
open("/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so", O_RDONLY) = 6
open("/etc/ld.so.cache", O_RDONLY) = 6
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/librsvg-2.so.2", O_RDONLY) = 6
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/libcroco-0.6.so.3", O_RDONLY) = 6
access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/libxml2.so.2", O_RDONLY) = 6
lstat("/usr/share/icons/Humanity/actions/24/edit-delete.svg", {st_mode=S_IFREG|0644, st_size=3191, ...}) = 0
open("/usr/share/icons/Humanity/actions/24/edit-delete.svg", O_RDONLY) = 5
lstat("/usr/share/icons/Humanity/actions/24/go-last.svg", {st_mode=S_IFREG|0644, st_size=5529, ...}) = 0
open("/usr/share/icons/Humanity/actions/24/go-last.svg", O_RDONLY) = 5
lstat("/usr/share/icons/Humanity/actions/24/edit-copy.svg", {st_mode=S_IFREG|0644, st_size=2034, ...}) = 0
open("/usr/share/icons/Humanity/actions/24/edit-copy.svg", O_RDONLY) = 5
lstat("/usr/share/icons/Humanity/actions/24/edit-paste.svg", {st_mode=S_IFREG|0644, st_size=3396, ...}) = 0
open("/usr/share/icons/Humanity/actions/24/edit-paste.svg", O_RDONLY) = 5
lstat("/usr/share/icons/Humanity/actions/24/edit-undo.svg", {st_mode=S_IFREG|0644, st_size=3666, ...}) = 0
open("/usr/share/icons/Humanity/actions/24/edit-undo.svg", O_RDONLY) = 5
lstat("/usr/share/icons/Humanity/actions/24/gtk-apply.svg", {st_mode=S_IFLNK|0777, st_size=16, ...}) = 0
stat("/usr/share/icons/Humanity/actions/24/gtk-apply.svg", {st_mode=S_IFREG|0644, st_size=2420, ...}) = 0
readlink("/usr/share/icons/Humanity/actions/24/gtk-apply.svg", "dialog-apply.svg", 256) = 16
open("/usr/share/icons/Humanity/actions/24/gtk-apply.svg", O_RDONLY) = 5
lstat("/usr/share/icons/hicolor/22x22/apps/gparted.png", {st_mode=S_IFREG|0644, st_size=1031, ...}) = 0
open("/usr/share/icons/hicolor/22x22/apps/gparted.png", O_RDONLY) = 5
stat("/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so", {st_mode=S_IFREG|0644, st_size=23088, ...}) = 0
open("/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so", O_RDONLY) = 6
lstat("/usr/share/icons/hicolor/16x16/apps/gparted.png", {st_mode=S_IFREG|0644, st_size=729, ...

Read more...

Carla Sella (carla-sella) wrote :
Download full text (9.0 KiB)

If of any help I ran ""sudo strace /usr/sbin/gpartedbin" these are the last lines of output:

read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"5\30\4\0\35\206 \4\4\0 \4\270\1\25\0\230\4\5\0\36\206 \4\35\206 \4!\1\0\0"..., 13392}, {"\0\0\0\0\0\1\0\0\0\200\7\0\0\0\0\0\0s\7\0\0\1\0\0\0\200P\0\0\0\0\0"..., 3800}, {"", 0}], 3) = 17192
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\230\6\5\0007\206 \4\0\0\0\0\0\0\0\0X\0\23\0\230\nt\0\5\206 \0047\0 \4"..., 1424}, {NULL, 0}, {"", 0}], 3) = 1424
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
nanosleep({0, 10000000}, NULL) = 0
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"5\30\4\0;\206 \4\4\0 \4\270\1\25\0\230\4\5\0<\206 \4;\206 \4!\1\0\0"..., 13392}, {"\0\0\0\0\0\1\0\0\0\200\7\0\0\0\0\0\0s\7\0\0\1\0\0\0\200P\0\0\0\0\0"..., 3800}, {"", 0}], 3) = 17192
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\230\6\5\0U\206 \4\0\0\0\0\0\0\0\0X\0\23\0\230\nt\0\5\206 \0047\0 \4"..., 1424}, {NULL, 0}, {"", 0}], 3) = 1424
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
nanosleep({0, 10000000}, NULL) = 0
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xdf06c4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}], 2, 0) = 0 (Timeout)
read(4, 0x7fff494d46a0, 16) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"5\30\4\0Y\206 \4\4\0 \4\270\1\25\0\230\4\5\0Z\206 \4Y\206 \4!\1\0\0"..., 13392}, {"\0\0\0\0\0\1\0\0\0\200\7\0\0\0\0\0\0s\7\0\0\1\0\0\0\200P\0\0\0\0\0"..., 3800}, {"", 0}], 3) = 17192
poll([{fd=3, events=POLLIN|POLLOUT}], 1,...

Read more...

Phillip Susi (psusi) wrote :

Well I was hoping to see an open() in there on /dev/fd to confirm that it is hanging up on that floppy. I'm not sure why it would change between releases of Ubuntu, but if the floppy is the problem, then this is at its core a hardware configuration issue. It doesn't really make sense to bother scanning floppies in the first place though, since they can not be partitioned, so I have submitted a patch upstream to skip them.

I'll see about merging it into ubuntu.

Changed in gparted (Ubuntu):
assignee: nobody → Phillip Susi (psusi)
importance: Undecided → Low
status: Incomplete → In Progress
Curtis Gedak (gedakc) wrote :

Carla, do you have the dmraid package installed?

If so, would you please try the following command and let us know the results:

     sudo dmraid -sa -c

This is to test if scanning of the floppy drive is related to the dmraid command.

Carla Sella (carla-sella) wrote :

Yes I have dmraid installed

This is the result:

charlie@charlie02:~$ sudo dmraid -sa -c
[sudo] password for charlie:
no raid disks
charlie@charlie02:~$

Curtis Gedak (gedakc) wrote :

Okay, that confirms that dmraid is not part of the problem. I didn't think it was, but it is always good to check.

On 1/5/2012 12:18 PM, Curtis Gedak wrote:
> Okay, that confirms that dmraid is not part of the problem. I didn't
> think it was, but it is always good to check.

What about kpartx?

Carla Sella (carla-sella) wrote :

I do not have kpartx installed.

Curtis Gedak (gedakc) wrote :

Thanks for checking kpartx. GParted removed use of kpartx in version 0.8.1, which was adopted in Oneiric Ubuntu (11.10).

Carla, would you be able to provide the results of the following command?

     sudo blkid -c /dev/null

Carla Sella (carla-sella) wrote :

This is the output of sudo blkid -c /dev/null:

charlie@charlie02:~$ sudo blkid -c /dev/null
/dev/zram0: UUID="22899080-92c1-4a74-9265-b7e580a6239e" TYPE="swap"
/dev/sda1: UUID="1ab3c2d9-9b38-4502-9e2a-434ec6833169" TYPE="ext4"
/dev/sda2: UUID="7559004b-3edf-46f5-8faa-723082912704" TYPE="ext4"
/dev/sda3: UUID="370b4504-ac8b-49f5-b54b-052fa5b01b25" TYPE="swap"
/dev/sda5: UUID="67982a72-683b-4728-b4ee-26154ef4f452" TYPE="ext4"
charlie@charlie02:~$

The only thing is that I had to wait like 15 minutes for this output, I wanted to press ctrl+c to get out, but decided to wait and see what would happen, so I waited a lot.

Phillip Susi (psusi) wrote :

On 1/5/2012 3:20 PM, Carla Sella wrote:
> This is the output of sudo blkid -c /dev/null:

Say Curtis, why do you use -c /dev/null? Why not let blkid use its
cache to speed things up?

> The only thing is that I had to wait like 15 minutes for this output,
> I wanted to press ctrl+c to get out, but decided to wait and see what
> would happen, so I waited a lot.

I think we found our culprit.

Curtis Gedak (gedakc) wrote :

Aha! So the delay is due to calling blkid.

Phillip, are you able to bring this problem with blkid searching non-existent floppy drive to the attention of the right people?

Curtis Gedak (gedakc) wrote :

Phillip,

In the past if I changed the label of a partition with GParted and then called blkid, I received the cached result which was the old label. That is why I used the "-c /dev/null" to force blkid to re-read the information.

I have not tested to see if blkid still has this same behaviour.

Phillip Susi (psusi) wrote :

On 1/5/2012 4:05 PM, Curtis Gedak wrote:
> Phillip, are you able to bring this problem with blkid searching non-
> existent floppy drive to the attention of the right people?

I don't think it is considered a bug by anyone. If the bios claims you
have a floppy, then the kernel thinks you have a floppy. If you try to
access the floppy, the the kernel tries it's hardest to access it, even
though it keeps failing.

> In the past if I changed the label of a partition with GParted and then
> called blkid, I received the cached result which was the old label.
> That is why I used the "-c /dev/null" to force blkid to re-read the
> information.
>
> I have not tested to see if blkid still has this same behaviour.

Right, if you call it before udev has had a chance to run it to update
the cache, that would happen. If you are changing the label, why don't
you just update your cached label directly instead of querying blkid again?

Curtis Gedak (gedakc) wrote :

> On 1/5/2012 4:05 PM, Curtis Gedak wrote:
>> Phillip, are you able to bring this problem with blkid searching non-
>> existent floppy drive to the attention of the right people?
>
> I don't think it is considered a bug by anyone. If the bios claims you
> have a floppy, then the kernel thinks you have a floppy. If you try to
> access the floppy, the the kernel tries it's hardest to access it, even
> though it keeps failing.

I do agree Phillip that the root cause of the problem is an incorrectly configured BIOS. Having said that, it would be nice if blkid could handle this situation better instead of scanning for a very long time.

Another reason to bring this to the attention of the blkid people is that according to Carla, the previous versions of blkid does not appear to exhibit this behaviour. Hence this looks like a recently introduced change/problem.

> > In the past if I changed the label of a partition with GParted and then
> > called blkid, I received the cached result which was the old label.
> > That is why I used the "-c /dev/null" to force blkid to re-read the
> > information.
> >
> > I have not tested to see if blkid still has this same behaviour.
>
> Right, if you call it before udev has had a chance to run it to update
> the cache, that would happen. If you are changing the label, why don't
> you just update your cached label directly instead of querying blkid again?

The main reason to not update the GParted cache directly is that then we won't know if the label write really succeeded. The only way to be sure the label was written correctly is to physically re-read the label from the disk. By re-reading the disk label we can learn if the label was truncated or not written for some reason.

Regarding waiting for udev to update it's cache, do you think a "udevadm settle" would be sufficient before a call to "blkid" to ensure that has up-to-date information?

Phillip Susi (psusi) wrote :

On 1/6/2012 11:41 AM, Curtis Gedak wrote:
> Regarding waiting for udev to update it's cache, do you think a "udevadm
> settle" would be sufficient before a call to "blkid" to ensure that has
> up-to-date information?

Yes, that should do it.

Curtis Gedak (gedakc) wrote :

Since GParted already includes a call to "udevadm settle" I removed the "-c /dev/null" and tested with ubuntu 11.04 and 10.04. Both of these worked correctly. :-)

As such I have committed the following patch to the upstream GParted code repository:

Fix long scan problem when BIOS floppy setting incorrect
http://git.gnome.org/browse/gparted/commit/?id=18f863151c82934fe0a980853cc3deb1e439bec2

Carla, would you be able to test with this new patch?

Instructions on to retrieve and compile GParted from the git source code repository can be found at the following link:
http://gparted.org/git.php

Carla Sella (carla-sella) wrote :

Hello Curtis,
I tried to retrieve and compile GParted from the git source code repository, but it needs glib-gettext >= 2.2.0 on Ubuntu Precise I have 0.18.1.
I tried to install 2.2.0 but I'm having other problems, I'll try to work it out so I can test the new patch for you.

Carla Sella (carla-sella) wrote :

Sorry couldn't finish installation, during make got this output and do not know how to fix it:

In file included from ../include/../include/../include/../include/i18n.h:9:0,
                 from ../include/../include/../include/Utils.h:28,
                 from ../include/../include/Partition.h:27,
                 from ../include/Device.h:22,
                 from Device.cc:19:
/usr/include/glibmm-2.4/glibmm/i18n.h:27:24: fatal error: glib/gi18n.h: No such file or directory
compilation terminated.
make[2]: *** [Device.o] Error 1
make[2]: Leaving directory `/home/charlie/gparted/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/charlie/gparted'
make: *** [all] Error 2

Curtis Gedak (gedakc) wrote :

Perhaps you are simply missing a dependency.

Would you please try the following command to ensure the dependencies are installed. This command last tested with Ubuntu 11.10 if I recall correctly.

sudo apt-get install build-essential e2fsprogs uuid uuid-dev \
                           gnome-common libparted-dev libgtkmm-2.4-dev \
                           libdevmapper-dev gnome-doc-utils

Then try the build again: ./configure && make

Carla Sella (carla-sella) wrote :

Hello Curtis,
First thanks for your help.
I think I made a bit of a mess.
I wasn't able to start my PC, for some reason I still have to find out, it freezed on "checking battery state...", but this is not your problem.
The fact is that I installed today's Precise Pangolin iso on the sda5 partition (it was free for tests) the Precise Pangolin I can't start as it freezes is on sda1.
I wanted to try to retrieve and compile GParted from the git source code repository on sda5, but first I installed Gparted from Ubuntu repositories just to verify that it would have the same problems I had on sda1.
The fact is that Gparted installed from Ubuntu repositories just works fine on sda5, so probably the problem I have on the sda1 partition and that I have been reporting as a bug is something else.
What should I do at this point ? Sorry for the mess.

Curtis Gedak (gedakc) wrote :

When you tested, did you still have your BIOS incorrectly set to say a floppy drive is present when there really isn't a floppy drive physically installed?

Carla Sella (carla-sella) wrote :

Yes, I checked it immediatly when I saw Gparted work.

Curtis Gedak (gedakc) wrote :

Based on that then I think this bug can be closed.

I do plan to keep the change to GParted since it does not appear to cause any harm, and it will offer a slight performance improvement when GParted rescans disk devices.

Carla Sella (carla-sella) wrote :

ok thank you.

Phillip Susi (psusi) on 2012-01-08
Changed in parted (Ubuntu):
status: New → In Progress
assignee: nobody → Phillip Susi (psusi)
Changed in gparted:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 2.3-8ubuntu2

---------------
parted (2.3-8ubuntu2) precise; urgency=low

  * Add 16-dos-partitions.patch: Fix parted to correctly handle
    more than 16 partitions on dos partition tables.
  * Add dm-part-sync.patch: Backport fix to allow modifying partitions
    on dmraid disks while other partitions are in use.
  * Replace dmraid.patch: Reimplemented and forwarded upstream,
    allows dmraid raid10 disks to show up (LP: #311179)
  * Replace loop-partitions.patch: this patch used to make sure that
    we don't try to partition loop devices. Now it backports a few
    upstream changes to allow partitioning loop devices since that is
    supported on Linux since 3.0. It includes a change that also fixes
    support for > 16 partitions.
  * Add skip-floppy.patch: don't probe floppy drives. (LP: #910379)
 -- Phillip Susi <email address hidden> Sat, 03 Dec 2011 09:50:05 -0500

Changed in parted (Ubuntu):
status: In Progress → Fix Released
Phillip Susi (psusi) on 2012-01-30
Changed in gparted (Ubuntu):
status: In Progress → Fix Released
dino99 (9d9) wrote :

Got the same issue on Precise i386 with 0.11 version:
Its the first time i try to use gparted since we got 0.11 version on Precise i386. Loading it from the menu (gnome-classic) fails with this error:

- the first time, a greyed parted dialogbox start to scan to find hdds (have 2 pata + 1 sata) but found nothing, then get the error.
- the next times i even does not get the dialogbox, it silently exit and give again:

error: libhal_acquire_global_interface_lock: org.freedesktop.Hal.Device.InterfaceAlreadyLocked: The interface org.freedesktop.Hal.Device.Storage is already exclusively locked either by someone else or it's already locked by yourself

then lot of messages like:

libgdu-WARNING **: Partition /org/freedesktop/UDisks/devices/sdc7 is a logical partition but no extended partition exists

Finally found the reason: the floppy ghost was activated into the silly bios. That bios propose to boot on something not existing in that box.

Effectively now gparted works, but its stupid too: it should not fail to detect the real hardware, it's his first job, even if a virtual ghost and/or a corrupted device is found, it need & might be able to work with the other devices.

So this report should not be set as "fixed"

dino99 (9d9) wrote :

on Precise, packages used are:
- parted 2.3-8ubuntu3
- gparted 0.11.0-1

Phillip Susi (psusi) wrote :

Ahh yes, gparted also needs the change to how it invokes blkid.

Changed in gparted (Ubuntu):
status: Fix Released → Triaged
Curtis Gedak (gedakc) wrote :

The upstream patch for the change on blkid invocation can be found at the following link:

Fix long scan problem when BIOS floppy setting incorrect
http://git.gnome.org/browse/gparted/commit/?id=18f863151c82934fe0a980853cc3deb1e439bec2

This patch is planned for inclusion in the upstream GParted 0.12.0 release sometime in mid to late February, 2012.

dino99 (9d9) wrote :

@Curtis

is the "cached blkid results" always up-to-dated ? or does the users need to be warned to refresh it then restart gparted again ?

Curtis Gedak (gedakc) wrote :

@dino99. GParted performs a "udevadm settle" before re-reading the blkid cache. Hence the cache should already have been updated before GParted proceeds with the device refresh.

In my testing I did find this to be the case and to work properly.

dino99 (9d9) wrote :

@Curtis

ok thanks, it was only a doubt of my own, in case it should be usefull before getting your patch. Waiting the new package, no hurry anyway.

Curtis Gedak (gedakc) wrote :

@dino99. To confirm that the problem is with blkid, would you be able to try running the following command with your computer setup?

     sudo blkid -c /dev/null

Changed in gparted:
status: Confirmed → Fix Released
dino99 (9d9) wrote :

@Curtis

oem@oem-desktop:~$ sudo blkid -c /dev/null
 sudo: command not found

root@oem-desktop:~# blkid -c /dev/null
/dev/sda1: LABEL="LTS32" UUID="0eea5390-114c-4ee2-815f-a3cfca716c04" TYPE="ext4"
/dev/sda2: UUID="0a9ca7f0-6eeb-4b21-b70f-670fa600de16" TYPE="swap"
/dev/sda3: LABEL="lhom" UUID="5d8d1ee1-f5af-40a1-a45d-dbc570808523" TYPE="ext3"
/dev/sdb1: LABEL="xpsp2" UUID="C45C913B5C912966" TYPE="ntfs"
/dev/sdb5: LABEL="xp-swap" UUID="06E3556109E86C28" TYPE="ntfs"
/dev/sdb6: LABEL="stor" UUID="74A45F0F7E91E03F" TYPE="ntfs"
/dev/sdb7: LABEL="docu" UUID="0FCF59F5512F10B0" TYPE="ntfs"
/dev/sdc1: LABEL="Dev32" UUID="9e61e83e-bca9-43cf-aa90-5a68892213fa" TYPE="ext3"
/dev/sdc2: UUID="66D40397D403691F" TYPE="ntfs"
/dev/sdc4: LABEL="Lub32" UUID="aa1bddfe-1ddb-4832-bee9-eb31c56faefa" TYPE="ext4"
/dev/sdc5: LABEL="Current32" UUID="00c5de83-479c-4ab0-9b54-9af0a727175e" TYPE="ext4"
/dev/sdc6: UUID="1AC0DA8DC0DA6F0F" TYPE="ntfs"
/dev/sdc7: LABEL="mob" UUID="1D9F1D4F3579932E" TYPE="ntfs"

Curtis Gedak (gedakc) wrote :

@dino99, how long did it take for the blkid command to run?
 When you performed the test, was your BIOS configured to indicate a floppy drive was present when there actually was no physical floppy drive?

The patch mentioned above was included in GParted 0.12.0 released upstream on February 21, 2012.

dino99 (9d9) wrote :

@Curtis

bios config : floppy off
no floppy reader into that system

blkid request send instantly (1/2 second)

do you need floppy activated into the bios ? then and other blkid test ?

dino99 (9d9) wrote :

I remember that i've already made the blkid request a few days back with the floppy setting activated into the bios. The blkid request took about 4 minutes to succeed.

Phillip Susi (psusi) wrote :

Curtis, 0.11.0 still runs blkid -p, not -c, doesn't it? That was changed in 0.12.0.

Dino, does the status bar indicate what device it is trying to scan?

dino99 (9d9) wrote :

@Phillip

test made with 0.11.0-1 on Precise i386:
- while scanning : the gparted screen is all greyed except this orange scan bar
- when the scan is done: it first select /dev/sda , then i can switch to sdb or sdc

so its ok if i do it with floppy setting deactivated into the bios. But my main previous comment was: gparted should never abort/fail/freeze because of a missetting/damaged device or else ( its first job is to scan then find the devices and finally if it find something borked, it should only return "sorry this device seems damaged" or so.)

dino99 (9d9) wrote :

****does the status bar indicate what device it is trying to scan? **** no nothing till the scan end

Phillip Susi (psusi) wrote :

Ok, then this is fixed in parted 0.12.0.

Curtis Gedak (gedakc) wrote :

@dino99. Thanks for running the extra tests. The concern was that "blkid -c /dev/null" would take a long time on a BIOS that was incorrectly configured to indicate it had a floppy device when no physical device was present. Phillip is correct, this is fixed in GParted 0.12.0.

@Phillip, GParted 0.11.0 still used the "blkid -c /dev/null" call so it would exhibit the problem. If you are patching the package, then the fix for this would be a good one to include with GParted 0.11.0.

eris23 (jdkatz23) wrote :

I have the problem on precise with parted 2.3-8ubuntu5

eris23 (jdkatz23) wrote :

Workaround disabling floppy in bios worked on precise with parted 2.3-8ubuntu5

Curtis Gedak (gedakc) wrote :

The patch to GParted mentioned in comment #26 is included in the upstream release of GParted 0.12.1.

Curtis Gedak (gedakc) wrote :

After checking again, the patch is actually first included in upstream GParted 0.12.0. Hence this patch is not yet part of Precise Pangolin, which is using GParted 0.11.0-2.

Phillip Susi (psusi) on 2012-07-08
Changed in gparted (Ubuntu):
status: Triaged → Fix Released
Carla Sella (carla-sella) wrote :

I am currently running Ubuntu 12.04.1 LTS Precise, kernel 3.2.0-29-generic, Gparted version: 0.11.0-2, if I have legacy floppy enabled in my bios I still have the problem of Gparted scanning devices forever. I will disable legacy diskette in my bios to get it work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.