gparted crashes when usb flash drive inserted.

Bug #581144 reported by enb on 2010-05-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gparted

I had gparted open, I inserted a kingston 4gb drive, and then hit ctrl - r in gparted and it instantly crashed. I tried launching it from a terminal, but it does not launch when the usb is connected. Once the drive is removed, it launches again.

$ sudo gparted
======================
libparted : 2.2
======================
Backtrace has 15 calls on stack:
  15: /lib/libparted.so.0(ped_assert+0x31) [0x7f2431ebb7c1]
  14: /lib/libparted.so.0(+0x3a116) [0x7f2431ee6116]
  13: /lib/libparted.so.0(+0x3a883) [0x7f2431ee6883]
  12: /lib/libparted.so.0(+0x3b53d) [0x7f2431ee753d]
  11: /lib/libparted.so.0(ped_disk_add_partition+0x1cb) [0x7f2431ec1ecb]
  10: /lib/libparted.so.0(+0x3c946) [0x7f2431ee8946]
  9: /lib/libparted.so.0(+0x3caf5) [0x7f2431ee8af5]
  8: /lib/libparted.so.0(ped_disk_new+0x75) [0x7f2431ec29a5]
  7: /usr/sbin/gpartedbin() [0x44ab84]
  6: /usr/sbin/gpartedbin() [0x45645c]
  5: /usr/sbin/gpartedbin() [0x476c47]
  4: /usr/lib/libglibmm-2.4.so.1(+0x36862) [0x7f243093e862]
  3: /lib/libglib-2.0.so.0(+0x67b84) [0x7f242fd92b84]
  2: /lib/libpthread.so.0(+0x69ca) [0x7f242f5e99ca]
  1: /lib/libc.so.6(clone+0x6d) [0x7f242f34769d]
Assertion (head_size <= 63) at ../../../libparted/labels/dos.c:659 in function probe_partition_for_geom() failed.

Thank you for reporting this to Ubuntu. Could you please generate an apport crash report for this?
You can enable apport for one instance like this:
sudo service apport start force_start=1

I am marking this invalid as apport will open a new bug when the crash is generated. If it does not, you can reset the status of this one to New and we will try something else.

Changed in gparted (Ubuntu):
status: New → Invalid
tdi (fsatglobal) wrote :

I have the same issue.

======================
libparted : 2.2
======================
Backtrace has 15 calls on stack:
  15: /lib/libparted.so.0(ped_assert+0x31) [0x7fb593562771]
  14: /lib/libparted.so.0(+0x3a0e6) [0x7fb59358d0e6]
  13: /lib/libparted.so.0(+0x3a853) [0x7fb59358d853]
  12: /lib/libparted.so.0(+0x3b50d) [0x7fb59358e50d]
  11: /lib/libparted.so.0(ped_disk_add_partition+0x1cb) [0x7fb593568e7b]
  10: /lib/libparted.so.0(+0x3c916) [0x7fb59358f916]
  9: /lib/libparted.so.0(+0x3cac5) [0x7fb59358fac5]
  8: /lib/libparted.so.0(ped_disk_new+0x75) [0x7fb593569955]
  7: /usr/sbin/gpartedbin() [0x44ab94]
  6: /usr/sbin/gpartedbin() [0x45646c]
  5: /usr/sbin/gpartedbin() [0x476c57]
  4: /usr/lib/libglibmm-2.4.so.1(+0x36862) [0x7fb591fe5862]
  3: /lib/libglib-2.0.so.0(+0x67b84) [0x7fb591438b84]
  2: /lib/libpthread.so.0(+0x69ca) [0x7fb590c8f9ca]
  1: /lib/libc.so.6(clone+0x6d) [0x7fb5909ec70d]
Assertion (head_size <= 63) at ../../../libparted/labels/dos.c:659 in function probe_partition_for_geom() failed.

tdi (fsatglobal) wrote :

I have now four installations 1x 10.10 64bit, 2 x 10.04 LTS 64bit, and 1 x 10.04 LTS 32 bit versions that have the exact same problem. Gparted used to work on all a few months ago. What is going here that this functionality is broken!!! I use this features all the time and now I am buggered. Please fix ASAP!

I am also experiencing this ....on Kubuntu 10.04 LTS 32 bit KDE-4.5.3 Gparted-0.5.1 parted (GNU parted) 2.2
as of yet it onley happens with 1 USB stick a duracell-4Gig ...........this dose not happen on my other 3 sticks that are less than 4Gig..........well 1 is a 4Gig but has that U3 system on it so the usable space is less than 4Gig I mention this encase the size of stick is relevant some how to the prob.

tried to use apport but got this..........

"The problem cannot be reported:

The program crashed on an assertion failure, but the message could not be retrieved. Apport does not support reporting these crashes. "

O well

VINNY

I have found part of the puzzle I think.

the partition on the brand new USB stick started at 3 not 1 hear is the fdisk

/dev/sdg1 3 2191 3938368 c W95 FAT32 (LBA)

I then used a Gparted livecd ....Gparted-0.3.1 GNU-parted-1.7.1 to repartition it and reformat it
so now fdisk shows this

/dev/sdg1 1 490 3935893+ b W95 FAT32

and the crashing of Gparted-0.5.1and parted (GNU parted) 2.2 runing in Kubuntu 10.04 LTS 32 bit KDE-4.5.3
has stopped and they will work with the stick

but it remains to wander why didn't the Gparted livecd crash ?

VINNY

Derek (bugs-m8y) wrote :

Charles, based on that last comment, I bet this is bug #545911

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers