gparted crashes at start

Bug #468 reported by Nicolas da Luz Duque
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

gparted crashes at startup.
This is always reproductible, just launch gparted, type in your password, and see it segfault.

gparted crashes at startup.
This is always reproductible, just launch gparted, type in your password, and see it segfault.

Oliver Grawert (ogra)
Changed in gparted:
assignee: nobody → dh
Revision history for this message
Colin Applegate (colin-a) wrote :

I installed GParted using Synaptic. I run GParted through Gnome's menu: applications --> system tools --> GParted

I type in my password for root privileges and GParted runs just fine, it does not segfault.

Nicolas, perhaps GParted seg faulting is specific to your system?

Revision history for this message
Daniel Holbach (dholbach) wrote :

Hey Nicolas,

thanks for reporting. Could you just start 'gksudo gparted' from the command line and paste the output here? It may clarify what's going wrong.

Thanks again,
 Daniel

Changed in gparted:
assignee: dh → gnome
Revision history for this message
Daniel Holbach (dholbach) wrote :

Does this still happen for you?

Changed in gparted:
status: New → Fixed
Revision history for this message
Nicolas da Luz Duque (hot-boy) wrote :

Hey! How come I didn't recieve any email when you posted comments? I've just recieved the email saying the bug was closed. Is it a bug in malone?

However, retrospectively, nothing proves me gparted crashes. It just seems to quit as soon as it is lauched.

I got this output:

iceman@Kamui:~ $ gksudo gparted
======================
libparted : 1.6.20
======================
iceman@Kamui:~ $

So indeed it doesn't say segmentation fault. The gparted window opens for a short while and seems to be scanning for something (partitions I'd expect) and then the window dissapear...

Sorry to have taken so long to answer but I expected to see something in my mailbox and eventually forgot about this report.

Revision history for this message
Daniel Holbach (dholbach) wrote :

which version of gparted are you using?

Revision history for this message
knorr (a-sokolov) wrote :

sudo gparted
[sudo] password for knorr:
======================
libparted : 2.3
======================

glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: basic_string::_S_create

aborting...

Revision history for this message
kmv (kellymartinv) wrote :

I get the exact same result as knorr on 10.10.

Revision history for this message
kmv (kellymartinv) wrote :

Since I realized my comment was useless, I did a little more testing to see where I was getting a fault.

I was able to run `sudo gparted /dev/sda` just fine. That drive is pretty standard, ext3 plus swap and an extended.

However, running gparted on sdb or sdb failed with that error shown above on knorr's comment. Those drives are set as a software RAID 0. Might that have something to do with the crash?

I also tested it on an SD card that mounted as /dev/sdf. No problems with it. Just with the RAID drives.

Revision history for this message
kmv (kellymartinv) wrote :

*sdb or sdc -- those are the RAID drives. just a typo.

Revision history for this message
MarkosJal (markosjal) wrote :

I ran into a similar issue in Maverick 10.10 . I copied an Apple TV partition to a larger drive and wanted to expand the partition to fill the larger drive.

I booted to linux on USB stick then ran gparted , and after scannking drives, it quits.

I then ran from terminal

 ~ $ sudo gparted
[sudo] password for xbmc:
======================
libparted : 2.3
======================
The backup GPT table is not at the end of the disk, as it should be. This might mean that another operating system believes the disk is smaller. Fix, by moving the backup to the end (and removing the old backup)?
Not all of the space available to /dev/sda appears to be used, you can fix the GPT to use all of the space (an extra 547002288 blocks) or continue with the current setting?
Backtrace has 14 calls on stack:
  14: /lib/libparted.so.0(ped_assert+0x2a) [0x37c87a]
  13: /lib/libparted.so.0(ped_geometry_read+0x116) [0x3865e6]
  12: /lib/libparted.so.0(hfsplus_probe+0x3a1) [0x3a6751]
  11: /lib/libparted.so.0(ped_file_system_probe_specific+0x6c) [0x37e3dc]
  10: /lib/libparted.so.0(ped_file_system_probe+0x81) [0x37e9d1]
  9: /lib/libparted.so.0(+0x4a00c) [0x3bd00c]
  8: /lib/libparted.so.0(ped_disk_new+0x75) [0x3857d5]
  7: /usr/sbin/gpartedbin() [0x8090126]
  6: /usr/sbin/gpartedbin() [0x80a06b5]
  5: /usr/sbin/gpartedbin() [0x80c1f42]
  4: /usr/lib/libglibmm-2.4.so.1(+0x31e42) [0x185e42]
  3: /lib/libglib-2.0.so.0(+0x6848f) [0x44948f]
  2: /lib/libpthread.so.0(+0x5cc9) [0xcc7cc9]
  1: /lib/libc.so.6(clone+0x5e) [0xba76ae]

Mark

Revision history for this message
Damiön la Bagh (kat-amsterdam) wrote :

This is the error message in 12.04LTS

(gpartedbin:21185): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/breakpoint trap (core dumped)

Why is gparted worried about libraries it doesn't need to use?

Revision history for this message
Damiön la Bagh (kat-amsterdam) wrote :

This bug is on Fixed Released even though this bug still exists. Where can I download the fix for this bug?

Revision history for this message
Phillip Susi (psusi) wrote :

This bug is from 2005 and so has nothing to do with your issue, which appears to be a gtk error.

Jeremy Bicha (jbicha)
Changed in gparted (Ubuntu):
assignee: Ubuntu GNOME (ubuntu-gnome) → nobody
Changed in gparted (Ubuntu):
assignee: nobody → LoCo Team Ubuntu (ltu11)
Revision history for this message
Phillip Susi (psusi) wrote :

Assigning bugs is for designating who is going to fix it. Since this was fixed long ago, assigning it is improper.

Changed in gparted (Ubuntu):
assignee: LoCo Team Ubuntu (ltu11) → nobody
Revision history for this message
Damiön la Bagh (kat-amsterdam) wrote :

Maybe the date needs to be a bit larger as this was the first bug that came up and exactly matches my issue.

I'll open a new bugreport so this can be properly solved (again).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers