gparted fails to correctly identify swap partition

Bug #444203 reported by Stephen Cradock on 2009-10-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: parted

Gparted claims that it cannot detect the swap partition in a karmic install (64-bit) after upgrades of parted and libparted1.8-12 from 1.8.8.git.2009.06.03-1ubuntu4 to -1ubuntu6 today. The swap partition is marked as "Unknown" type, instead of swap, it has no "Swapoff" option in its context menu, and its Information includes a warning that the file system type is undetectable.

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 5 19:23:59 2009
DistroRelease: Ubuntu 9.10
Package: parted 1.8.8.git.2009.06.03-1ubuntu6
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: parted
Uname: Linux 2.6.31-11-generic x86_64

Related branches

Stephen Cradock (s-cradock) wrote :
Erick Brunzell (lbsolost) wrote :

Identical problem here after updates to parted ands libparted on 10/05/09.

Just as a matter of troubleshooting I installed Jaunty's libparted and downgraded to Jaunty's gparted and then gparted reads and displays properly. Not a fix, nor even a decent work-around.

Erick Brunzell (lbsolost) wrote :

Just happened to think about how the Live CD might be effected.

I'd be glad to download and burn the 10/06 Ubuntu daily i386 for testing purposes if needed.

A parted issue with the live CD would certainly be much more serious than the same issue on an installed version of Gparted.

Just shout.

Colin Watson (cjwatson) wrote :

The installer isn't affected by this - it was adjusted to pre-emptively take account of this parted change quite some time ago.

gparted was fixed in 0.4.6, but we're on 0.4.5. I'll backport the change.

I'll check the KDE partitioning tools I know of as well.

affects: parted (Ubuntu) → gparted (Ubuntu)
Changed in gparted (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
tags: added: regression-potential
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.4.5-2ubuntu1

---------------
gparted (0.4.5-2ubuntu1) karmic; urgency=low

  * Backport from upstream:
    - Enhance to use new linux-swap "filesystem" types added in
      parted-1.9.0, and backported to Ubuntu's parted package (LP: #444203).

 -- Colin Watson <email address hidden> Tue, 06 Oct 2009 09:24:47 +0100

Changed in gparted (Ubuntu):
status: Triaged → Fix Released
Stephen Cradock (s-cradock) wrote :

Thanks - that fixed it!

Erick Brunzell (lbsolost) wrote :

Fix confirmed.

Many thanks.

philipp beitz (philippbeitz) wrote :

Still not working. Tried to create a swap partition with my installed karmic system -> not possible , device or resource busy

than i booted with jaunty - creation of swap partition was possible but still karmic doesnt recognized it.

what do to now ?

Colin Watson (cjwatson) wrote :

Philipp, you have some different problem which should be filed separately. Note that it is generally not possible to edit partitions while you have partitions mounted on the same disk (e.g. you're running from an installation on the same disk); you often need to use a live CD instead.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers