no need to copy data when moving swap partitions

Bug #401228 reported by Marian Sigler on 2009-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Medium
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gparted

When moving a swap partition, gparted copies all the data from the old place to the new one. This is absolutely unneccessary ;-)

Please set the priority to wishlist, if you are allowed to, thanks.

Jan Claeys (janc) wrote :

I can see one use-case for keeping the data: if you hibernated before booting from the live-CD and expect to be able to resume after repartitioning, but I suppose supporting that is not what most people expect (and it doesn't work with current GParted anyway, so this is really a bug).

Changed in gparted:
status: Unknown → New
Changed in gparted:
status: New → Confirmed
Changed in gparted:
importance: Unknown → Medium
Curtis Gedak (gedakc) wrote :

The enhancements to address this bug report have been included in upstream GParted 0.7.0
which was released on October 29, 2010.

Changed in gparted:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.7.0-1

---------------
gparted (0.7.0-1) unstable; urgency=high

  * New upstream release
    Fix gparted crash at start with glibmm-ERROR
      Closes: 601818
      LP: #609477, #617885
    Fix crash moving more than one logical partition right
      Closes: 601817
    Skip move/copy action because linux swap contains no data
      LP: #401228
    Fix several memory leaks and valgrind errors
    Remove unnecessary null pointer checks
    Fix partitions moved or copied are 1 MiB larger
    Insert additional translator comments
    Add initial support for btrfs
 -- Michael Bienia <email address hidden> Thu, 04 Nov 2010 00:16:34 +0000

Changed in gparted (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.