GParted's DEB package dependencies appear to be incomplete

Bug #334170 reported by Conrad Knauer on 2009-02-25
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)

Bug Description

Binary package hint: gparted

Running Jaunty (alpha; current to the repos as of Feb 24). Earlier today Synaptic updated the gparted package on my system from 0.3.9-3ubuntu1 to 0.4.3-0ubuntu1 and so I decided to have a closer look. I noticed that the suggested dependencies are:

xfsprogs, reiserfsprogs, reiser4progs, jfsutils, ntfsprogs

however, when running GParted, if you go View -> File System Support you will notice a nice table that includes the names of the "required software" to achieve certain functionality, some of which are missing from the suggested dependencies:

hfsprogs, hfsutils

Please add those two to the suggested dependencies.

Also, shouldn't the DEB package explicitly recommend or depend on the others listed? That is:

e2fsprogs, dosfstools, mtools, util-linux

Related branches

Conrad Knauer (atheoi) wrote :

Also, based on some trial and error, xfsdump should be added to the suggested dependencies too.

Dave Walker (dogatemycomputer) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in gparted (Ubuntu):
status: New → Confirmed
Conrad Knauer (atheoi) wrote :

Note: in Karmic, dosfstools is now suggested.

Phillip Susi (psusi) on 2012-01-04
Changed in gparted (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.17.0-3

gparted (0.17.0-3) unstable; urgency=low

  * Change Suggests: ntfsprogs to ntfs-3g

 -- Phillip Susi <email address hidden> Fri, 27 Dec 2013 15:18:40 -0500

Changed in gparted (Ubuntu):
status: Triaged → Fix Released
Ubfan (ubfan1) wrote :

The e2fsprogs is still not a dependency in gparted 0.25.0-1
The resize2fs which expands the filesystem when a partition is enlarged is a part of e2fsprogs.
This automatic ext filesystem resizing is a feature gparted offers over other partition managers like fdisk, but is not mentioned in the man pages either.
  As was mentioned in the original report, gparted's view/filesystem support does list the packages required for various filesystems, several are in the "suggests", but still missing are:
btrfs-progs, brtfs-tools, e2fsprogs, f2fs-tools, hfsutils, hfsprogs, util-linux, lvm2, nilfs-utils, ntfsprogs, xfsdump

Phillip Susi (psusi) on 2017-03-07
Changed in gparted (Ubuntu):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers