[need-update] Gparted to latest stable 0.4.3 (added ext4 support) in Ubuntu Jaunty

Bug #305280 reported by Dmitry Korzhevin on 2008-12-04
90
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Wishlist
Colin Watson
Jaunty
Wishlist
Colin Watson

Bug Description

Please, update Gparted to latest 0.4.3 in 9.04 Jaunty

See News: http://gparted.sourceforge.net/news.php

Dmitry Korzhevin (korg) wrote :
Lauri Niskanen (ape3000) on 2009-01-25
Changed in gparted:
status: New → Confirmed

0.4.1 is in Debian experimental.

http://packages.debian.org/source/experimental/gparted

 gparted (0.4.1-1) experimental; urgency=low

   * New upstream stable release
     - drop 05_GParted_Core.cc.diff, merged upstream
     - refreshed 01_fix-desktop.patch to be applied correctly
   * Updated debian/control:
     - bump standards version to 3.8.0.1, no extra change is needed
     - added intltool to build-deps

 -- Alan Baghumian <email address hidden> Mon, 15 Dec 2008 20:21:35 -0800

Changed in gparted:
importance: Undecided → Wishlist

Sounds like a good idea since gparted 3.8.0 produced various errors here.

Ivan Zorin (iaz) wrote :

In attachment - diff.gz for ubuntu jaunty.
So, if anyone from maintainers think, that it's useful, then he can take it, check it for possible errors and, if everything fine, build and upload it to ubuntu repo.

Dmitry Korzhevin (dkorzhevin) wrote :

Hello!

Tell me please, if gparted package will be updated for Ubuntu 9.04? It is still have 0.3.9-3ubuntu1 version in Jaunty..

Changed in gparted:
assignee: nobody → surfaz28
Changed in gparted:
status: Confirmed → In Progress
description: updated

gparted (0.4.2-1ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #305280)
    + Added support for ext4 file system (LP: #137872)
      - Support for ext4 is built into version 2.6.28 of the Linux kernel
      - e2fsprogs version 1.41.0 or higher required
    + Fixed bug in german translation (LP: #45449)
    + Fixed 'fails to recognize newly created swap partition' (LP: #137700)(LP: #114713)
    + Reduced file system information disk reads to improve performance (LP #311470)

  * debian/patches
    + dropped 05_GParted_Core.cc.diff, merged upstream
    + refreshed 10_dev_mapper.patch to be applied correctly
    + refreshed 01_fix-desktop.patch to be applied correctly

  * debian/control
    + Added intltool to Build-Depends

  * debian/rules
    + Added --with-help-dir= to build help manual in /usr/share

  * debian/watch
    + Fixed debian-watch-file-should-use-sf-redirector lintian warning.

 -- Surfaz Gemon Meme <email address hidden> Fri, 06 Feb 2009 04:18:03 +0000

Attached .diff.gz

Colin Watson (cjwatson) wrote :

This version number is incorrect since there has not been a 0.4.2-1 upload to Debian, as far as I can see; it should be 0.4.2-0ubuntu1 instead.

Fixed version number and a small problem with help mail path (now to /usr/share/gnome/help)

Attached new gparted_0.4.2-0ubuntu1.diff.gz

Changelog:

gparted (0.4.2-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #305280)
    + Added support for ext4 file system (LP: #137872)
      - Support for ext4 is built into version 2.6.28 of the Linux kernel
      - e2fsprogs version 1.41.0 or higher required
    + Fixed bug in german translation (LP: #45449)
    + Fixed 'fails to recognize newly created swap partition' (LP: #137700)(LP: #114713)
    + Reduced file system information disk reads to improve performance (LP #311470)

  * debian/patches
    + dropped 05_GParted_Core.cc.diff, merged upstream
    + refreshed 10_dev_mapper.patch to be applied correctly
    + refreshed 01_fix-desktop.patch to be applied correctly

  * debian/control
    + Added intltool to Build-Depends

  * debian/rules
    + Added --with-help-dir= to build help manual in /usr/share/gnome/help

  * debian/watch
    + Fixed debian-watch-file-should-use-sf-redirector lintian warning.

 -- Surfaz Gemon Meme <email address hidden> Fri, 07 Feb 2009 15:40:03 +0100

Changed in gparted:
assignee: surfaz28 → nobody
status: In Progress → Confirmed

Attached debdiff (changes for .diff.gz of gparted-0.3.9)

debdiff patch not remove 05_GParted_Core.cc.diff, only left a empty file. 05_GParted_Core.cc.diff should be deleted manually

Hi Anibal, Alan, Otavio,

We have an Ubuntu bug open at the moment
(https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/305280) asking
for gparted 0.4.2 in Ubuntu. This is more urgent than it is in Debian,
since we're aiming for full ext4 support in our next release, and our
feature freeze is only a week away. As such, I'm minded to sponsor this
despite the fact that Debian experimental only has 0.4.1 at the moment.

However, upstream only ships .tar.bz2 files, which means that we would
have to repack it to get an .orig.tar.gz. I'm cautious about doing this
independently since it could get in the way of later being able to sync
the package from Debian if we ended up with different files.

Unless you're already in the process of packaging this, in which case
I'll gladly yield to your .orig.tar.gz, perhaps we could agree on this
file, with SHA256sum
6b6a927b9f46c1d5b7841214f0298c45a7b91ada1cd6abe040cf0866748613ef?

  http://people.ubuntu.com/~cjwatson/tmp/gparted_0.4.2.orig.tar.gz

Thanks,

--
Colin Watson [<email address hidden>]

Changed in gparted:
assignee: nobody → kamion

On Wed, Feb 11, 2009 at 12:22:06PM -0000, Surfaz Gemon Meme wrote:
> Colin, I don't understand you message.

That's OK. It was sent to the Debian maintainers of gparted, and copied
to this bug for the record.

Surfaz, Colin's message was directed towards the Debian maintainers, so that we share a common orig.tar.gz. Don't worry about it.

Dmitry Korzhevin (korg) wrote :

Release Name: gparted-0.4.2

Notes:
NOTES
 The big news for this GParted release is support for ext4 file systems,
 and the addition of an application help manual.

 Key changes include:
   - Added support for ext4 file system
     - Support for ext4 is built into version 2.6.28 of the Linux kernel
     - e2fsprogs version 1.41.0 or higher required
   - Created application help manual
   - Updated gparted manual page
   - Made text beside field labels selectable (i.e., copy/paste UUID)
   - Added lvm2 physical volume detection
   - Reduced file system information disk reads to improve performance
   - Fixed application crash when saving details and locale not set
   - Enhanced copy/paste checks when MBR/EBR involved

Changes:
BUG FIXES
 * Added additional category to desktop file (#568937)
 * Created application help manual (#329584)
 * Reworded caution message when applying operations (#564952)
 * Recognized linux-swap(new)/(old) as linux-swap (#419515)
 * Improved text for libparted not found error message (#565682)
 * Added support for ext4 file system (#503112)
 * Removed doubled space in front of fdl license link (#556114)
 * Added lvm2 physical volume detection (small part of #160787)

TRANSLATIONS (new/updated)
 * ca(David Planella), cs(Adrian Gunis), de(Mario Blättermann),
   el(Evgenia Petoumenou), es(Jorge Gonzalez), fr(Claude Paroz),
   it(Milo Casagrande), pl(Tomasz Dominikowski),
   pt_BR(Fábio Nogueira, Fabrício Godoy, Leonardo Gregianin,
         Leonardo Ferreira Fontenelle, Djavan Fagundes),
   sk(Pavol Klačanský), sv(Daniel Nylander),
   th(Pongpichit Panna, Theppitak Karoonboonyanan)

DEPENDENCIES (new/updated)
 * e2fsprogs v1.41.0 or higher required for ext4 file system support

Colin Watson (cjwatson) wrote :

There is no need to post the release notes to this bug. As you can see from the above comments, we are already aware of gparted 0.4.2.

On Wed, Feb 11, 2009 at 11:31:10AM +0000, Colin Watson wrote:
>perhaps we could agree on this file, with SHA256sum
>6b6a927b9f46c1d5b7841214f0298c45a7b91ada1cd6abe040cf0866748613ef?

Aye!

I downloaded
http://people.ubuntu.com/~cjwatson/tmp/gparted_0.4.2.orig.tar.gz
and its sha256sum matches the one above.

sha256sum < gparted_0.4.2.orig.tar.gz
6b6a927b9f46c1d5b7841214f0298c45a7b91ada1cd6abe040cf0866748613ef -

The SHA256 checksums of the .tar files from Colin and upstrem also
match:

gzip -cd gparted_0.4.2.orig.tar.gz | sha256sum
5891a6e56012b5ef84ca6d0bf3506e8816838ea3556a88c681440ac27990ba4f -

bzip2 -cd gparted-0.4.2.tar.bz2 | sha256sum
5891a6e56012b5ef84ca6d0bf3506e8816838ea3556a88c681440ac27990ba4f -

Hi guys!

New upstream release today! xD

Version: 0.4.3 - Released on 2009-02-12 16:48:25 UTC
0.4.3 (2009-02-12)
This release of GParted includes bug fixes, and language translation updates.

Key changes include:
- Corrected name of lock taken by hal-lock
(The lock is needed to prevent automounting of file systems)
- Fixed crash on startup with some languages

Download: http://downloads.sourceforge.net/gparted/gparted-0.4.3.tar.bz2

description: updated
Martin Pitt (pitti) wrote :

The hal-lock issue is bug 37768 (for closing in changelog).

2009/2/12 Martin Pitt <email address hidden>

> The hal-lock issue is bug 37768 (for closing in changelog).
>

Well, then 0.4.3 release fixes #137872, #45449, #137700, #114713, #311470
and #37768 bugs of Launchpad.

Jerone Young (jerone) wrote :

When do we expect to have the updated version of Gparted in jaunty so that it can get proper testing?

On Mon, Feb 16, 2009 at 08:40:23AM -0800, Alan Baghumian wrote:
> I think we are gonna work on 0.4.3!

Ah yes. http://people.ubuntu.com/~cjwatson/tmp/gparted_0.4.3.orig.tar.gz
then; SHA256sum
f870e01c150594c7d3a425492c4f87d44c82d7a30a4c0c64530fc09f3ffe4de4.

(I created this using 'bzcat gparted-0.4.3.tar.bz2 | gzip -9n >
gparted_0.4.3.orig.tar.gz', which seems to be a reliable way to get the
same result every time; gzip -n avoids the timestamp being embedded in
the gzip header. This should probably be standard practice when
repacking an upstream tarball.)

Colin Watson (cjwatson) wrote :

I made a few minor tweaks, mainly preserving the Filesystem element in the desktop file's Categories field, adjusting changelog entries a bit, and upgrading to 0.4.3, but this is essentially as posted by Surfaz. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.4.3-0ubuntu1

---------------
gparted (0.4.3-0ubuntu1) jaunty; urgency=low

  [ Surfaz Gemon Meme, Colin Watson ]
  * New upstream release (LP: #305280)
    + Added support for ext4 file system (LP: #137872)
      - Support for ext4 is built into version 2.6.28 of the Linux kernel
      - e2fsprogs version 1.41.0 or higher required
    + Fixed bug in german translation (LP: #45449)
    + Fixed 'fails to recognize newly created swap partition'
      (LP: #137700, #114713)
    + Reduced file system information disk reads to improve performance
      (LP: #311470)
    + Fixed typo of "freedeskdesktop" in hal-lock name (LP: #37768)

  * debian/patches
    + dropped 05_GParted_Core.cc.diff, merged upstream
    + refreshed 10_dev_mapper.patch to be applied correctly
    + refreshed 01_fix-desktop.patch to be applied correctly

  * debian/control
    + Added intltool to Build-Depends

  * debian/rules
    + Added --with-help-dir= to build help manual in /usr/share/gnome/help

  * debian/watch
    + Fixed debian-watch-file-should-use-sf-redirector lintian warning.

 -- Surfaz Gemon Meme <email address hidden> Tue, 24 Feb 2009 13:16:44 +0000

Changed in gparted:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers