Installing gparted caused segmentation fault

Bug #1839066 reported by fcole90 on 2019-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

I just installed gparted and a segmentation fault happened at the end of the installation process.

sudo apt install gparted
[sudo] password for fabio:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libatkmm-1.6-1v5 libcairomm-1.0-1v5 libgail-common libgail18
  libglibmm-2.4-1v5 libgtk2.0-0 libgtk2.0-bin libgtkmm-2.4-1v5
  libpangomm-1.4-1v5 libsigc++-2.0-0v5
Suggested packages:
  xfsprogs reiserfsprogs reiser4progs jfsutils kpartx dmraid gpart udftools
The following NEW packages will be installed
  gparted libatkmm-1.6-1v5 libcairomm-1.0-1v5 libgail-common libgail18
  libglibmm-2.4-1v5 libgtk2.0-0 libgtk2.0-bin libgtkmm-2.4-1v5
  libpangomm-1.4-1v5 libsigc++-2.0-0v5
0 to upgrade, 11 to newly install, 0 to remove and 0 not to upgrade.
Need to get 3,803 kB of archives.
After this operation, 16.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://archive.ubuntu.com/ubuntu eoan/main amd64 libsigc++-2.0-0v5 amd64 2.10.1-2 [11.7 kB]
Get:2 http://archive.ubuntu.com/ubuntu eoan/main amd64 libglibmm-2.4-1v5 amd64 2.60.0-1 [545 kB]
Get:3 http://archive.ubuntu.com/ubuntu eoan/main amd64 libatkmm-1.6-1v5 amd64 2.28.0-2 [66.1 kB]
Get:4 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgtk2.0-0 amd64 2.24.32-3ubuntu1 [1,777 kB]
Get:5 http://archive.ubuntu.com/ubuntu eoan/main amd64 libcairomm-1.0-1v5 amd64 1.12.2-4 [38.5 kB]
Get:6 http://archive.ubuntu.com/ubuntu eoan/main amd64 libpangomm-1.4-1v5 amd64 2.42.0-2 [44.0 kB]
Get:7 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgtkmm-2.4-1v5 amd64 1:2.24.5-4 [702 kB]
Get:8 http://archive.ubuntu.com/ubuntu eoan/main amd64 gparted amd64 0.32.0-2 [482 kB]
Get:9 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgail18 amd64 2.24.32-3ubuntu1 [14.4 kB]
Get:10 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgail-common amd64 2.24.32-3ubuntu1 [114 kB]
Get:11 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgtk2.0-bin amd64 2.24.32-3ubuntu1 [7,740 B]
Fetched 3,803 kB in 29s (129 kB/s)
Selecting previously unselected package libsigc++-2.0-0v5:amd64.
(Reading database ... 215353 files and directories currently installed.)
Preparing to unpack .../00-libsigc++-2.0-0v5_2.10.1-2_amd64.deb ...
Unpacking libsigc++-2.0-0v5:amd64 (2.10.1-2) ...
Selecting previously unselected package libglibmm-2.4-1v5:amd64.
Preparing to unpack .../01-libglibmm-2.4-1v5_2.60.0-1_amd64.deb ...
Unpacking libglibmm-2.4-1v5:amd64 (2.60.0-1) ...
Selecting previously unselected package libatkmm-1.6-1v5:amd64.
Preparing to unpack .../02-libatkmm-1.6-1v5_2.28.0-2_amd64.deb ...
Unpacking libatkmm-1.6-1v5:amd64 (2.28.0-2) ...
Selecting previously unselected package libgtk2.0-0:amd64.
Preparing to unpack .../03-libgtk2.0-0_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgtk2.0-0:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libcairomm-1.0-1v5:amd64.
Preparing to unpack .../04-libcairomm-1.0-1v5_1.12.2-4_amd64.deb ...
Unpacking libcairomm-1.0-1v5:amd64 (1.12.2-4) ...
Selecting previously unselected package libpangomm-1.4-1v5:amd64.
Preparing to unpack .../05-libpangomm-1.4-1v5_2.42.0-2_amd64.deb ...
Unpacking libpangomm-1.4-1v5:amd64 (2.42.0-2) ...
Selecting previously unselected package libgtkmm-2.4-1v5:amd64.
Preparing to unpack .../06-libgtkmm-2.4-1v5_1%3a2.24.5-4_amd64.deb ...
Unpacking libgtkmm-2.4-1v5:amd64 (1:2.24.5-4) ...
Selecting previously unselected package gparted.
Preparing to unpack .../07-gparted_0.32.0-2_amd64.deb ...
Unpacking gparted (0.32.0-2) ...
Selecting previously unselected package libgail18:amd64.
Preparing to unpack .../08-libgail18_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgail18:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libgail-common:amd64.
Preparing to unpack .../09-libgail-common_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgail-common:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libgtk2.0-bin.
Preparing to unpack .../10-libgtk2.0-bin_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgtk2.0-bin (2.24.32-3ubuntu1) ...
Setting up libgtk2.0-0:amd64 (2.24.32-3ubuntu1) ...
Setting up libsigc++-2.0-0v5:amd64 (2.10.1-2) ...
Setting up libgail18:amd64 (2.24.32-3ubuntu1) ...
Setting up libgtk2.0-bin (2.24.32-3ubuntu1) ...
Setting up libglibmm-2.4-1v5:amd64 (2.60.0-1) ...
Setting up libgail-common:amd64 (2.24.32-3ubuntu1) ...
Setting up libcairomm-1.0-1v5:amd64 (1.12.2-4) ...
Setting up libpangomm-1.4-1v5:amd64 (2.42.0-2) ...
Setting up libatkmm-1.6-1v5:amd64 (2.28.0-2) ...
Setting up libgtkmm-2.4-1v5:amd64 (1:2.24.5-4) ...
Setting up gparted (0.32.0-2) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for mime-support (3.62ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for libc-bin (2.29-0ubuntu3) ...
Processing triggers for man-db (2.8.6-1) ...
Segmentation fault (core dumped)

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: gparted 0.32.0-2
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
Uname: Linux 5.2.0-8-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 6 11:16:30 2019
InstallationDate: Installed on 2019-02-03 (183 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: gparted
UpgradeStatus: Upgraded to eoan on 2019-07-21 (15 days ago)

fcole90 (fcole90) wrote :
fcole90 (fcole90) wrote :

I'm nevertheless able to launch gparted normally

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers