No support for LUKS volumes

Bug #175161 reported by era on 2007-12-09
4
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Wishlist
gparted (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gparted

It would be nice if Gparted could show encrypted LUKS partitions as LUKS instead of "unknown". Even if it cannot currently move or resize or otherwise manipulate them, it would be nice to be able to see what you have where. (Yes, my partition table is probably too complex, but that's beside the point.)

Saivann Carignan (oxmosys) wrote :

Thanks for this bug report!

I think that Gparted should not show "LUKS" as filesystem for a partition because LUKS isn't a filesystem, it can encrypt a filesystem. I just tried to boot from latest Linux Ubuntu Gutsy live CD to see what Gparted would say about my LUKS ext3 filesystem and it showed it as "ext3 partition". I also tried on another computer which have a ext2 LUKS partition and Gparted showed a ext2 partition. I think that it's exactly the good behavior.

I tested this with gparted 0.3.3-2ubuntu6.1, can you tell what version of gparted you are using? You can know this by typing this on a terminal :

apt-cache policy gparted

Changed in gparted:
assignee: nobody → saivann
status: New → Incomplete

On Thu, 13 Dec 2007 05:16:13 -0000, "Saïvann Carignan"
<email address hidden> said:
> I think that Gparted should not show "LUKS" as filesystem for a
> partition because LUKS isn't a filesystem, it can encrypt a
> filesystem. I just tried to boot from latest Linux Ubuntu Gutsy live
> CD to see what Gparted would say about my LUKS ext3 filesystem and it
> showed it as "ext3 partition". I also tried on another computer which
> have a ext2 LUKS partition and Gparted showed a ext2 partition. I
> think that it's exactly the good behavior.

I was also using the Gutsy live installer, and it showed "unknown".
When you select Properties (or was it Information?) it explained that
this could mean that it's unallocated, or that gparted doesn't recognize
the partition type, or that it's hosed.

Does it matter whether the partition is mounted or not? When you have
the decryption in place, of course gparted can look inside and see what
the container contains, but when it's encrypted, that should not be
possible (I assume).

Granted, LUKS is not a partition type, but it would be better if it
showed "I know what this is" rather than a yellow warning triangle and a
"might be broken or empty" explanation.

> I tested this with gparted 0.3.3-2ubuntu6.1, can you tell what version
> of gparted you are using? You can know this by typing this on a
> terminal :
>
> apt-cache policy gparted

Sorry, I repurposed the USB stick I was using while installing, but it
was whatever ships on the Ubuntu 7.10 installer.

/* era */

--
If this were a real .signature, it would suck less. Well, maybe not.

Changed in gparted:
status: Incomplete → New
Saivann Carignan (oxmosys) wrote :

The file system name and others informations are always available in LUKS partition. Only the content of file system itself is encrypted, so Gparted can gather these informations and show the real file system name to the final user, it could also see that the partition is encrypted and the algorithm used.

Since I can't reproduce that bug here, we would need somebody who's able to reproduce that bug with gparted in order to confirm this bug report.

Changed in gparted:
assignee: saivann → nobody
Saivann Carignan (oxmosys) wrote :

Comment from bug #106741 in ubiquity confirm that bug report. Bug #106741 will need this bug to be fixed in gparted before all. This bug has been already reported upstream at this link : http://bugzilla.gnome.org/show_bug.cgi?id=490740 .

Changed in gparted:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gparted:
status: Unknown → New
Changed in gparted:
status: New → In Progress
Changed in gparted:
status: In Progress → Fix Released

This was fixed upstream and will be present in gparted 0.4.4.

Changed in gparted:
status: Confirmed → Fix Committed
Curtis Gedak (gedakc) wrote :

GParted 0.4.4 has been released. It includes recognition of crypt-luks partitions.

Felix Geyer (debfx) on 2009-06-06
Changed in gparted (Ubuntu):
status: Fix Committed → Fix Released
Changed in gparted:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.