gparted hangs "Scanning all Devices" forever (because of /dev/fd0)

Bug #155047 reported by Ari on 2007-10-20
92
This bug affects 12 people
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Critical
gparted (Ubuntu)
Medium
Unassigned

Bug Description

   In my system, starting gparted all I get is the app window saying "Scanning all devices" for ever (== at least half an hour... that's as far as my patience goes :))

If a floppy drive is activated in the computer BIOS, but not available physically, gparted enters an infinite loop while scanning devices.

WORKAROUNDS:
a) disable your floppy drive in the computer BIOS
b) start gparted with the device you want to work on, e.g. "gparted /dev/sda"
c) NOT RECOMMENDED/UNTESTED: move away /dev/fd0 before starting gparted

Dominik Boehi (dboehi) wrote :

Thank you for reporting this bug.

 Have you tried starting gparted from the terminal? Do you get any output?

Changed in gparted:
assignee: nobody → dboehi
status: New → Incomplete
Ari (ari-reads) wrote :

Actually I noticed that the scanning actually finishes about 20 minutes (I was too impatient), which is weird anyways.

This is the terminal output:

ari@nahuatl:~$ sudo gparted
[sudo] password for ari:
======================
libparted : 1.7.1
======================
Unable to open /dev/fd0 read-write (Read-only file system). /dev/fd0 has been opened read-only.
Unable to open /dev/fd0 - unrecognised disk label.

Note that in this machine there is no floppy disk drive!! So why doesn't gparted realize it? And why does it try to open a floppy at all?

Ty
A

Dominik Boehi (dboehi) wrote :

That's strange. When I run gparted, I get a similar output:

======================
libparted : 1.7.1
======================
Unable to open /dev/hdc read-write (Read-only file system). /dev/hdc has been opened read-only.
Unable to open /dev/hdc - unrecognised disk label.

But gparted only scans for some seconds and then I can work normally.

Can you please post the content of /etc/fstab ?
Maybe it's a problem there.

Dominik, I think you are on to something here. Your error message was
/hdc, while mine was /fd0. I checked the /fstab on another computer
running Ubuntu 7.10 (32 bit) and it does not have the /dev/fd0 line.
It's an old computer running a 3100 chip with just 1/2 G memory, and
Gparted works instantly. So, would you recommend that I delete the last
line below? Neither computer has a floppy disk. Thanks, Don

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda3
UUID=f784f9f7-e59f-4a29-9575-5af86d651a4b / ext2
defaults,errors=remount-ro 0 1
# /dev/hda1
UUID=76FC4FADFC4F6709 /media/hda1 ntfs
defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/hda2
UUID=39e464bc-1fe3-47a1-8e12-c4bb47a69a4d none swap
sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

It's best if you just comment it, that is, put a # in front of the line.
Then you can restart the computer and try gparted again.

I'm sorry to say that after putting the # at the beginning of the last
line and restarting the computer, the exact same thing happened. After
about 5 minutes of searching Gparted came up with the same error
message. Don

Changed in gparted:
status: Unknown → New

I had this same problem yesterday after upgrading to 7.10.

Then after reading this post I noticed that mine too was hanging for at least 10 minutes while checking /dev/fd0. As I new GParted on 7.04 used to start swiftly on my system, I immediately assumed a bug in GParted. (It was also slow using the 7.0 live cd)

I don't have a floppy drive, but then I remembered I did add one temporarily a little while ago and removed it again.

It turned out after disconnecting it, I had forgotten to disable it in the bios. Setting floppy in the bios to none fixed it.

Dan

Dan,

Brilliant. Just brilliant. I never thought of checking the bios. This
computer never has had a floppy but the CMOS setup showed one. I
changed the CMOS from Floppy A to None, and now Gparted works perfectly
-- instantly. What's weird is that it worked fine on 7.04 with the
CMOS showing a floppy. Problem solved. Thanks Don

Removing fd0 from fstab didn't help here.

Now, right before installing gutsy i changed the HD and... removed the useless floppy :) so I guess that was the issue (didn't check yet but it looks like that's it).

Annabelle Van Gelder (waxje) wrote :

I don't have a floppy drive in my computer either and putting the floppy to none in the bios indeed helps i also commented out fd0 in etc/fstab
it did bring up a new bug but that had nothing to do with this one

thx a lot

Daniel Hahler (blueyed) on 2007-11-22
description: updated
description: updated
Changed in gparted:
status: Incomplete → Confirmed

Be certain that you CMOS does not show a floppy disk as installed
(fd0). If it does, eliminate the entry and all will work just fine.

Ari (ari-reads) wrote :

Just confirmed that disabling the floppy from the bios (there is no physical floppy in my system) fixed the problem

Robert (ubuntu-10-rmn30) wrote :

I too encountered this bug. Regardless of whether it can be made to work by disabling the floppy in the bios it would be better if gparted did not hang in this way.

Roger Lancefield (rlancefield) wrote :

It's kind of redundant now because several people above have confirmed that explicitly disabling the floppy drive in the BIOS fixes this issue, but for what it's worth, this 'fix' also worked for me. My experience has been the same as Don Melcer's (above); it wasn't an issue in Feisty for me, the problem started after upgrading to Gutsy.

Federico Foschini (undicizeri) wrote :

>it wasn't an issue in Feisty for me, the problem started after upgrading to Gutsy.

Same here! In feisty gparted works very well.

Johnathon (kirrus) wrote :

Comment on the bug report in Gnome Bugzilla:
 Comment #14 from Laurent de Trogoff (points: 14)
2007-11-05 05:36 UTC [reply]

This should have been fixed by parted update to 1.8.8.
It is in the last beta and next release !
http://gparted-livecd.tuxfamily.org/beta.php

spottedmahn (spottedmahn) wrote :

I'm having a similar problem where gparted hangs but I don't think is because of missing floppy drive.

If I start gparted from the terminal here's what I get:

======================
libparted : 1.7.1
automounting disabled
======================
Unable to open /dev/scd0 read-write (Read-only file system). /dev/scd0 has been opened read-only.
Unable to open /dev/scd0 - unrecognised disk label.

Changed in gparted:
status: New → In Progress
Changed in gparted:
importance: Undecided → Medium
Changed in gparted:
status: In Progress → Fix Released
Henri Schumacher (pacha-mama) wrote :

I have exactly the same problem, but not only in Ubuntu, but also with the gparted-livecd 0.3.7-5.
With gparted live-cd 0.3.4-11 there was no problem.
It also has problem with /dev/fd0 and there is no floppy installed.

Dominik Boehi (dboehi) on 2008-09-25
Changed in gparted:
assignee: dboehi → nobody

Hi guys, i'm testing alpha 6 and i was trying to format a 4GB pen drive using gparted but i keeps looking for devices forever and never show me anything... with ubuntu 8.04 i never had this problem since i could format my pen drive many times this way...

Regards,

Saivann Carignan (oxmosys) wrote :

Santiago : Can you start gparted from the terminal and copy the outputs on the bug report? If you don't get outputs concerning /dev/fd0, this is another bug so it would be better to open a new bug. Thanks for your testing!

Changed in gparted:
status: Confirmed → Incomplete
Saivann Carignan (oxmosys) wrote :

Can someone reproduce the original problem described in the bug description with a up-to-date intrepid (with gparted 0.3.8)?

Hey Saivann, the bug is gone. I updated the distribution (via the update manager) and i had no more this bug... is it fixed?

Saivann Carignan (oxmosys) wrote :

Santiago : Thanks for the feedback. This bug has been identified by gparted developers and fixed in gparted 0.3.8 release, which has been upload to ubuntu intrepid 2008-08-01 . Most probably that you simply updated to that version so the bug isn't reproducible for you. According to your positive feedback, I set the bug status to fix released. However, don't hesitate to comment here again if you can reproduce this bug in the future.

Changed in gparted:
status: Incomplete → Fix Released
milubu (miljop) wrote :

Sorry, just red this
having exactly the described problem with:

Ubuntu 8.10, kernel 2.6.27-9-generic - intrepid

gparted 0.3.8
(parted 1.8.8.git.2008.03.24-7ubuntu7 intrepid)

hangs on device scan. Even closing the gparted-window doesn't stop the processor from getting busier and busier (or the fan from working harder and harder)
on restarting:
error: libhal_acquire_global_interface_lock: org.freedesktop.Hal.Device.InterfaceAlreadyLocked: The interface org.freedeskdesktop.Hal.Device.Storage is already exclusively locked either by someone else or it's already locked by yourself
only reboot can reset this

100% reproducible

milubu (miljop) wrote :

can't get terminal output -
gparted just keeps warming up zhe room via processor for +30minutes now
NEW: some minutes later, gparted came up showing the hard drive - no log, no message, no terminal output
indications for the floppy reason:
a when starting as "sudo gparted /dev/sda": no problem
b partition logic 0.69 live disc produces error log concerning a twenty times tried to connect fd0 (is this using a partedlib or so??)

in my BIOS there is no floppy entry besides the boot sequence menu
(acer travelmate 4150 never having had cnotact to any floppy)

so perhaps this can help to go further?

milan

milubu (miljop) wrote :

sorry, error
must be:
a when starting as "sudo gparted /dev/sdb1"

and
libparted : 1.8.9
is used

Saivann Carignan (oxmosys) wrote :

milubu : This bug is fixed so the issue you get is another one (even if it look the same) so can you open a new bug report for this? Thanks for your contribution.

milubu (miljop) wrote :

sorry for the wind
a bios update volatilized this bug
(and another one well-discribed in forums)....
milan

Changed in gparted:
importance: Unknown → Critical
Kieran O'Neill (oneillkza) wrote :

This bug is still occurring with the version of gparted on the 12.04.1 boot disk.

Five years and still not fixed? Something this critical?

Kieran O'Neill (oneillkza) wrote :

Others have also been experiencing this recently:
http://www.pclinuxos.com/forum/index.php?topic=110055.15

Curtis Gedak (gedakc) wrote :

@Kieran, perhaps your BIOS is incorrectly set to indicate that the floppy drive is present when there is no physical floppy drive present?

Often an incorrectly set BIOS can cause this problem.

If not, other things to try are to defragment NTFS and FAT file systems.

Petko Ditchev (pditchev) wrote :

I confirm 12.10 and the bug is still present

GParted 0.12.1
libparted : 2.3
Debian GNU/Linux 7.2 (wheezy)

Gparted hangs with "Scanning all devices..'. Dosn't produce an error when starting it from terminal.

It takes me over 14 minutes before gparted finally give up fd0.
(workaround is of course 'gparted /dev/sdX' OR uncomment fd0 in /etc/fstab and 'rmmod floppy' OR some kind of blacklisting of floppy module OR disable floppy in bios)

'dmesg' shows:
[ 1195.692582] end_request: I/O error, dev fd0, sector 0
[ 1207.868596] end_request: I/O error, dev fd0, sector 0
[ 1207.868602] Buffer I/O error on device fd0, logical block 0
..
[ 2048.356502] end_request: I/O error, dev fd0, sector 0
[ 2048.356508] Buffer I/O error on device fd0, logical block 0

Still think its a silly that the program tries this 'hard' to read the device. Might be an idea to make a popup asking the user if he wants to continue trying the device (fd0) after 3 failed attempts.

Its easy to reproduce this on my computer:
modprobe floppy && gparted

I still have this issue. First run of gparted after system reboot is fine, but it hangs after applying any action. Is there someone working on this? I could provide required debug/strace/ltrace ?

Phillip Susi (psusi) wrote :

If you do not have a floppy drive, then you must not configure your bios to think that you do.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.