please add support for ext4

Bug #137872 reported by Trevor Schauls on 2007-09-07
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Medium
gparted (Baltix)
Undecided
Unassigned
gparted (Ubuntu)
Wishlist
Unassigned
Declined for Gutsy by Steve Langasek
Declined for Intrepid by Brian Murray
Jaunty
Wishlist
Unassigned
qtparted (Ubuntu)
Wishlist
Unassigned
Declined for Gutsy by Steve Langasek
Declined for Intrepid by Brian Murray
Jaunty
Wishlist
Unassigned

Bug Description

Binary package hint: gparted

 Ext4 is the next line in ext* filesystems. This has also been out since 2006! So I'm requesting support for this on 8.04.

Matti Lindell (mlind) on 2007-09-27
Changed in gparted:
importance: Undecided → Wishlist
description: updated
Changed in gparted:
status: New → Confirmed
Saivann Carignan (oxmosys) wrote :

Thanks for this bug report.

I've forwarded the bug upstream as this new feature only depends on Gparted developers. You can participate to this bug report from here :

http://bugzilla.gnome.org/show_bug.cgi?id=503112

Changed in gparted:
status: Confirmed → New
Changed in gparted:
status: Unknown → New

I'd like to see qtparted have this too, (and a few other things)

Changed in qtparted:
importance: Undecided → Wishlist
Kẏra (thekyriarchy) on 2008-08-11
Changed in gparted:
status: New → Confirmed
Kẏra (thekyriarchy) on 2008-08-12
Changed in qtparted:
status: New → Confirmed

Kernel 2.6.28 will have ext4 marked as stable (renamed from ext4dev->ext4, and the experimental note in config removed)

Changed in gparted:
status: New → Fix Released
Hew (hew) wrote :

Awesome. Marking Fix Committed, as this will be included with gparted 0.4.2.

Changed in gparted:
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Ubuntu's libparted now has the necessary support.

Colin Watson (cjwatson) wrote :

... and the relevant patch is in an upstream bug: http://parted.alioth.debian.org/cgi-bin/trac.cgi/ticket/188

parted (1.8.8.git.2008.03.24-11.1ubuntu2) jaunty; urgency=low

  * ext4.dpatch: Add skeletal ext4 support.
  * dm-null-target.dpatch: Fix segfault in case DM_DEVICE_TABLE returns no
    targets.

 -- Colin Watson <email address hidden> Thu, 08 Jan 2009 15:00:22 +0000

Dean Loros (autocrosser) wrote :

THANK YOU everyone!!!!

Dean Loros (autocrosser) wrote :

Hi Colin---

Shirish had a good idea (I think)--take a look at: http://ubuntuforums.org/showthread.php?t=1042329

Would syncing gnome svn to gparted make it easier or harder?

Shirish Agarwal (shirishag75) wrote :

actually should be easier, for there is lot of stuff ubuntu devs pull from gnome .

Although traditionally, I am guessing the devs look at debian, look at the bug-reports and then make a call when to sync with them.

In fact one of the prime examples of what I was talking about is brasero.

Which isn't yet part of GNOME (officially) but still the devs take
stuff from there.
--
          Regards,
          Shirish Agarwal
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Eric Appleman (erappleman) wrote :

I'd like to remind everyone that the lack of synchronization is absurd.

What's the point of ext4 if we can't even put an ext4-enabled build of Gparted on a livecd or liveusb of Ubuntu short of creating a custom iso. In addition to this, neither a ext4-enabled bootable livecd or liveusb image of Gparted Live even exists yet.

Why was ext4 implemented if there is no meaningful way of altering the partitions after the installation of Ubuntu?

hanasaki (hanasaki-ubuntu) wrote :

Have Intrepid Alpha 3 with all updates as of 2009-01-25. Do not see support for making an ext4 partition in gnome/partition manager. Also, as the ticket is written, is it "wishlist" or "fix committed" or "declined"

Steve Langasek (vorlon) wrote :

'fix committed' for an Ubuntu task implies that the fix is committed to an Ubuntu source repository or is in a developer's staging directory, not just that upstream has committed the fix. Rolling this back to triaged, since it still needs someone to shepherd that patch into jaunty.

Debian currently has gparted 0.4.1 in experimental, but Ubuntu only has 0.3.9 and also has some changes that would need to be merged. Merging this might be a good starting point on the way to 0.4.2 - is there an ETA for the 0.4.2 release?

Changed in gparted:
status: Fix Committed → Triaged
hanasaki (hanasaki-ubuntu) wrote :

will this also include the tools (like defrag / disk defragment)? If not, shall we get a ticket for those tools?

Shirish Agarwal (shirishag75) wrote :

Reply in-line :-

On Thu, Jan 29, 2009 at 10:18, hanasaki <email address hidden> wrote:
> will this also include the tools (like defrag / disk defragment)? If
> not, shall we get a ticket for those tools?

Hi all,
     AFAIK the defrag feature of ext4 is supposed to be done in
2.6.29.x series so don't think we are going to get that feature during
the jaunty cycle. Unless the developers prefer to have 2.6.29 in there
(which most probably is unlikely as not enough time for testing would
be there. )

Just my 2 paise.
--
          Regards,
          Shirish Agarwal
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

hanasaki (hanasaki-ubuntu) wrote :

Defrag is kernel support based? Or a user space utility only? It could be put in as a dummy package to be filled in by a Jaunty maintenance release. This is a pretty darn valuable function to leave out for another 6 months. http://lwn.net/Articles/302391/

Shirish Agarwal (shirishag75) wrote :

hanasaki,
 I had also read a similar patch set for 2.6.29 at http://lwn.net
about a fortnight or so.

Somebody should mark bug #321528 as a duplicate of this bug perhaps?
--
          Regards,
          Shirish Agarwal
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Shirish Agarwal (shirishag75) wrote :

hanasaki,
 here you go.

http://lwn.net/Articles/263315/

http://linux.derkeiler.com/Mailing-Lists/Kernel/2009-01/msg08829.html

http://www.gossamer-threads.com/lists/linux/kernel/1018448

There is possibility that it does become later but it depends on how
risky (or not) ubuntu developers feel it would be.

<flame>
Something such as defrag eating my ext4 data
</flame>

As it is people are experience ext4 data loss in another bug.

--
          Regards,
          Shirish Agarwal
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Shirish Agarwal (shirishag75) wrote :

Hi all,
       just another note, gparted got a new release. In fact 0.4.2 has
got ext4 support while jaunty uses 0.3.9 http://gparted.org/ and the
latest release 0.4.3 .

Also seems ext4 had some regressions or stuff which was worked upon
and released within last week itself.
--
          Regards,
          Shirish Agarwal
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

hanasaki (hanasaki-ubuntu) wrote :

So that leaves the question; "since juanty is still in Alpha, can the newer version of gparted be brought in?" With jaunty having mainstream support for ext4 (including in the installer) this would be very valuable instead of waiting another 6+ months for the next Ubuntu release.

Saivann Carignan (oxmosys) wrote :

According to the fact that debian has 0.4.1-2 in unstable and that they are on freeze, and since jaunty FeatureFreeze is tomorrow, that's a really good question. Ubuntu would have to break more than 2 years of merge from debian only for ext4 support.

At the same time, at the condition that it does not introduce important bugs, having the ability to install with ext4 but not to partition ext4 is not really polished and might be a good reason to consider it, though it's not really dramatic compared to serious filesystem issues (if such bugs exist in current gparted for ext4).

Dean Loros (autocrosser) wrote :

Well the bugs that exist in current gparted are that ext4 can not be worked with at all...I am running the gparted from debian unstable so I can work with ext4--I have found no problems with it & if we are to "really" use ext4, we need to do the "normal" things like resizing, creating & deletion. I know that FeatureFreeze is tomorrow, but shipping a broken gparted is not a feature--it is just broken--shipping a working with all current filesystems is a needed feature.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.4.3-0ubuntu1

---------------
gparted (0.4.3-0ubuntu1) jaunty; urgency=low

  [ Surfaz Gemon Meme, Colin Watson ]
  * New upstream release (LP: #305280)
    + Added support for ext4 file system (LP: #137872)
      - Support for ext4 is built into version 2.6.28 of the Linux kernel
      - e2fsprogs version 1.41.0 or higher required
    + Fixed bug in german translation (LP: #45449)
    + Fixed 'fails to recognize newly created swap partition'
      (LP: #137700, #114713)
    + Reduced file system information disk reads to improve performance
      (LP: #311470)
    + Fixed typo of "freedeskdesktop" in hal-lock name (LP: #37768)

  * debian/patches
    + dropped 05_GParted_Core.cc.diff, merged upstream
    + refreshed 10_dev_mapper.patch to be applied correctly
    + refreshed 01_fix-desktop.patch to be applied correctly

  * debian/control
    + Added intltool to Build-Depends

  * debian/rules
    + Added --with-help-dir= to build help manual in /usr/share/gnome/help

  * debian/watch
    + Fixed debian-watch-file-should-use-sf-redirector lintian warning.

 -- Surfaz Gemon Meme <email address hidden> Tue, 24 Feb 2009 13:16:44 +0000

Changed in gparted:
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

qtparted has been removed from Jaunty (see bug 329439), so I can't add ext4 support to it. Its replacement is partitionmanager, which has ext4 support in Jaunty.

In the course of looking into this, I noticed that kvpm also needs to have ext4 support added, and filed bug 335972 with a patch.

Changed in qtparted:
status: Confirmed → Won't Fix
status: Confirmed → Won't Fix
hanasaki (hanasaki-ubuntu) wrote :

Its a great thing to have the support in the package partitionmanager. Question: is there a Gnome based package / program that does the same thing? For those of us that run gnome and not KDE, it is quite desirable to not install all the KDE libs and a KDE specific program for functionality that really has nothing to do with the GUI. Just ends up being alot of extra disk and memory in use to load all that KDE stuff under a Gnome environment.

Hew (hew) wrote :

hanasaki: gparted

Denis Rut'kov (dendron2000) wrote :

Gparted support of ext4 is limited. It still does a sector-by-sector copy of ext4 partition in case of resizing as if it was an unsupported file system. Because of this it took more than 3 hours for me to finish resizing .

Hew (hew) wrote :

This bug is about adding ext4 support to Ubuntu, which has now been done. It's probably best to take up new issues in new bugs. Thanks.

Changed in gparted:
importance: Unknown → Medium
Phillip Susi (psusi) on 2013-11-11
Changed in gparted (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.