gpartedbin crashed with SIGABRT in g_assertion_message()

Bug #1376051 reported by Cristian Aravena Romero on 2014-09-30
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GParted
Expired
Critical
gparted (Ubuntu)
Critical
Unassigned
Utopic
Critical
Brian Murray

Bug Description

[Impact]

Program crashes or otherwise has erratic behavior when applying operations due to a cross thread write after free that was introduced in this upstream release. Upstream has already applied this fix after others discovered the issue and verified the fix.

[Test Case]

Apply various operations to disk, such as resizing and moving filesystems. Sometimes it works, sometimes it crashes. The original report below is an example of one way in which it may crash.

[Regression Potential]

Minimal; patch already upstream.

I'm working with vfat.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: gparted 0.19.0-1build1
ProcVersionSignature: Ubuntu 3.16.0-18.25-generic 3.16.3
Uname: Linux 3.16.0-18-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
Date: Tue Sep 30 20:35:28 2014
ExecutablePath: /usr/sbin/gpartedbin
InstallationDate: Installed on 2014-09-25 (5 days ago)
InstallationMedia: Ubuntu-GNOME 14.10 "Utopic Unicorn" - Alpha amd64 (20140923)
ProcCmdline: /usr/sbin/gpartedbin
Signal: 6
SourcePackage: gparted
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gpartedbin crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Changed in gparted (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in gparted:
importance: Unknown → Critical
status: Unknown → New
Mantas Kriaučiūnas (mantas) wrote :

Maybe this bug is fixed in the latest 0.19.1 version:

GParted 0.19.1 (2014-07-15) Release Notes

This release of GParted includes a critical bug fix for a potential crash. The crash is rare, but if the crash happens while applying operations then data loss might occur. Also included are language translation updates.

Key changes include:
    Prevent crash caused by cross thread write after free in _OnReadable()

Bug Fixes
    Prevent cross thread write after free in _OnReadable() (#731752)

Changed in gparted:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gparted (Ubuntu):
status: New → Confirmed
A. Eibach (andi3) wrote :

Uhhh, that's the 1build1 I have that too. (or better: got it installed by upgrading from Trusty to Utopic (final)

Unfortunately 0.19.1 is not available as a package for either Ubuntu nor its flavors. I've looked everywhere, including PPAs.

A. Eibach (andi3) wrote :

Additional info: Even though 0.18.x dumps out a MYRIAD of debug, warning AND error messages when started from console, it works fine. It was my life-saver when I urgently had to change a partition size.

Phillip Susi (psusi) wrote :

If you enable my ppa you should get an updated version with the fix applied. If you can confirm that it fixes this that would be helpful.

Curtis Gedak (gedakc) wrote :

Hi Phillip,

The most recent version of GParted I saw in the psusi PPA was 0.19.0-1-ubuntu1, not 0.19.1.

https://launchpad.net/~psusi/+archive/ubuntu/ppa

Recently on October 20th, GParted 0.20.0 was released.

Am I looking at the correct URL for the PPA for the most recent version of GParted?

Curtis

Phillip Susi (psusi) wrote :

That is correct; since it is an SRU, only the individual patch has been backported rather than upgrading to the new upstream release.

Curtis Gedak (gedakc) wrote :

Thank you Phillip for the clarification about only the fix being back-ported.

Phillip Susi (psusi) wrote :

Woops, that was the other bug...

description: updated
description: updated
A. Eibach (andi3) wrote :

Bingo, because I can confirm FOR SURE that 0.19.0-1-ubuntu1 does NOT include the fix for this _critical_ bug here at all!
Left to say, I'm sick and tired of finding the 0.19.0somethingbuildsomething crap everywhere.

*It* *is* *simply* *unuseable*. Full stop.

I had to move my butt to ubuntuupdates.org to get the 0.19.1 release, which works great, but is virtually unavailable elsewhere.
The same I can also recommend to you desperate users, for the waiting is really a little bit too long now.
How long are we still supposed to wait? Spring 2015 ??

This has nothing to do with impatience; the bug described in #1376051 is *SO* critical that I have to revert to 0.18.x otherwise.
PPA sometimes feels like a home for the elderly recently, needing dozens of nudges to get things going there...

Plus, a lot of those PPAs you'd find there are already available in the *standard* distros. However, people would usually move over to PPA to find packages *NOT YET* in distros. When one finds greatly the very same stuff in there again, there is no point of having a PPA to your disposal.

A. Eibach (andi3) wrote :

OK...I take it back...

The actual reason was that IDIOTIC and illogical naming.

I will never understand why a _fully published_ version of gparted in Utopic is called 0.19.0-1___build___1 and your still somewhat unofficial PPA-only version is called 0.19.0-1-___ubuntu___1.

Normally, the x.yy.z-p-ubuntuQ naming ought to be used for releases that are in the *standard* distribution, and not the PPA. It is always way better to indicate certain builds of packages coming from a PPA by using an appropriate filename (at least not the above one, that's for sure).
So JFTR, at the moment, 0.19.0-1build1 is the (non-working, crap) version shipped with Utopic, whilst 0.19.0-1ubuntu1 is the (working) PPA version. Just to get this clear for further readers running into this extremely time-consuming problem.

BTW sorry for the rude tone, but I've really wasted way too much pointless time with this stuff now, and that---may I quote the description---so-called "minor regression". I'd burst out laughing, if it wasn't so pathetic...? That oh-so "minor" regression will be enough for me for months again...

Mind you all of you, "essential tools with little bugs" and "essential tools that do not run at all" is not quite the same thing...
Lastly: YES 0.19.0-1ubuntu1 is the first version that works again since 0.18.x. Good Lord...don't get me started about the QA here therefore...

Phillip Susi (psusi) on 2014-12-15
Changed in gparted (Ubuntu):
status: Confirmed → In Progress
importance: Medium → Critical
Brian Murray (brian-murray) wrote :

Fixed in Vivid it seems:

gparted (0.19.0-2) unstable; urgency=medium

  * 03_fix-crash.patch: cherry pick of upstream commit that fixes
    a crash caused by a cross thread write after free.

 -- Phillip Susi <email address hidden> Sun, 09 Nov 2014 16:44:03 -0500

Changed in gparted (Ubuntu Utopic):
status: New → In Progress
importance: Undecided → Critical
Changed in gparted (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

[ubuntu/utopic-proposed] gparted 0.19.0-1ubuntu1 (Waiting for approval)

I've uploaded this to the utopic-proposed queue.

Changed in gparted:
status: Incomplete → Expired

Hello Cristian, or anyone else affected,

Accepted gparted into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gparted/0.19.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gparted (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gparted (Ubuntu Utopic):
assignee: nobody → Brian Murray (brian-murray)

The fix for this bug has been awaiting testing feedback in the -proposed repository for utopic for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
description: updated
A. Eibach (andi3) wrote :

to comment 18:
I am not so sure if the fix inside gparted will be enough.
I remember that even here on Vivid I had to manually "update" to libglibmm-2.4-1c2a (version 2.44).

The reason for this is that the significant fix was not applied yet in 2.43.x, but in 2.44 :
https://git.gnome.org/browse/glibmm/commit/?id=10e24926a149c8dbfbc5853b2d4ff5a4cd50bc4b

Unfortunately, nobody has ever thought about pushing 2.44 to the standard 'Buntu repos so far.

Rolf Leggewie (r0lf) wrote :

utopic has seen the end of its life and is no longer receiving any updates. Marking the utopic task for this ticket as "Won't Fix".

Changed in gparted (Ubuntu Utopic):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.