fails to recognize newly created swap partition

Bug #114713 reported by dn on 2007-05-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gparted

I worked around this but it was still strange. I'm running Feisty as a dual-boot with WinXP on Lenovo's Thinkpad T60, and at the time this happened my partitions were: NTFS, ext2,ext3,ext3, unallocated, linux-swap. I wanted to expand the swap partition left-ward, so I swapoff'd and tried resizing it. GParted immediately quit when the operation was apparently done, but when I opened it up it listed the newly sized partition as 'unknown'. Formatting it as a swap again didn't help. I rebooted; it still wouldn't recognize it; then, I reformatted it as ext2, then re-reformatted it as a swap, again, and now it recognizes it.

Adam Niedling (krychek) wrote :

Feisty is not supported anymore but I don't think it's safe to close this bug. I wonder if you could retest this issue with a later version of Ubuntu?

Changed in gparted:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.4.3-0ubuntu1

---------------
gparted (0.4.3-0ubuntu1) jaunty; urgency=low

  [ Surfaz Gemon Meme, Colin Watson ]
  * New upstream release (LP: #305280)
    + Added support for ext4 file system (LP: #137872)
      - Support for ext4 is built into version 2.6.28 of the Linux kernel
      - e2fsprogs version 1.41.0 or higher required
    + Fixed bug in german translation (LP: #45449)
    + Fixed 'fails to recognize newly created swap partition'
      (LP: #137700, #114713)
    + Reduced file system information disk reads to improve performance
      (LP: #311470)
    + Fixed typo of "freedeskdesktop" in hal-lock name (LP: #37768)

  * debian/patches
    + dropped 05_GParted_Core.cc.diff, merged upstream
    + refreshed 10_dev_mapper.patch to be applied correctly
    + refreshed 01_fix-desktop.patch to be applied correctly

  * debian/control
    + Added intltool to Build-Depends

  * debian/rules
    + Added --with-help-dir= to build help manual in /usr/share/gnome/help

  * debian/watch
    + Fixed debian-watch-file-should-use-sf-redirector lintian warning.

 -- Surfaz Gemon Meme <email address hidden> Tue, 24 Feb 2009 13:16:44 +0000

Changed in gparted:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers