gparted menu entry is not HIG compliant

Bug #114648 reported by Սահակ on 2007-05-14
18
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Undecided
Unassigned
gparted (Debian)
Fix Released
Unknown
gparted (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: gparted

gparted menu entry is not HIG compliant.
Here is the current menu entry:"
Name=GNOME Partition Editor
Comment=GNOME Partition Editor
"

According to HIG the word "GNOME" should not be included in the menu entry's name:
http://developer.gnome.org/projects/gup/hig/2.0/desktop-integration.html#menu-item-names
"Do not include words like "GNOME", "X Window System", "GTK+" or other platform details in Application menu names. The user probably already knows what platform they are using, and if they don't, then application names are not the right place to inform them."

Also according to HIG the tooltip (Comment field) should be phrased as an imperative verb.
http://developer.gnome.org/projects/gup/hig/2.0/desktop-integration.html#menu-item-tooltips

"GNOME Partition Editor" is not phrased as an imperative verb.

Changed in gparted:
status: Unknown → Unconfirmed
Changed in gparted:
status: New → Confirmed
Cesare Tirabassi (norsetto) wrote :

(note that the HIG is not a specification but a guideline).

The first concern (name field) is addressed in gutsy by patch 01_fix-desktop.patch
The above patch do not however address the second concern (comment field)

Note that in addition to the above, the .desktop file is not compliant to the freedesktop.org Desktop Entry Specification v1.0:

- the encode field is deprecated
- the icon should be extension-less
- Application is not a correct Category

Changed in gparted:
importance: Undecided → Wishlist
status: Confirmed → Triaged

I'm working on this

Changed in gparted:
assignee: nobody → mariobonino
Cesare Tirabassi (norsetto) wrote :

Mario,

please coordinate this with upstream.

This debdiff should fix this bug report; Cesare now I'm going to comment the gnome-bug, please check it out because I'm not sure to do it the right way. :)

It's better to wait and see if this patch is ok before doing that maybe.

Cesare Tirabassi (norsetto) wrote :

The debdiff looks good, I would just change the changelog to fit it in a 60-70 column range:

gparted (0.3.3-2ubuntu5) gutsy; urgency=low

  * Update debian/01_fix-desktop.patch to make it freedesktop.org
    and HIG compliant (LP: #114648):
    - Remove encoding field
    - Change Comment field to 'Manage your partitions'
    - Remove icon extension
    - Remove Application from list of Categories

 -- Mario Bonino <email address hidden> Tue, 25 Sep 2007 16:53:32 +0200

Can you forward the corrected patch (01_fix-desktop.patch) to debian and the correct desktop file to gparted?

If you want your patch to be sponsored in Ubuntu you should subscribe u-m-s (gparted is in main).

Changed in gparted:
status: Triaged → In Progress

Thanks for you commet Cesare, I have modified the debian/changelog file according to that. I hope this debdiff is ok. Now I'm going to forward the patch to Debian but when you say to forward the correct desktop file to gparted, you mean to send an e-mail to the maintainer with that ?

Daniel Holbach (dholbach) wrote :

Martin: as agreed on #ubuntu-devel, it'd be nice if you could take care of that in the next cycle - this is going to break translations.

Changed in gparted:
assignee: mariobonino → pitti
Cesare Tirabassi (norsetto) wrote :

Mario,

just add or paste the (patched) .desktop file in a comment in their tracker so that you give them the freedom on how they will use it.

Changed in gparted:
status: Unknown → New
Changed in gparted:
status: New → Fix Released
Սահակ (petrosyan) wrote :

Hello Mario,
In your Changelog you say:
- Change Comment field to 'Manage your partitions'
However in gparted-0.3.3-2ubuntu6 the Comment field is still: "GNOME Partition Editor"

Probably because Debian has not included Comment change.

Changed in gparted:
status: New → Fix Released
Changed in gparted:
status: Fix Released → Confirmed
Martin Pitt (pitti) on 2008-03-11
Changed in gparted:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.3.5-1ubuntu3

---------------
gparted (0.3.5-1ubuntu3) hardy; urgency=low

  * debian/patches/01_fix-desktop.patch: Fix comment field (LP: #114648)

 -- Martin Pitt <email address hidden> Tue, 11 Mar 2008 11:17:22 +0100

Changed in gparted:
status: Fix Committed → Fix Released
Սահակ (petrosyan) on 2008-04-22
Changed in gparted:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.