Changing line width in gpaint freezes X

Bug #209173 reported by Bang Malley on 2008-03-30
14
Affects Status Importance Assigned to Milestone
gpaint (Debian)
Fix Released
Unknown
gpaint (Ubuntu)
High
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: gpaint

I'm using Hardy.

the "line width" box is just empty. Clicking on it shows a new empty box below it.

version 0.3.3-1 is affected, but not 0.3.1-2 (gutsy)
-------
X freezes and gpaint needs to be killed from a virtual terminal.

jimmy smith (timmy-lea) wrote :

I confirm this. On my systems, selecting the Line Width dropdown causes X to freeze, and gpaint must then be manually killed from a virtual console before I can get control of the desktop again.

To repeat:

1. Install gpaint
2. Start a new drawing
3. Click the Line Width dropdown

Iva Deck (ivadeck) on 2008-07-04
description: updated
Iva Deck (ivadeck) on 2008-07-04
description: updated
Caroline Ford (secretlondon) wrote :

Confirming and high.

I also had to kill from a virtual terminal to get X back.

Changed in gpaint:
importance: Undecided → High
status: New → Confirmed
description: updated
Caroline Ford (secretlondon) wrote :

I've tried to get a stacetrace when it freezes but I've found it hard going. This is the best I have so far.

Changed in gpaint:
status: Unknown → New
bugmenot (bugmenot) wrote :

gutsy version works better than this. suggest downgrading.

bugmenot (bugmenot) wrote :

for those having this problem, downgrading to 3.1 works pretty well.

http://launchpadlibrarian.net/8318047/gpaint_0.3.1-2_i386.deb

Changed in gpaint:
status: New → Fix Released
Caroline Ford (secretlondon) wrote :

we need to get a sync from debian for this as they say they've fixed it.

Caroline Ford (secretlondon) wrote :

Bug #272795 is the sync request.

gpaint (0.3.3-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * debian/patches/20_fix_line_width_combo.dpatch: Add items to the
    line width combo box in gpaint.glade. Fixes the combo box grabbing
    the curser when clicked. Closes: #497484.
  * Patch configure in debian/rules to avoid rpath.
  * Fix debian/copyright.

Changed in gpaint:
status: Confirmed → Fix Released

This has been fixed in Intrepid, but it seems like it might make a good SRU for Hardy. Has anyone tried using the patch added by Debian on Hardy?

Fix for Hardy:

gpaint (0.3.3-1ubuntu0.1) hardy-proposed; urgency=low

  * debian/patches: backport fixes from Debian.
   - 10_fix_crash_on_font_select.dpatch (LP: #262889)
     http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497201
   - 11_fix_image_rotation.dpatch (LP: #262942)
     http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497487
   - 20_fix_line_width_combo.dpatch (LP: #209173)
     http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497484

Debs for testing can be found in my PPA: https://edge.launchpad.net/~andrewsomething/+archive

This also incorporates fixes from Bug #262889 and Bug #262942. These come from the not uploaded yet 0.3.3-2 revision of the package in Debian, but have been committed to Debian's git packaging branch. These are not yet in Intrepid. I have not yet packaged these for Intrepid as the new revision should hopefully hit Sid soon enough to sync directly. I'll set those bugs to "In Progress" and assign myself so if the sync is not ready I can prepare a package before Intrepid release.

0.3.3-2 is now in unstable. Sync bug filed here: Bug #277725

Martin Pitt (pitti) wrote :

Works fine for me and looks appropriate for this kind of "leaf" application. Sponsored.

Changed in gpaint:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

@pitti

Thanks for the upload. Could you please ACK the above mentioned sync request (Bug #277725) so that these fixes will be in Intrepid as well.

Martin Pitt (pitti) wrote :

Andrew, synced.

Martin Pitt (pitti) wrote :

Works fine for me now. Copied to hardy-updates.

Changed in gpaint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.