Ubuntu

Gpaint doesn't follow Menus & Toolbar system preferences

Reported by Fernando Muñoz on 2007-07-21
2
Affects Status Importance Assigned to Milestone
gpaint (Debian)
Fix Released
Unknown
gpaint (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gpaint

It seems like Gpaint toolbar uses a fixed style for button labels, and it doesn't follow settings from GNOME's Menus & Toolbar configurator. Gpaint only displays toolbar labels in 'Text below icon' style. In my opinion it should follow user preferences to create a more uniform desktop experience.

Caroline Ford (secretlondon) wrote :

Confirmed, wishlist.

Changed in gpaint:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gpaint:
status: Unknown → New
Changed in gpaint (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpaint - 0.3.3-6

---------------
gpaint (0.3.3-6) unstable; urgency=low

  * debian/patches/26_fix_toolbar.diff: don't set the style for the toolbar,
    allowing gpaint to follow the user's preferences (Closes: #497488)
    (LP: #127296)
  * debian/patches/21_fix_crash_on_fill_button_click.dpatch: fixed the check
    for null drawing_area.
  * debian/patches/*.dpatch: renamed to *.diff since we're not using dpatch
    anymore
  * debian/control: added ${misc:Depends} to the binary package Depends
  * debian/patches/*.diff: Added meta information tags compliant with DEP-3
    recommendations.

gpaint (0.3.3-5) unstable; urgency=low

  * debian/control:
    - Removed build-dependencies on libgnomeprint2.2-dev and
    libgnomeprintui2.2-dev
    - Added build-dependency on libgtk2.0-dev (>= 2.10) for using GtkPrint
    (Closes: #542569)
    - Removed spurious build-dependency on libgnomeui-dev
    - Bumped Standards-Version to 3.8.3 (no changes needed)
  * Updated debhelper compatibility level 7
    - debian/compat: changed to 7
    - debian/control: changed version of debhelper build-dependency to 7
  * Changed to 3.0 (quilt) source format
    - debian/source/format: added file with source format declaration
   - debian/rules: removed patch applying rules
   - debian/control: removed build-dependency on dpatch
    - debian/patches/00list: removed
    - debian/patches/04_update_pt_br_translation.dpatch: removed
    - debian/patches/*: updated so they apply cleanly with quilt
  * debian/patches/25_fix_color_selection.dpatch: Fix color selection through
    click in the foreground and background color indicators. (Closes: #497488)
    (LP: #344237)

gpaint (0.3.3-4) unstable; urgency=low

  [ Matt Wheeler ] (merged from Ubuntu)
  * debian/patches/23_add_accelerator_keys.dpatch:
    added various keyboard shortcuts (LP: #444750) (Closes: #550305)

  [ Goedson Teixeira Paixao ]
  * debian/patches/24_fix_crash_on_failed_write.dpatch:
    check if is possible to save in the format chosen by the user before
    trying to save. (LP: #386234)
 -- Bhavani Shankar <email address hidden> Mon, 11 Jan 2010 05:31:34 +0000

Changed in gpaint (Ubuntu):
status: Fix Committed → Fix Released
Changed in gpaint (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.