gpac version 0.4.5-0.3ubuntu8 failed to build on i386

Bug #749110 reported by Matthias Klose on 2011-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gpac (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

gpac version 0.4.5-0.3ubuntu8 compilation fails with following error:
cc: error: unrecognized option '--warn-common'

due to a typo on configure:
LDFLAGS="$LDFLAGS -Wl --warn-common"
which should be
LDFLAGS="$LDFLAGS -Wl,--warn-common"

Related branches

tags: added: oneiric
Changed in gpac (Ubuntu):
milestone: none → oneiric-alpha-1
Changed in gpac (Ubuntu Oneiric):
milestone: oneiric-alpha-1 → oneiric-alpha-2
Changed in gpac (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → none
status: New → Confirmed
tags: added: universe
Julian Taylor (jtaylor) wrote :

the no-add-needed build failure can't be reproduced anymore in oneiric, instead there is a failure due to a typo in configure

description: updated
tags: removed: natty no-add-needed
summary: - gpac version 0.4.5-0.3ubuntu7 failed to build on i386
+ gpac version 0.4.5-0.3ubuntu8 failed to build on i386
Julian Taylor (jtaylor) on 2011-07-08
tags: added: patch-accepted-upstream
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gpac - 0.4.5-0.3ubuntu9

---------------
gpac (0.4.5-0.3ubuntu9) oneiric; urgency=low

  * debian/patches/05_warn-common-typo.diff: (LP: #749110)
    - fix typo in ld option: s/-Wl --warn-common/-Wl,--warn-common/ configure
 -- Julian Taylor <email address hidden> Fri, 08 Jul 2011 19:59:47 +0200

Changed in gpac (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers