gpa version 0.9.0-1 failed to build in oneiric

Bug #831133 reported by Matthias Klose on 2011-08-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gpa (Debian)
Fix Released
Unknown
gpa (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

gpa version 0.9.0-1 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694842

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694842/+files/buildlog_ubuntu-oneiric-amd64.gpa_0.9.0-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 860 lines into the build log:

checking for inotify_init... yes
configure:
***
*** You need libassuan to build this program.
*** This library is for example available at
*** ftp://ftp.gnupg.org/gcrypt/libassuan/
*** (at least version 1.0.4 is required).
***
configure: error:
***
*** Required libraries not found. Please consult the above messages
*** and install them before running configure again.
***
make: *** [config.status] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110821-0454
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/gpa-0.9.0

Matthias Klose (doko) on 2011-08-22
Changed in gpa (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in gpa (Debian):
status: Unknown → New
Matthias Klose (doko) wrote :

needs a port to the LIBASSUAN_API 2, but the project seems to be dead upstream. removing and black-listing.

2011-09-23 10:31:09 INFO Removing candidates:
2011-09-23 10:31:09 INFO gpa 0.9.0-1 in oneiric
2011-09-23 10:31:09 INFO gpa 0.9.0-1 in oneiric amd64
2011-09-23 10:31:09 INFO gpa 0.9.0-1 in oneiric armel
2011-09-23 10:31:09 INFO gpa 0.9.0-1 in oneiric i386
2011-09-23 10:31:09 INFO gpa 0.9.0-1 in oneiric powerpc
2011-09-23 10:31:09 INFO Removed-by: Matthias Klose
2011-09-23 10:31:09 INFO Comment: FTFBS in oneiric, see LP: #831133, Debian #628305
2011-09-23 10:31:09 INFO 5 packages successfully removed.

Changed in gpa (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in gpa (Ubuntu):
status: Confirmed → Won't Fix
Changed in gpa (Debian):
status: New → Fix Committed
Changed in gpa (Debian):
status: Fix Committed → Fix Released

The last comment says "Fix Released" but released where? GPA is not in the oneric repo's.

On Thu, 01 Mar 2012 16:17:38 -0000, LanceHaverkamp wrote:

> The last comment says "Fix Released" but released where? GPA is not in
> the oneric repo's.

The last comment is:

| Changed in gpa (Debian):
| status: Fix Committed → Fix Released

So the fix is in Debian unstable and not yet in Ubuntu.

Cheers,
gregor

--
 .''`. Homepage: http://info.comodo.priv.at/ - OpenPGP key 0xBB3A68018649AA06
 : :' : Debian GNU/Linux user, admin, and developer - http://www.debian.org/
 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe
   `-

Andreas Moog (ampelbein) wrote :

The package has been completely removed from Debian and Ubuntu.

I agree that the status "Fix Released" can be misleading, but in this
case the status refers to the removal in comment +1 from doko.

Cheers,

 Andreas

Andreas Moog (ampelbein) wrote :

Erm, of course, gregor is right. It was removed from Oneiric, not Ubuntu in general. I jumped to conclusions, sorry for the noise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.