Google Earth fails to run when compiled with make-googleearth-package

Bug #682934 reported by Gareth Hart on 2010-11-30
This bug affects 12 people
Affects Status Importance Assigned to Milestone
googleearth-package (Debian)
Fix Released
googleearth-package (Ubuntu)
Adnan Hodzic
Clint Byrum
Clint Byrum

Bug Description

Binary package hint: googleearth-package

When I ran make-googleearth-package --force to install the new version of Google Earth which was released today, everything goes fine until I attempt to run the googleearth command to launch the application, at which case the following error message occurs in the terminal:

/usr/bin/googleearth: 14: /usr/lib/googleearth/googleearth-bin: not found

Even though the googleearth-bin binary is quite clearly inside the /usr/lib/googleearth directory.

I am using Kubuntu 64-bit Natty with googleearth-package 0.5.7.


=== IMPACT ===

With the release of the latest google earth, the generated package does not produce a package with the appropriate dependencies, so for most users, it will be useless and they will not know how to install the package until they google and find that they need to install the 'lsb-core' package.

=== DEV FIX ===

This was fixed in the Debian package, v0.6.0, by adding lsb-core to the list of dependencies for the generated package.

=== PATCH ===

See merge proposal for maverick.

=== TEST CASE: ===

# verify that lsb-core is not installed (dpkg -l lsb-core)
# install googleearth-package (apt-get install googleearth-package)
# build the package with 'make-googleearth-package --force'
# install the package and its dependencies (either with something like gdebi, or 'sudo dpkg -i file.deb ; sudo apt-get -f install'
# run googleearth

The broken packages will not have installed lsb-core, and will fail with

$ googleearth
/usr/bin/googleearth: 14: /usr/lib/googleearth/googleearth-bin: not found

But a working package will run google earth properly.


Adding a dependency could erroneously install lsb-core in a place where it is not needed, but otherwise I don't see any danger.

Related branches

OberonKing (oberonking) wrote :

Same issue here.... Ubuntu 10.10 64-bit

$ googleearth
/usr/bin/googleearth: 14: /usr/lib/googleearth/googleearth-bin: not found

The file it's in that place

OberonKing (oberonking) wrote :

This solves my problems

$ sudo apt-get install lsb-core

After install this, run like a charm.

Gareth Hart (tghe-retford) wrote :

I can verify that OberonKing's lsb-core install fix does work. Just puzzled now at what changed between version 5 and version 6 to require that package to be installed.

Clint Byrum (clint-fewbar) wrote :

This was fixed upstream in Debian, v0.6.0, just a few days ago. As such, this is fixed in natty.

Adding link to Debian bug report, and marking Triaged + High in Ubuntu, nominating for Maverick and Lucid (it would be great if a Lucid user could report confirming the bug in Lucid).

Changed in googleearth-package (Ubuntu):
status: New → Triaged
importance: Undecided → High
Clint Byrum (clint-fewbar) wrote :

Correction, I do not have rights to nominate for Lucid/Maverick, but it should be

Natty => Fix Released
Maverick => Triaged, High
Lucid => ?,?

description: updated
Changed in googleearth-package (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
Changed in googleearth-package (Ubuntu):
status: Triaged → Fix Released
Changed in googleearth-package (Ubuntu Maverick):
status: Triaged → Fix Committed
Meghan Anderson (kheila) wrote :

Confirmed in Lucid -- followed the test steps, results were exactly as described.

Changed in googleearth-package (Ubuntu Lucid):
status: New → Confirmed
Clint Byrum (clint-fewbar) wrote :

I just tried out the maverick proposed package on maverick-amd64 and lucid-amd64 chroots. With the removal of ia32-libs from the package, make-googleearth-package does not work at all.

I would suggest that maybe this package can't be Architecture: all, but this is going beyond my current knowledge of how to do architecture specific dependencies.

Either way, the current proposed package should not be released into maverick-updates.

Changed in googleearth-package (Ubuntu Lucid):
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in googleearth-package (Ubuntu Maverick):
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in googleearth-package (Ubuntu Lucid):
status: Confirmed → In Progress
Stefano Rivera (stefanor) wrote :

It hasn't made it into proposed yet, I'll request rejection on IRC

Adnan Hodzic (fooctrl) wrote :

This problem has been resolved in 0.6.x which is in Natty and in Debian unstable.

Martin Pitt (pitti) wrote :

There is no such package upload in the lucid queue; perhaps someone already rejected it.

Adnan Hodzic (fooctrl) wrote :

No idea what's happening with Lucid, only Ubuntu I see 0.6.x in is in *Natty*

Adnan Hodzic (fooctrl) wrote :


I just backported latest (0.6.1) version for Ubuntu 10.04 (Lucid Lynx) and up, please try the following PPA:

Changed in googleearth-package (Debian):
status: Unknown → Fix Released
tags: added: testcase
Adnan Hodzic (fooctrl) on 2011-10-05
Changed in googleearth-package (Ubuntu):
assignee: nobody → Adnan Hodzic (absinthesyringe)
JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bugtask for Maverick. Please upgrade to a newer version of Ubuntu.
More information here:

Changed in googleearth-package (Ubuntu Maverick):
status: Fix Committed → Invalid

Affects Ubuntu 12.10 (Quantal Quetzal), but broken dependencies are fixed with "sudo apt-get -f install":
sudo apt-get install googleearth-package
make-googleearth-package --force
sudo dpkg -i googleearth*.deb
sudo apt-get -f install

Complete terminal output attachment: make-googleearth-package_--force_Ubuntu_12.10

Hi Christopher (2012.10.22_00:01:46_+0200)
> make-googleearth-package --force
> sudo dpkg -i googleearth*.deb
> sudo apt-get -f install

I'd say that's entirely expected. Not a bug at all. Although maybe
make-googleearth-package should tell you that you'll have to run apt-get
-f install...

Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in googleearth-package (Ubuntu Lucid):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.