Another crash happened while handling crash

Bug #1559489 reported by Weiller on 2016-03-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
googleearth-package (Ubuntu)
Undecided
Unassigned

Bug Description

Major Version 7
Minor Version 1
Build Number 0004
Build Date Mar 30 2015
Build Time 22:42:31
OS Type 3
OS Major Version 4
OS Minor Version 4
OS Build Version 0
OS Patch Version 0
Crash Signal 11
Crash Time 1458402156
Up Time 1,58566

Stacktrace from glibc:
./libgoogleearth_free.so(+0x23924c)[0x7fb47d9f324c]
./libgoogleearth_free.so(+0x2394ad)[0x7fb47d9f34ad]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x10cd0)[0x7fb47e6d2cd0]
[0x7fb37eaff030]

weiller@weiller-POS-MA760GCP:~$ google-earth
[0319/125927:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0319/125927:ERROR:x509_certificate_nss.cc(730)] CERT_PKIXVerifyCert for www.google.com failed err=-8181
[0319/125927:ERROR:x509_certificate_nss.cc(730)] CERT_PKIXVerifyCert for kh.google.com failed err=-8181
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:x509_certificate_nss.cc(730)] CERT_PKIXVerifyCert for accounts.google.com failed err=-8181
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:x509_certificate_nss.cc(730)] CERT_PKIXVerifyCert for support.google.com failed err=-8181
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125927:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125928:WARNING:backend_impl.cc(1875)] Destroying invalid entry.
[0319/125928:WARNING:backend_impl.cc(1875)] Destroying invalid entry.
[0319/125928:ERROR:x509_certificate_nss.cc(730)] CERT_PKIXVerifyCert for mw1.google.com failed err=-8181
[0319/125928:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125928:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125928:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125928:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0319/125928:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.

Another crash happened while handling crash!

weiller@weiller-POS-MA760GCP:~$ lsb_release -rd
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04

weiller@weiller-POS-MA760GCP:~$ apt-cache policy google-earth-stable
google-earth-stable:
  Instalado: 7.1.4.1529-r0
  Candidato: 7.1.4.1529-r0
  Tabela de versão:
 *** 7.1.4.1529-r0 100
        100 /var/lib/dpkg/status
     6.0.3.2197-r0 500
        500 http://dl.google.com/linux/earth/deb stable/main amd64 Packages

What you expected to happen?
I hope it opens normally when I click the icon to open it and not start to open and then close out of nowhere.

What happened instead?
He opened and closed nothing without displaying the globe and settings. Then I started it with a terminal command, for me to see what would be the line of code that would get out about this error which is doing what it does not open properly. The output terminal and the file located in /home/weiller/.googleearth/crashlogs/, I posted here to help solve this problem at application startup.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in googleearth-package (Ubuntu):
status: New → Confirmed
JMB (jmb-tux) wrote :

It is sad but the situation becomes worse with the upcoming Xubuntu Xenial Xerus 16.04 LTS release:
Bug #1562948
Till Werewolf, the installation was problematic (as explained Bug #1314993 or Bug #1241816) and
google-earth unstable (frequent crashes: as reported here - or mislead location: Bug # 1196703).
Now, even installation left inconvenient range ... maybe time for a change of this miserable situation.
JMB

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers