google-earth builds 32 bit binary which fails on amd64

Bug #1362357 reported by Ian Kelling on 2014-08-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
googleearth-package (Ubuntu)
Undecided
Unassigned

Bug Description

result of installing the package built make-

$ sudo dpkg -i googleearth_6.0.3.2197+1.1.0-1_amd64.deb
Selecting previously unselected package googleearth.
(Reading database ... 385522 files and directories currently installed.)
Preparing to unpack googleearth_6.0.3.2197+1.1.0-1_amd64.deb ...
Unpacking googleearth (6.0.3.2197+1.1.0-1) ...
dpkg: dependency problems prevent configuration of googleearth:
 googleearth depends on libfreeimage3; however:
  Package libfreeimage3 is not installed.
 googleearth depends on lsb-core; however:
  Package lsb-core is not installed.
 googleearth depends on libcurl3:i386; however:
 googleearth depends on libsm6:i386; however:
 googleearth depends on libfontconfig1:i386; however:
 googleearth depends on libxt6:i386; however:
 googleearth depends on libxrender1:i386; however:
 googleearth depends on libxext6:i386; however:
 googleearth depends on libgl1-mesa-glx:i386; however:
 googleearth depends on libgl1-mesa-dri:i386; however:

dpkg: error processing package googleearth (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Errors were encountered while processing:
 googleearth

(exit code of 1)

But it still installed the googleearth binary at least, but running it, thiis error occurs

$ googleearth
/usr/bin/googleearth: 14: /usr/bin/googleearth: /usr/lib/googleearth/googleearth-bin: not found

(exit code 127)

it appears this is because it is a 32 bit binary:
file /usr/lib/googleearth/googleearth-bin
/usr/lib/googleearth/googleearth-bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, BuildID[sha1]=ecf12dc9139e39775445913de6c50bae908a6d1a, stripped

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in googleearth-package (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers